aboutsummaryrefslogtreecommitdiff
path: root/mail/enigmail-thunderbird
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-01-15 19:34:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-01-15 19:34:13 +0000
commit07c7a5819633ed6a5f745426fc6bd064c7b1204b (patch)
tree91e4d2533deac9b55232b893e6d06803c53cda0b /mail/enigmail-thunderbird
parentffd6d3a59f465a788ddf483d53c2d4dac2fb8799 (diff)
downloadports-07c7a5819633ed6a5f745426fc6bd064c7b1204b.tar.gz
ports-07c7a5819633ed6a5f745426fc6bd064c7b1204b.zip
Update to 0.94.0 release (compatible with TB 1.5).
Now the extension doesn't global register itself, instead the user should manually install the generated XPI file into his own profile.
Notes
Notes: svn path=/head/; revision=153585
Diffstat (limited to 'mail/enigmail-thunderbird')
-rw-r--r--mail/enigmail-thunderbird/Makefile65
-rw-r--r--mail/enigmail-thunderbird/distinfo3
-rw-r--r--mail/enigmail-thunderbird/pkg-deinstall8
-rw-r--r--mail/enigmail-thunderbird/pkg-descr13
-rw-r--r--mail/enigmail-thunderbird/pkg-install14
-rw-r--r--mail/enigmail-thunderbird/pkg-message7
6 files changed, 77 insertions, 33 deletions
diff --git a/mail/enigmail-thunderbird/Makefile b/mail/enigmail-thunderbird/Makefile
index aa2fca11ac4a..65a3a6e8d2c4 100644
--- a/mail/enigmail-thunderbird/Makefile
+++ b/mail/enigmail-thunderbird/Makefile
@@ -5,21 +5,64 @@
# $FreeBSD$
#
-PKGNAMESUFFIX= -thunderbird
+PORTNAME= enigmail
+PORTVERSION= 0.94.0
+CATEGORIES= mail security
+MASTER_SITES= http://www.mozilla-enigmail.org/downloads/src/
+PKGNAMEPREFIX?= thunderbird-
-COMMENT= A GnuPG extension for the Thunderbird mail client
+MAINTAINER= ale@FreeBSD.org
+COMMENT?= A GnuPG extension for the Thunderbird mail client
-EXTRACT_DEPENDS=${WRKDIR}/../../../${LOCAL_SRCDIR}/work/mozilla/Makefile:${PORTSDIR}/${LOCAL_SRCDIR}:configure
-RUN_DEPENDS= thunderbird:${PORTSDIR}/${LOCAL_SRCDIR}
+EXTRACT_DEPENDS=${GECKO_WRKSRC}/Makefile:${PORTSDIR}/${GECKO_PORTDIR}:configure
+LIB_DEPENDS= nspr4:${PORTSDIR}/devel/nspr
+RUN_DEPENDS= ${GECKO}:${PORTSDIR}/${GECKO_PORTDIR} \
+ gpg:${PORTSDIR}/security/gnupg
-MASTERDIR= ${.CURDIR}/../enigmail
+GECKO= ${PKGNAMEPREFIX:S/-//}
+.if ${GECKO} == "thunderbird"
+GECKO_PORTDIR= mail/${GECKO}
+.else
+GECKO_PORTDIR= www/${GECKO}
+.endif
+GECKO_WRKSRC= ${WRKDIR}/../../../${GECKO_PORTDIR}/work/mozilla
+WRKSRC= ${WRKDIR}/mozilla
-BROKEN= "enigmail cannot be installed as global extension in TB 1.5 anymore"
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GNOME= gtk20 libidl
-PKGINSTALL= ${.CURDIR}/pkg-install
-PKGDEINSTALL= ${.CURDIR}/pkg-deinstall
+XPI_FILE= ${DISTNAME}-${GECKO}-freebsd-${ARCH}.xpi
+PLIST_FILES= %%DATADIR%%/${XPI_FILE}
+PLIST_DIRS= %%DATADIR%%
-LOCAL_SRCDIR= mail/thunderbird
-LOCAL_SUBDIR= lib/thunderbird
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${CP} -R ${GECKO_WRKSRC} ${WRKSRC}
+ @for f in ${EXTRACT_ONLY}; do \
+ cd ${WRKSRC}/mailnews/extensions && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$f ${EXTRACT_AFTER_ARGS}; \
+ done
-.include "${MASTERDIR}/Makefile"
+pre-patch:
+ @${REINPLACE_CMD} -e "s|${GECKO_PORTDIR}|mail/enigmail-${GECKO}|g" \
+ `${FIND} ${WRKSRC} -name autoconf.mk`
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} export)
+ @(cd ${WRKSRC}/modules/libreg; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
+ @(cd ${WRKSRC}/xpcom/string; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
+ @(cd ${WRKSRC}/xpcom; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
+ @(cd ${WRKSRC}/xpcom/obsolete; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
+ @(cd ${WRKSRC}/mailnews/extensions/enigmail; ./makemake -r; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS});
+ @(cd ${WRKSRC}/mailnews/extensions/enigmail; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} xpi);
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/bin/${DISTNAME}-freebsd-${ARCH}.xpi ${DATADIR}/${XPI_FILE}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/enigmail-thunderbird/distinfo b/mail/enigmail-thunderbird/distinfo
new file mode 100644
index 000000000000..2d72c3541174
--- /dev/null
+++ b/mail/enigmail-thunderbird/distinfo
@@ -0,0 +1,3 @@
+MD5 (enigmail-0.94.0.tar.gz) = d326c302c1d2d68217fffcaa01ca7632
+SHA256 (enigmail-0.94.0.tar.gz) = db2b5fc014fe5efef95fc46804ac609616557b1696d5f355d2d7641e567904f3
+SIZE (enigmail-0.94.0.tar.gz) = 508113
diff --git a/mail/enigmail-thunderbird/pkg-deinstall b/mail/enigmail-thunderbird/pkg-deinstall
deleted file mode 100644
index 08be91f913b2..000000000000
--- a/mail/enigmail-thunderbird/pkg-deinstall
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-if test "$2" = "POST-DEINSTALL"; then
-FILE=${PKG_PREFIX}/lib/thunderbird/chrome/installed-chrome.txt
-cp ${FILE} ${FILE}.orig
-cat ${FILE}.orig | grep -v enigmime | grep -v enigmail > ${FILE}
-rm ${FILE}.orig
-fi
diff --git a/mail/enigmail-thunderbird/pkg-descr b/mail/enigmail-thunderbird/pkg-descr
new file mode 100644
index 000000000000..d3a91c99f9bb
--- /dev/null
+++ b/mail/enigmail-thunderbird/pkg-descr
@@ -0,0 +1,13 @@
+Enigmail is an extension to the Thunderbird / Seamonkey mail client
+which allows users to access the authentication and encryption features
+provided by the popular GnuPG software.
+
+Enigmail can encrypt/sign mail when sending, and also decrypt/authenticate
+received mail. It can also import/export public keys. Enigmail supports
+both the inline PGP format, and the PGP/MIME format (RFC 3156), which can
+be used to encrypt attachments.
+
+WWW: http://enigmail.mozdev.org/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/mail/enigmail-thunderbird/pkg-install b/mail/enigmail-thunderbird/pkg-install
deleted file mode 100644
index a55f8759cc88..000000000000
--- a/mail/enigmail-thunderbird/pkg-install
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-if test "$2" = "POST-INSTALL"; then
-cat << EOF >> ${PKG_PREFIX}/lib/thunderbird/chrome/installed-chrome.txt
-skin,install,url,jar:resource:/chrome/enigmime.jar!/content/enigmime/
-locale,install,url,jar:resource:/chrome/enigmime.jar!/content/enigmime/
-content,install,url,jar:resource:/chrome/enigmime.jar!/content/enigmime/
-skin,install,url,jar:resource:/chrome/enigmail.jar!/content/enigmail/
-locale,install,url,jar:resource:/chrome/enigmail.jar!/content/enigmail/
-content,install,url,jar:resource:/chrome/enigmail.jar!/content/enigmail/
-skin,install,url,jar:resource:/chrome/enigmail-skin-tbird.jar!/skin/classic/enigmail/
-locale,install,url,jar:resource:/chrome/enigmail.jar!/locale/en-US/enigmail/
-EOF
-fi
diff --git a/mail/enigmail-thunderbird/pkg-message b/mail/enigmail-thunderbird/pkg-message
new file mode 100644
index 000000000000..8ec572dc6bca
--- /dev/null
+++ b/mail/enigmail-thunderbird/pkg-message
@@ -0,0 +1,7 @@
+*****************************************************************************
+In order to activate the Enigmail extension, every user should install the
+XPI file into his own profile via the menu:
+
+Tools -> Extensions -> Install
+
+*****************************************************************************