aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-devel
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2002-02-13 05:03:22 +0000
committerAde Lovett <ade@FreeBSD.org>2002-02-13 05:03:22 +0000
commit90be146649bee1eaf62ffa7f25c786e571b9a722 (patch)
tree20e2a6debbd784f37ec9d38c6abb20a54f02953e /mail/evolution-devel
parent1d25b2294bb9a220d8a3ef9dda5d5394ec684213 (diff)
downloadports-90be146649bee1eaf62ffa7f25c786e571b9a722.tar.gz
ports-90be146649bee1eaf62ffa7f25c786e571b9a722.zip
Add OpenLDAP2 support if WITH_LDAP is defined - this is a candidate for
turning into a WITHOUT_LDAP switch to abide by accepted GNOME bloatware standards. PR: 32838 Submitted by: Joe Marcus Clarke <marcus@marcuscom.com>
Notes
Notes: svn path=/head/; revision=54647
Diffstat (limited to 'mail/evolution-devel')
-rw-r--r--mail/evolution-devel/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/mail/evolution-devel/Makefile b/mail/evolution-devel/Makefile
index e3bd363d2e29..cb5052f20f98 100644
--- a/mail/evolution-devel/Makefile
+++ b/mail/evolution-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= http://www.sleepycat.com/update/3.1.17/:db \
${MASTER_SITE_GNOME}
@@ -18,15 +19,15 @@ MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf \
nss3.1:${PORTSDIR}/security/nss
-# ldap.2:${PORTSDIR}/net/openldap2
+.if defined(WITH_LDAP}
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+.endif
RUN_DEPENDS= gnome-spell-component:${PORTSDIR}/textproc/gnomespell
.if !defined(WITHOUT_PILOT)
BUILD_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
RUN_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
.endif
-#BROKEN= "Out of sync with latest gal"
-
USE_GMAKE= yes
USE_BISON= yes
USE_X_PREFIX= yes
@@ -40,7 +41,11 @@ CONFIGURE_ARGS= --with-db3-libs=${DB3_WRKSRC} \
--with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/security \
--with-nss-libs=${LOCALBASE}/lib
-# --with-openldap=${LOCALBASE}
+
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
+.endif
+
.if !defined(WITHOUT_PILOT)
CONFIGURE_ARGS+= --with-pisock=${LOCALBASE} \
--enable-pilot-conduits=yes