aboutsummaryrefslogtreecommitdiff
path: root/mail/exilog/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-05-15 13:27:30 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-05-15 13:27:30 +0000
commitea42e87bab0ad8cf32c20f267005fec1ec2ab5f7 (patch)
treed386881b6be0cbe96d36938e3e1ee3708d675da7 /mail/exilog/Makefile
parent1d988b45cfef0a5a487963e457e16bdb83924acb (diff)
downloadports-ea42e87bab0ad8cf32c20f267005fec1ec2ab5f7.tar.gz
ports-ea42e87bab0ad8cf32c20f267005fec1ec2ab5f7.zip
- Fix PostgreSQL support
- Pet portlint - Unquote BROKEN message - Use modern USE_RC_SUBR style PR: ports/97213 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=162438
Diffstat (limited to 'mail/exilog/Makefile')
-rw-r--r--mail/exilog/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/mail/exilog/Makefile b/mail/exilog/Makefile
index 765b3a8c0fb9..185ee305e6da 100644
--- a/mail/exilog/Makefile
+++ b/mail/exilog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exilog
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://duncanthrax.net/exilog/
@@ -29,9 +29,9 @@ WITH_MYSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.elif (${WITH_SQL_BACKEND} == "postgresql")
WITH_POSTGRESQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.else
-BROKEN= "You should specify sql backend using WITH_SQL_BACKEND"
+BROKEN= You should specify sql backend using WITH_SQL_BACKEND
.endif
.ifndef WITHOUT_WWWDIR
@@ -43,7 +43,7 @@ EXILOGDIR?= ${PREFIX}/exilog
.if defined(NO_AGENT)
PLIST_SUB+= AGENT="@comment "
.else
-USE_RC_SUBR= yes
+USE_RC_SUBR= exilog.sh
PLIST_SUB+= AGENT=""
.endif
@@ -60,15 +60,13 @@ pre-patch:
@${REINPLACE_CMD} -e 's,$$RealBin/exilog.conf,${PREFIX}/etc/exilog.conf,' ${WRKSRC}/exilog_config.pm
@${REINPLACE_CMD} -e "s,\(use exilog_config\),use lib \'${EXILOGDIR}\'; \1," ${WRKSRC}/exilog_agent.pl
@${REINPLACE_CMD} -e "s,\(use exilog_config\),use lib \'${EXILOGDIR}\'; \1," ${WRKSRC}/exilog_cleanup.pl
- @${SED} -e 's,%%RC_SUBR%%,${RC_SUBR},' \
- -e 's,%%PREFIX%%,${PREFIX},' ${FILESDIR}/exilog.sh > ${WRKDIR}/exilog.sh
do-install:
@${MKDIR} ${EXILOGDIR}
@${MKDIR} ${EXILOGDIR}/icons
@${CP} ${WRKSRC}/*.pm ${WRKSRC}/*.css ${WRKSRC}/*.js ${EXILOGDIR}
@${CP} ${WRKSRC}/icons/* ${EXILOGDIR}/icons
-
+
.if !defined(NO_AGENT)
@${INSTALL_SCRIPT} ${WRKSRC}/exilog_agent.pl ${PREFIX}/sbin
.endif