aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2003-08-18 17:19:58 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2003-08-18 17:19:58 +0000
commit397db8d46b04f848c992872a6ac09952b715e06a (patch)
treea10120df0adc0a6a65c274ada48ccb8f4a4ec227 /mail/exim
parent7228877fdc58b1dcd9f47fe567f057566d18ed31 (diff)
downloadports-397db8d46b04f848c992872a6ac09952b715e06a.tar.gz
ports-397db8d46b04f848c992872a6ac09952b715e06a.zip
Update to exim-4.22:
* IPv6 bug fix incorporated. * Catch up with changes in makefiles. * Make portlint happier with respect to DOCSDIR, INFO and spaces. * Use the new INFO macro. * Use PATCHFILES instead of patching by hand, now that we don't support the non-ACL exiscan patch. This release fixes a few last minute release mistakes from 4.21. PR: ports/55701 Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com>
Notes
Notes: svn path=/head/; revision=87219
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile37
-rw-r--r--mail/exim/distinfo4
-rw-r--r--mail/exim/files/patch-OS::Makefile-FreeBSD4
-rw-r--r--mail/exim/files/patch-src::EDITME39
-rw-r--r--mail/exim/files/patch-src::os.c19
-rw-r--r--mail/exim/pkg-plist32
6 files changed, 55 insertions, 80 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 2abde4cffdfb..b4b66e7bc533 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,20 +7,18 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
-PORTREVISION= 2
CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_EXIM} \
- http://duncanthrax.net/%SUBDIR%/:exiscan_acl
-MASTER_SITE_SUBDIR= exim4 exiscan-acl/:exiscan_acl
+MASTER_SITES= ${MASTER_SITE_EXIM}
+MASTER_SITE_SUBDIR= exim4
DISTFILES= exim-${EXIM_VERSION}${EXTRACT_SUFX} \
exim-texinfo-${EXIM_DOCVERSION}${EXTRACT_SUFX}
-.if !defined(WITHOUT_EXISCAN)
-DISTFILES+= exiscan-acl-${EXISCAN_ACL_VERSION}.patch.bz2:exiscan_acl
-.endif
DIST_SUBDIR= exim
-EXTRACT_ONLY= exim-${EXIM_VERSION}${EXTRACT_SUFX} \
- exim-texinfo-${EXIM_DOCVERSION}${EXTRACT_SUFX}
+.if !defined(WITHOUT_EXISCAN)
+PATCH_SITES= http://duncanthrax.net/%SUBDIR%/
+PATCH_SITE_SUBDIR= exiscan-acl
+PATCHFILES= exiscan-acl-${EXISCAN_ACL_VERSION}.patch.bz2
+.endif
MAINTAINER= sheldonh@FreeBSD.org
COMMENT= High performance MTA for Unix systems on the Internet
@@ -30,17 +28,20 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_BZIP2= yes
USE_PERL5= yes
MAN8= exim.8
+INFO= exim exim_filter
-EXIM_VERSION= 4.21
+EXIM_VERSION= 4.22
EXIM_DOCVERSION= 4.20
EXISCAN_ACL_VERSION= ${EXIM_VERSION}-10
-PLIST_SUB+= EXIM_VERSION="${EXIM_VERSION}"
+PLIST_SUB+= EXIM_VERSION="${EXIM_VERSION}"
.if defined(NOPORTDOCS)
PKGMESSAGE= ${WRKDIR}/POST-INSTALL-NOTES
.endif
+PATCH_DIST_STRIP= -p1
+
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH} LOCALBASE=${LOCALBASE}
POSTGRESQL_PORT?= databases/postgresql7
@@ -137,9 +138,9 @@ PORTDOC_FILES= Exim3.upgrade Exim4.upgrade OptionLists.txt README \
spec.txt
.if !defined(WITHOUT_EXISCAN)
PORTDOC_FILES+= exiscan-acl-examples.txt exiscan-acl-spec.txt
-PLIST_SUB+= EXISCAN_ACL=""
+PLIST_SUB+= EXISCAN_ACL=""
.else
-PLIST_SUB+= EXISCAN_ACL="@comment "
+PLIST_SUB+= EXISCAN_ACL="@comment "
.endif
.if ${OSVERSION} < 400014
@@ -320,8 +321,6 @@ pre-everything::
post-patch:
.if !defined(WITHOUT_EXISCAN)
- ${BZCAT} ${DISTDIR}/${DIST_SUBDIR}/exiscan-acl-${EXISCAN_ACL_VERSION}.patch.bz2 \
- | ${PATCH} -d ${WRKSRC} -p1 > ${WRKDIR}/patch-exiscan-acl.log 2>&1
@${CAT} ${FILESDIR}/POST-INSTALL-NOTES.exiscan-acl \
${FILESDIR}/POST-INSTALL-NOTES > ${WRKDIR}/POST-INSTALL-NOTES
.else
@@ -342,13 +341,13 @@ pre-install:
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/exim.sh ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/exim
- ${INSTALL_DATA} ${WRKDIR}/POST-INSTALL-NOTES ${PREFIX}/share/doc/exim
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/POST-INSTALL-NOTES ${DOCSDIR}
.for file in ${PORTDOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/exim
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
.for file in ${MAN8}
- ${INSTALL_MAN} ${WRKSRC}/doc/${file} ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/doc/${file} ${MAN8PREFIX}/man/man8
.endfor
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 2bfabcb5044d..2708870419b8 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,3 +1,3 @@
-MD5 (exim/exim-4.21.tar.bz2) = 16b1290e4c289c7d70294ca447b0a3bc
+MD5 (exim/exim-4.22.tar.bz2) = 938ae799c08ed1899dd27fd50d48f4e5
MD5 (exim/exim-texinfo-4.20.tar.bz2) = debc6d3fdd88fd6d9c646ca0495fa92d
-MD5 (exim/exiscan-acl-4.21-10.patch.bz2) = b22d3ed3e132ea11069b89ae4269f493
+MD5 (exim/exiscan-acl-4.22-10.patch.bz2) = 239fb3db3eeb5da7c816ce2765b5db2a
diff --git a/mail/exim/files/patch-OS::Makefile-FreeBSD b/mail/exim/files/patch-OS::Makefile-FreeBSD
index 59769cfb40f7..aefbb83fcb6a 100644
--- a/mail/exim/files/patch-OS::Makefile-FreeBSD
+++ b/mail/exim/files/patch-OS::Makefile-FreeBSD
@@ -1,12 +1,12 @@
--- OS/Makefile-FreeBSD.orig Tue Aug 12 17:39:51 2003
+++ OS/Makefile-FreeBSD Thu Aug 14 12:10:46 2003
-@@ -5,12 +5,16 @@
+@@ -5,11 +5,16 @@
PORTOBJFORMAT!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout
CHOWN_COMMAND=/usr/sbin/chown
+STRIP_COMMAND=/usr/bin/strip
- HAVE_ICONV=yes
++HAVE_ICONV=yes
HAVE_SA_LEN=YES
# crypt() is in a separate library
diff --git a/mail/exim/files/patch-src::EDITME b/mail/exim/files/patch-src::EDITME
index dc7ff7373dbd..a6e48c5f2579 100644
--- a/mail/exim/files/patch-src::EDITME
+++ b/mail/exim/files/patch-src::EDITME
@@ -1,5 +1,5 @@
---- src/EDITME.orig Mon Jul 22 10:59:47 2002
-+++ src/EDITME Mon Sep 16 11:33:03 2002
+--- src/EDITME.orig Mon Aug 18 14:52:52 2003
++++ src/EDITME Mon Aug 18 17:34:17 2003
@@ -98,7 +98,7 @@
# /usr/local/sbin. The installation script will try to create this directory,
# and any superior directories, if they do not exist.
@@ -9,16 +9,16 @@
#------------------------------------------------------------------------------
-@@ -113,7 +113,7 @@
- # directories if they don't exist. It will also install a default runtime
- # configuration if this file does not exist.
+@@ -114,7 +114,7 @@
+ # don't exist. It will also install a default runtime configuration if this
+ # file does not exist.
-CONFIGURE_FILE=/usr/exim/configure
+CONFIGURE_FILE=XX_PREFIX_XX/etc/exim/configure
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
# In this case, Exim will use the first of them that exists when it is run.
-@@ -131,14 +131,14 @@
+@@ -132,14 +132,14 @@
# owner of a local mailbox.) Specifying these values as root is very strongly
# discouraged. These values are compiled into the binary.
@@ -35,7 +35,7 @@
# Many sites define a user called "exim", with an appropriate default group,
# and use
-@@ -264,6 +264,7 @@
+@@ -265,6 +265,7 @@
# LDAP_LIB_TYPE=OPENLDAP2
# LDAP_LIB_TYPE=NETSCAPE
# LDAP_LIB_TYPE=SOLARIS
@@ -43,7 +43,7 @@
# If you don't set any of these, Exim assumes the original University of
# Michigan (OpenLDAP 1) library.
-@@ -276,8 +277,10 @@
+@@ -277,8 +278,10 @@
# don't need to set LOOKUP_INCLUDE if the relevant directories are already
# specified in INCLUDE.
@@ -56,7 +56,7 @@
#------------------------------------------------------------------------------
-@@ -288,7 +290,7 @@
+@@ -289,7 +292,7 @@
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
# local OS-specific make files.
@@ -65,7 +65,7 @@
-@@ -326,7 +328,7 @@
+@@ -393,7 +396,7 @@
# SUPPORT_TLS=yes
# Uncomment this setting if you are using OpenSSL
@@ -74,7 +74,7 @@
# Uncomment these settings if you are using GnuTLS
# USE_GNUTLS=yes
-@@ -377,7 +379,7 @@
+@@ -444,7 +447,7 @@
# Once you have done this, "make install" will build the info files and
# install them in the directory you have defined.
@@ -83,7 +83,7 @@
#------------------------------------------------------------------------------
-@@ -390,7 +392,7 @@
+@@ -457,7 +460,7 @@
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
@@ -92,13 +92,14 @@
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
-@@ -493,12 +495,20 @@
-
- # USE_TCP_WRAPPERS=yes
- # CFLAGS=-O -I/usr/local/include
--# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
+@@ -594,12 +597,20 @@
+ #
+ # USE_TCP_WRAPPERS=yes
+ # CFLAGS=-O -I/usr/local/include
+-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
+-#
+EXTRALIBS=XX_TCP_WRAPPERS_LIBS_XX XX_PAM_LIBS_XX
-
++
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -114,7 +115,7 @@
#------------------------------------------------------------------------------
# The default action of the exim_install script (which is run by "make
# install") is to install the Exim binary with a unique name such as
-@@ -726,7 +736,7 @@
+@@ -841,7 +852,7 @@
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:
diff --git a/mail/exim/files/patch-src::os.c b/mail/exim/files/patch-src::os.c
deleted file mode 100644
index 8da53762c0de..000000000000
--- a/mail/exim/files/patch-src::os.c
+++ /dev/null
@@ -1,19 +0,0 @@
-*** src/os.c.orig Tue Aug 12 16:39:56 2003
---- src/os.c Thu Aug 14 15:53:49 2003
-***************
-*** 659,665 ****
- addrp = &ifreq.V_ifr_addr;
-
- #else
-! memcpy((char *)&ifreq, cp, len);
- memcpy(addrbuf, (char *)&(ifreq.V_ifr_addr), len - sizeof(ifreq.V_ifr_name));
- addrp = (struct sockaddr *)addrbuf;
- #endif
---- 659,665 ----
- addrp = &ifreq.V_ifr_addr;
-
- #else
-! memcpy((char *)&ifreq, cp, sizeof(ifreq));
- memcpy(addrbuf, (char *)&(ifreq.V_ifr_addr), len - sizeof(ifreq.V_ifr_name));
- addrp = (struct sockaddr *)addrbuf;
- #endif
diff --git a/mail/exim/pkg-plist b/mail/exim/pkg-plist
index f8403431c744..2fc9fae85f11 100644
--- a/mail/exim/pkg-plist
+++ b/mail/exim/pkg-plist
@@ -1,7 +1,5 @@
etc/exim/configure.default
etc/rc.d/exim.sh
-info/exim.info
-info/exim_filter.info
sbin/exim
sbin/exim-%%EXIM_VERSION%%-1
sbin/exim_checkaccess
@@ -17,21 +15,17 @@ sbin/exigrep
sbin/eximstats
sbin/exiqgrep
sbin/exiqsumm
-%%PORTDOCS%%share/doc/exim/POST-INSTALL-NOTES
-%%PORTDOCS%%share/doc/exim/Exim3.upgrade
-%%PORTDOCS%%share/doc/exim/Exim4.upgrade
-%%PORTDOCS%%share/doc/exim/OptionLists.txt
-%%PORTDOCS%%share/doc/exim/README
-%%PORTDOCS%%share/doc/exim/dbm.discuss.txt
-%%PORTDOCS%%share/doc/exim/filter.txt
-%%PORTDOCS%%share/doc/exim/pcrepattern.txt
-%%PORTDOCS%%share/doc/exim/pcretest.txt
-%%PORTDOCS%%share/doc/exim/spec.txt
-%%PORTDOCS%%%%EXISCAN_ACL%%share/doc/exim/exiscan-acl-examples.txt
-%%PORTDOCS%%%%EXISCAN_ACL%%share/doc/exim/exiscan-acl-spec.txt
-@unexec install-info --delete %D/info/exim.info %D/info/dir
-@unexec install-info --delete %D/info/exim_filter.info %D/info/dir
-@exec install-info --section="Exim" --entry "* Exim Specification: (exim). Exim manual" %D/info/exim.info %D/info/dir
-@exec install-info --section="Exim" --entry "* Exim Filtering: (exim_filter). Filtering mail with Exim" %D/info/exim_filter.info %D/info/dir
+%%PORTDOCS%%%%DOCSDIR%%/POST-INSTALL-NOTES
+%%PORTDOCS%%%%DOCSDIR%%/Exim3.upgrade
+%%PORTDOCS%%%%DOCSDIR%%/Exim4.upgrade
+%%PORTDOCS%%%%DOCSDIR%%/OptionLists.txt
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/dbm.discuss.txt
+%%PORTDOCS%%%%DOCSDIR%%/filter.txt
+%%PORTDOCS%%%%DOCSDIR%%/pcrepattern.txt
+%%PORTDOCS%%%%DOCSDIR%%/pcretest.txt
+%%PORTDOCS%%%%DOCSDIR%%/spec.txt
+%%PORTDOCS%%%%EXISCAN_ACL%%%%DOCSDIR%%/exiscan-acl-examples.txt
+%%PORTDOCS%%%%EXISCAN_ACL%%%%DOCSDIR%%/exiscan-acl-spec.txt
@dirrm etc/exim
-@dirrm share/doc/exim
+%%PORTDOCS%%@dirrm %%DOCSDIR%%