aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-12-02 10:06:31 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-12-02 10:06:31 +0000
commite76cd7d6927a01e87121db2cfb729697a0b864ab (patch)
treeeb0de7aba916db8c653fcfffecb90ec868c5d3f6 /mail/exim
parent4017ec4340f13eee31405d362d133eeb489ed69f (diff)
downloadports-e76cd7d6927a01e87121db2cfb729697a0b864ab.tar.gz
ports-e76cd7d6927a01e87121db2cfb729697a0b864ab.zip
Add DomainKeys support.
PR: ports/89011 Submitted by: skv Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=150211
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile11
-rw-r--r--mail/exim/files/patch-src::EDITME24
-rw-r--r--mail/exim/options7
3 files changed, 34 insertions, 8 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 111573cf48fd..df73e38aeb8d 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -229,6 +229,9 @@ WITH_DEFAULT_CHARSET?= ISO-8859-1
# Enable Sender Policy Framework (SPF) checking in exiscan-acl
#WITH_SPF= yes
#
+# Enable DomainKeys support
+#WITH_DOMAINKEYS= yes
+#
# Enable Sender Rewriting Scheme (SRS)
#WITH_SRS= yes
#
@@ -494,6 +497,14 @@ SEDLIST+= -e 's,XX_SPF_FLAGS_XX,,' \
-e 's,XX_SPF_LIBS_XX,,'
.endif
+.if defined(WITH_DOMAINKEYS)
+LIB_DEPENDS+= domainkeys.3:${PORTSDIR}/mail/libdomainkeys
+SEDLIST+= -e 's,XX_DOMAINKEYS_LIBS_XX,-ldomainkeys,' \
+ -e 's,^\# (EXPERIMENTAL_DOMAINKEYS=),\1,'
+.else
+SEDLIST+= -e 's,XX_DOMAINKEYS_LIBS_XX,,'
+.endif
+
.if defined(WITH_SRS)
LIB_DEPENDS+= srs2.0:${PORTSDIR}/mail/libsrs2
SEDLIST+= -e 's,XX_SRS_FLAGS_XX,-DSRS,' \
diff --git a/mail/exim/files/patch-src::EDITME b/mail/exim/files/patch-src::EDITME
index 73c330522b3e..0f9761a76cd6 100644
--- a/mail/exim/files/patch-src::EDITME
+++ b/mail/exim/files/patch-src::EDITME
@@ -69,7 +69,15 @@ $FreeBSD$
#------------------------------------------------------------------------------
# Compiling Exim with content scanning support: If you want to compile Exim
-@@ -438,6 +441,7 @@
+@@ -370,6 +373,7 @@
+
+
+
++# EXPERIMENTAL_DOMAINKEYS=yes
+ ###############################################################################
+ # THESE ARE THINGS YOU MIGHT WANT TO SPECIFY #
+ ###############################################################################
+@@ -438,6 +442,7 @@
# ALT_CONFIG_PREFIX=/some/directory/
# ALT_CONFIG_PREFIX=/some/directory/exim.conf-
@@ -77,7 +85,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -491,7 +495,7 @@
+@@ -491,7 +496,7 @@
# one that is set in the headers_charset option. The default setting is
# defined by this setting:
@@ -86,7 +94,7 @@ $FreeBSD$
# If you are going to make use of $header_xxx expansions in your configuration
# file, or if your users are going to use them in filter files, and the normal
-@@ -563,7 +567,7 @@
+@@ -563,7 +568,7 @@
# SUPPORT_TLS=yes
# Uncomment this setting if you are using OpenSSL
@@ -95,7 +103,7 @@ $FreeBSD$
# Uncomment these settings if you are using GnuTLS
# USE_GNUTLS=yes
-@@ -614,7 +618,7 @@
+@@ -614,7 +619,7 @@
# Once you have done this, "make install" will build the info files and
# install them in the directory you have defined.
@@ -104,7 +112,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -627,7 +631,7 @@
+@@ -627,7 +632,7 @@
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
@@ -113,7 +121,7 @@ $FreeBSD$
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
-@@ -795,13 +799,21 @@
+@@ -795,13 +800,21 @@
# library for TCP wrappers, so you probably need something like this:
#
# USE_TCP_WRAPPERS=yes
@@ -121,7 +129,7 @@ $FreeBSD$
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
-#
+CFLAGS=XX_CFLAGS_XX XX_SPF_FLAGS_XX XX_SRS_FLAGS_XX XX_SQLITE_FLAGS_XX
-+EXTRALIBS=XX_TCP_WRAPPERS_LIBS_XX XX_PAM_LIBS_XX XX_ICONV_LIBS_XX XX_SPF_LIBS_XX XX_SRS_LIBS_XX XX_RADIUS_LIBS_XX XX_SQLITE_LIBS_XX
++EXTRALIBS=XX_TCP_WRAPPERS_LIBS_XX XX_PAM_LIBS_XX XX_ICONV_LIBS_XX XX_SPF_LIBS_XX XX_SRS_LIBS_XX XX_DOMAINKEYS_LIBS_XX XX_RADIUS_LIBS_XX XX_SQLITE_LIBS_XX
+
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -138,7 +146,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
# The default action of the exim_install script (which is run by "make
# install") is to install the Exim binary with a unique name such as
-@@ -1066,7 +1078,7 @@
+@@ -1066,7 +1079,7 @@
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:
diff --git a/mail/exim/options b/mail/exim/options
index 026e2e8f8d1a..9825b2a2c5cb 100644
--- a/mail/exim/options
+++ b/mail/exim/options
@@ -131,6 +131,10 @@
# srs_recipient (string*) SRS recipient
# srs_status (string*) SRS status
+#WITHOUT_DOMAINKEYS
+# Enable Yahoo DomainKeys support.
+# DomainKeys support depends on exiscan.
+
#WITHOUT_TCP_WRAPPERS
# Link against libwrap to support /etc/hosts.allow access control.
@@ -262,6 +266,9 @@ WITHOUT_SPF?=yes
.ifndef WITH_SRS
WITHOUT_SRS?=yes
.endif
+.ifndef WITH_DOMAINKEYS
+WITHOUT_DOMAINKEYS?=yes
+.endif
.ifndef WITH_TCP_WRAPPERS
WITHOUT_TCP_WRAPPERS?=yes
.endif