aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-12-10 16:09:13 +0000
committerSimon Barner <barner@FreeBSD.org>2005-12-10 16:09:13 +0000
commitd55a49e9d58b40b3d686fb8203e01a9bee238d84 (patch)
treeda59cde63931541bea7259f5919d7afd9d042d73 /mail/fetchmail
parent5058735c52a3169368d6bdfd215b1eb2c88fc553 (diff)
downloadports-d55a49e9d58b40b3d686fb8203e01a9bee238d84.tar.gz
ports-d55a49e9d58b40b3d686fb8203e01a9bee238d84.zip
- Use USE_OPENSSL [1]
- Remove obsolete --enable-inet6 configure argument [1] - Don't try to enable Kerberos IV and V at the same time [1] - Add WITH_NTLM knob. Inform port user about other knobs (WITH_X11, WITHOUT_NLS) [1] - Correct man page patch [1] - Fix default OpenSSL certificate path [1] [2] - Fix plist [1] [3] - Bump PORTREVISON Submitted by: Matthias Andree <matthias.andree@gmx.de> [1] Reported by: Dieter Rauschenberger <dr@d-ra.de> [2] PR: ports/90084 [2] Reported by: kris via pointyhat [3]
Notes
Notes: svn path=/head/; revision=150802
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile61
-rw-r--r--mail/fetchmail/files/patch-configure11
-rw-r--r--mail/fetchmail/files/patch-fetchmail.man98
-rw-r--r--mail/fetchmail/files/patch-socket.c13
-rw-r--r--mail/fetchmail/pkg-plist3
5 files changed, 139 insertions, 47 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 8b23a31a05f9..4e77572f20b1 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,6 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
http://home.pages.de/~mandree/%SUBDIR%/ \
@@ -18,17 +19,19 @@ MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
MASTER_SITE_SUBDIR= fetchmail
MAINTAINER= barner@FreeBSD.org
-COMMENT= Batch mail retrieval utility for IMAP/POP2/POP3/APOP/KPOP/ETRN/ODMR
+COMMENT= Batch mail retrieval utility for IMAP/POP2/POP3/ETRN/ODMR
USE_BZIP2= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_OPENSSL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-POP2 --enable-SDPS \
--with-hesiod=no --enable-fallback=no
+# bsd.openssl.mk will add the LDFLAGS to CONFIGURE_ENV:
+LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
MAN1= fetchmail.1
@@ -41,9 +44,11 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${POR
.include <bsd.port.pre.mk>
-FDOC= ${PREFIX}/share/doc/fetchmail
-DOCS= FAQ FEATURES NEWS NOTES README \
- design-notes.html fetchmail-FAQ.html fetchmail-features.html
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+
+DOCS= FAQ FEATURES NEWS NOTES README README.SSL \
+ design-notes.html fetchmail-FAQ.html fetchmail-features.html \
+ esrs-design-notes.html
.if !defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --enable-nls
@@ -54,31 +59,10 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+=--enable-inet6
-.endif
-
-.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
-CONFIGURE_ARGS+=--with-ssl=/usr
-DOCS+= README.SSL
-PLIST_SUB+= SSLDOCS="%%PORTDOCS%%"
-.elif exists(${LOCALBASE}/lib/libssl.a) && exists(${LOCALBASE}/lib/libcrypto.a)
-CONFIGURE_ARGS+=-with-includes=${LOCALBASE}/include/openssl --with-ssl=${LOCALBASE}
-.if exists(${LOCALBASE}/lib/libRSAglue.a)
-CONFIGURE_ENV+= RSAGLUE=-lRSAglue
-.endif
-DOCS+= README.SSL
-PLIST_SUB+= SSLDOCS="%%PORTDOCS%%"
-.else
-PLIST_SUB+= SSLDOCS="%%PORTDOCS%%@comment "
-.endif
-
-.if exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4)
-CONFIGURE_ARGS += --with-kerberos=/usr
-.endif
-
.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libkrb5.a)
CONFIGURE_ARGS += --with-kerberos5=${KRB5_HOME}
+.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4)
+CONFIGURE_ARGS += --with-kerberos=/usr
.endif
.if defined(WITH_NTLM)
@@ -97,10 +81,27 @@ pre-patch:
${WRKDIR}/fetchmailconf
post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL} -d -m 555 -o ${DOCOWN} -g ${DOCGRP} ${FDOC}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${FDOC}
+ ${INSTALL} -d -m 555 -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${PREFIX}/bin
+pre-configure:
+.if defined(WITH_NTLM)
+ @${ECHO_CMD} "Building in support for NTLM/MSN authentication."
+.else
+ @${ECHO_CMD} "Add -DWITH_NTLM to add support for NTLM/MSN authentication."
+.endif
+.if defined(WITH_X11)
+ @${ECHO_CMD) "Adding Python/Tkinter dependencies for fetchmailconf."
+.else
+ @${ECHO_CMD} "Add -DWITH_X11 to add Python/Tkinter dependencies for fetchmailconf."
+.endif
+.if defined(WITHOUT_NLS)
+ @${ECHO_CMD} "Using national language support (NLS)."
+.else
+ @${ECHO_CMD} "You can use -DWITHOUT_NLS to suppress national language support (NLS)."
+.endif
+
.include <bsd.port.post.mk>
diff --git a/mail/fetchmail/files/patch-configure b/mail/fetchmail/files/patch-configure
deleted file mode 100644
index 8ff0ae95dd59..000000000000
--- a/mail/fetchmail/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Sep 26 00:29:14 2005
-+++ configure Mon Sep 26 08:59:07 2005
-@@ -12374,7 +12374,7 @@
- { (exit 1); exit 1; }; }
- fi
- LDEFLAGS="$LDEFLAGS -L$with_ssl/lib"
-- LIBS="$LIBS -lssl -lcrypto"
-+ LIBS="$LIBS -lssl -lcrypto $RSAGLUE"
- echo "$as_me:$LINENO: checking for additional library dependencies of SSL" >&5
- echo $ECHO_N "checking for additional library dependencies of SSL... $ECHO_C" >&6
- found=0
diff --git a/mail/fetchmail/files/patch-fetchmail.man b/mail/fetchmail/files/patch-fetchmail.man
index b81f1c0f79c4..552fae173a23 100644
--- a/mail/fetchmail/files/patch-fetchmail.man
+++ b/mail/fetchmail/files/patch-fetchmail.man
@@ -1,20 +1,108 @@
---- fetchmail.man.orig Tue Dec 6 21:49:31 2005
-+++ fetchmail.man Tue Dec 6 21:49:50 2005
+Index: fetchmail.man
+===================================================================
+--- fetchmail.man (Revision 4499)
++++ fetchmail.man (Arbeitskopie)
@@ -798,7 +798,7 @@
but a string matching the user host name is likely.
By using the option 'envelope Delivered\-To:' you can make fetchmail reliably
identify the original envelope recipient, but you have to strip the
-'mbox\-userstr\-' prefix to deliver to the correct user.
-+\'mbox\-userstr\-' prefix to deliver to the correct user.
++\&'mbox\-userstr\-' prefix to deliver to the correct user.
This is what this option is for.
.TP
.B \-\-configdump
-@@ -2188,7 +2188,7 @@
+@@ -1339,11 +1339,11 @@
+ two or more lines, unless you use a backslash to join lines (see below).
+ An unquoted string is any whitespace-delimited token that is neither
+ numeric, string quoted nor contains the special characters ',', ';',
+-':', or '='.
++\&':', or '='.
+ .PP
+ Any amount of whitespace separates tokens in server entries, but is
+ otherwise ignored. You may use backslash escape sequences (\en for LF,
+-\&\et for HT, \&\eb for BS, \er for CR, \e\fInnn\fP for decimal (where
++\&\et for HT, \eb for BS, \er for CR, \e\fInnn\fP for decimal (where
+ nnn cannot start with a 0), \e0\fIooo\fP for octal, and \ex\fIhh\fP for
+ hex) to embed non-printable characters or string delimiters in strings.
+ In quoted strings, a backslash at the very end of a line will cause the
+@@ -1386,7 +1386,7 @@
+ square brackets are optional. Those corresponding to short command-line
+ options are followed by '\-' and the appropriate option letter. If
+ option is only relevant to a single mode of operation, it is noted as
+-'s' or 'm' for singledrop- or multidrop-mode, respectively.
++\&'s' or 'm' for singledrop- or multidrop-mode, respectively.
+
+ Here are the legal global options:
+
+@@ -1452,7 +1452,7 @@
+ local[domains] \& m T{
+ Specify domain(s) to be regarded as local
+ T}
+-port \& T{
++port \& \& T{
+ Specify TCP/IP service port (obsolete, use 'service' instead).
+ T}
+ service \-P \& T{
+@@ -1489,7 +1489,7 @@
+ plugout \& \& T{
+ Specify command through which to make listener connections.
+ T}
+-dns \& m T{
++dns \& m T{
+ Enable DNS lookup for multidrop (default)
+ T}
+ no dns \& m T{
+@@ -1519,7 +1519,7 @@
+ esmtpname \& \& T{
+ Set name for RFC2554 authentication to the ESMTP server.
+ T}
+-esmtppassword \& \& T{
++esmtppassword \& \& T{
+ Set password for RFC2554 authentication to the ESMTP server.
+ T}
+ .TE
+@@ -1788,7 +1788,7 @@
+ to the listener or MDA unaltered (local-name mappings are \fInot\fR
+ applied).
+ .PP
+-If you are using 'localdomains', you may also need to specify \&'no
++If you are using 'localdomains', you may also need to specify 'no
+ envelope', which disables \fIfetchmail\fR's normal attempt to deduce
+ an envelope address from the Received line or X-Envelope-To header or
+ whatever header has been previously set by 'envelope'. If you set 'no
+@@ -1923,7 +1923,7 @@
+ followed by a string sets the same global specified by \-\-logfile. A
+ command-line \-\-logfile option will override this. Note that \-\-logfile is
+ only effective if fetchmail detaches itself from the terminal. Also,
+-'set daemon' sets the poll interval as \-\-daemon does. This can be
++\&'set daemon' sets the poll interval as \-\-daemon does. This can be
+ overridden by a command-line \-\-daemon option; in particular \-\-daemon\~0
+ can be used to force foreground operation. The 'set postmaster'
+ statement sets the address to which multidrop mail defaults if there are
+@@ -2182,13 +2182,13 @@
+ header. But this doesn't work reliably for other MTAs, nor if there is
+ more than one recipient. By default, \fIfetchmail\fR looks for
+ envelope addresses in these lines; you can restore this default with
+-\&\-E "Received" or \&'envelope Received'.
++\&\-E "Received" or 'envelope Received'.
+ .PP
+ .B As a better alternative,
some SMTP listeners and/or mail servers insert a header
in each message containing a copy of the envelope addresses. This
header (when it exists) is often 'X\-Original\-To', 'Delivered\-To' or
-'X\-Envelope\-To'. Fetchmail's assumption about this can be changed with
-+\'X\-Envelope\-To'. Fetchmail's assumption about this can be changed with
++\&'X\-Envelope\-To'. Fetchmail's assumption about this can be changed with
the \-E or 'envelope' option. Note that writing an envelope header of
this kind exposes the names of recipients (including blind-copy
recipients) to all receivers of the messages, so the upstream must store
+@@ -2243,8 +2243,8 @@
+ list called (say) "fetchmail-friends", and you want to keep the alias
+ list on your client machine.
+ .PP
+-On your server, you can alias \&'fetchmail\-friends' to 'esr'; then, in
+-your \fI.fetchmailrc\fR, declare \&'to esr fetchmail\-friends here'.
++On your server, you can alias 'fetchmail\-friends' to 'esr'; then, in
++your \fI.fetchmailrc\fR, declare 'to esr fetchmail\-friends here'.
+ Then, when mail including 'fetchmail\-friends' as a local address
+ gets fetched, the list name will be appended to the list of
+ recipients your SMTP listener sees. Therefore it will undergo alias
diff --git a/mail/fetchmail/files/patch-socket.c b/mail/fetchmail/files/patch-socket.c
new file mode 100644
index 000000000000..91fba2b5c0fa
--- /dev/null
+++ b/mail/fetchmail/files/patch-socket.c
@@ -0,0 +1,13 @@
+Index: socket.c
+===================================================================
+--- socket.c (Revision 4499)
++++ socket.c (Arbeitskopie)
+@@ -841,6 +841,8 @@
+ }
+ if (certpath)
+ SSL_CTX_load_verify_locations(_ctx, NULL, certpath);
++ else
++ SSL_CTX_set_default_verify_paths(_ctx);
+
+ _ssl_context[sock] = SSL_new(_ctx);
+
diff --git a/mail/fetchmail/pkg-plist b/mail/fetchmail/pkg-plist
index 7c98b9aeca9e..4b1f3d312b64 100644
--- a/mail/fetchmail/pkg-plist
+++ b/mail/fetchmail/pkg-plist
@@ -8,8 +8,9 @@ libexec/fetchmailconf.py
%%PORTDOCS%%%%DOCSDIR%%/NOTES
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%NTLMDOCS%%%%DOCSDIR%%/README.NTLM
-%%PORTDOCS%%%%SSLDOCS%%%%DOCSDIR%%/README.SSL
+%%PORTDOCS%%%%DOCSDIR%%/README.SSL
%%PORTDOCS%%%%DOCSDIR%%/design-notes.html
+%%PORTDOCS%%%%DOCSDIR%%/esrs-design-notes.html
%%PORTDOCS%%%%DOCSDIR%%/fetchmail-FAQ.html
%%PORTDOCS%%%%DOCSDIR%%/fetchmail-features.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%