aboutsummaryrefslogtreecommitdiff
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-04-28 17:26:35 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-04-28 17:26:35 +0000
commiteaf628233775993bb2876c585b5420b0ba1bcd56 (patch)
tree09666ceb8d395c7022dbea624d471ff5a323a5ba /mail/fetchmail
parent16a81bf7dbfa4d2e96a7d1c6e1d157c4fcd94372 (diff)
downloadports-eaf628233775993bb2876c585b5420b0ba1bcd56.tar.gz
ports-eaf628233775993bb2876c585b5420b0ba1bcd56.zip
- fix POP bug [1]
- add WITHOUT_NLS [2] Seems like 6.2.6 takes a while... PR: 60262 [1], 62732 [2] Submitted by: Stuart Barkley <stuartb@4gh.net> [1] Katsura Matsumoto <katsura@cc.osaka-kyoiku.ac.jp> [1]
Notes
Notes: svn path=/head/; revision=107836
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile17
-rw-r--r--mail/fetchmail/files/patch-driver.c15
-rw-r--r--mail/fetchmail/pkg-plist30
3 files changed, 44 insertions, 18 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index b6c6de4895f3..3a556e82c09e 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,7 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= http://www.catb.org/~esr/%SUBDIR%/ \
ftp://ftp.ayamura.org/pub/%SUBDIR%/ \
@@ -26,17 +26,20 @@ COMMENT= Batch mail retrieval utility for IMAP/POP2/POP3/APOP/KPOP/ETRN/ODMR
RUN_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
+.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+.endif
.if defined(WITH_X11)
USE_PYTHON= yes
.endif
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-POP2 --enable-SDPS \
- --enable-nls --with-hesiod=no --enable-fallback=no
+ --with-hesiod=no --enable-fallback=no
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
MAN1= fetchmail.1
@@ -46,6 +49,14 @@ FDOC= ${PREFIX}/share/doc/fetchmail
DOCS= FAQ FEATURES NEWS NOTES README \
design-notes.html fetchmail-FAQ.html fetchmail-features.html
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 400014
diff --git a/mail/fetchmail/files/patch-driver.c b/mail/fetchmail/files/patch-driver.c
new file mode 100644
index 000000000000..54f0042d4db4
--- /dev/null
+++ b/mail/fetchmail/files/patch-driver.c
@@ -0,0 +1,15 @@
+--- driver.c 2003-10-16 00:52:31 +0530
++++ driver.c 2003-10-17 11:24:27 +0530
+@@ -429,8 +429,11 @@
+ /* for POP3, we can get the size of one mail only! Unfortunately, this
+ * protocol specific test cannot be done elsewhere as the protocol
+ * could be "auto". */
+- if (ctl->server.protocol == P_POP3)
++ switch (ctl->server.protocol)
++ {
++ case P_POP3: case P_APOP: case P_RPOP:
+ fetchsizelimit = 1;
++ }
+
+ /* Time to allocate memory to store the sizes */
+ xalloca(msgsizes, int *, sizeof(int) * fetchsizelimit);
diff --git a/mail/fetchmail/pkg-plist b/mail/fetchmail/pkg-plist
index 684815da5cca..a47265264866 100644
--- a/mail/fetchmail/pkg-plist
+++ b/mail/fetchmail/pkg-plist
@@ -7,22 +7,22 @@ libexec/fetchmailconf.bin
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/NOTES
%%PORTDOCS%%%%DOCSDIR%%/README
-%%NTLMDOCS%%%%DOCSDIR%%/README.NTLM
-%%SSLDOCS%%%%DOCSDIR%%/README.SSL
+%%PORTDOCS%%%%NTLMDOCS%%%%DOCSDIR%%/README.NTLM
+%%PORTDOCS%%%%SSLDOCS%%%%DOCSDIR%%/README.SSL
%%PORTDOCS%%%%DOCSDIR%%/design-notes.html
%%PORTDOCS%%%%DOCSDIR%%/fetchmail-FAQ.html
%%PORTDOCS%%%%DOCSDIR%%/fetchmail-features.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-share/locale/ca/LC_MESSAGES/fetchmail.mo
-share/locale/cs/LC_MESSAGES/fetchmail.mo
-share/locale/da/LC_MESSAGES/fetchmail.mo
-share/locale/de/LC_MESSAGES/fetchmail.mo
-share/locale/el/LC_MESSAGES/fetchmail.mo
-share/locale/es/LC_MESSAGES/fetchmail.mo
-share/locale/fr/LC_MESSAGES/fetchmail.mo
-share/locale/gl/LC_MESSAGES/fetchmail.mo
-share/locale/ja/LC_MESSAGES/fetchmail.mo
-share/locale/pl/LC_MESSAGES/fetchmail.mo
-share/locale/pt_BR/LC_MESSAGES/fetchmail.mo
-share/locale/sk/LC_MESSAGES/fetchmail.mo
-share/locale/tr/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/da/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/de/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/el/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/es/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/fetchmail.mo