aboutsummaryrefslogtreecommitdiff
path: root/mail/imap-uw
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-13 19:53:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-13 19:53:56 +0000
commitd0fe1d882c2648c5ec9a05dd19582976a5d67200 (patch)
tree619de9303a8179be5d61df0472f8f2d482960ac5 /mail/imap-uw
parent10ab754f5762a972acd0881d4f90bd0fed15f10a (diff)
downloadports-d0fe1d882c2648c5ec9a05dd19582976a5d67200.tar.gz
ports-d0fe1d882c2648c5ec9a05dd19582976a5d67200.zip
- Use $SUB_FILES to adjust PREFIX in pkg-message instead of hardcoding /usr/local
- Use bsd.port.options.mk - Remove unneeded variables DISTNAME,DISTFILES & WRKSRC - Declare LIB_DEPENDS earlier PR: 142733 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=249802
Diffstat (limited to 'mail/imap-uw')
-rw-r--r--mail/imap-uw/Makefile23
-rw-r--r--mail/imap-uw/files/pkg-message.in (renamed from mail/imap-uw/pkg-message)6
2 files changed, 15 insertions, 14 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 6853ab0a9330..f36a90ed0f43 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -15,12 +15,20 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/mail/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
PKGNAMESUFFIX= -uw
-DISTNAME= imap-${PORTVERSION}
-DISTFILES= ${DISTNAME}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}
MAINTAINER= anders@FreeBSD.org
COMMENT= University of Washington IMAP4rev1/POP2/POP3 mail servers
+LIB_DEPENDS= c-client4.9:${PORTSDIR}/mail/cclient
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+SUB_FILES= pkg-message
+
+MAN1= dmail.1 mailutil.1 tmail.1
+MAN8= ipopd.8 imapd.8
+
+ALL_TARGET= bsf
+
# This port must have the same SSL settings as mail/cclient, which it depends on
# To make MBX format the default mailbox format, change the settings of cclient
@@ -29,21 +37,13 @@ OPTIONS= SSL "Compile with SSL support" on \
DRAC "Dynamically open MTA for relaying" off \
NETSCAPE_BRAIN_DAMAGE "See Makefile for documentation" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-LIB_DEPENDS= c-client4.9:${PORTSDIR}/mail/cclient
.if defined(WITH_DRAC)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
MAKE_ARGS+= WITH_DRAC=yes
.endif
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-MAN1= dmail.1 mailutil.1 tmail.1
-MAN8= ipopd.8 imapd.8
-
-ALL_TARGET= bsf
.if defined(WITHOUT_SSL)
MAKE_ARGS+= SSLTYPE=none SSLDIR=${OPENSSLBASE}
.else
@@ -61,6 +61,7 @@ MAKE_ARGS+= WITH_NETSCAPE_BRAIN_DAMAGE=yes
.endif
# See src/imapd/Makefile for more information about these three options.
+.include <bsd.port.pre.mk>
pre-build:
@${SH} ${PKGREQ}.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
.if !defined(WITHOUT_SSL)
diff --git a/mail/imap-uw/pkg-message b/mail/imap-uw/files/pkg-message.in
index cfda7e555fc0..ca41cd71f947 100644
--- a/mail/imap-uw/pkg-message
+++ b/mail/imap-uw/files/pkg-message.in
@@ -1,9 +1,9 @@
The ipop2d, ipop3d, and imapd daemons should be invoked by your
/etc/inetd.conf file with lines such as:
-pop2 stream tcp nowait root /usr/local/libexec/ipop2d ipop2d
-pop3 stream tcp nowait root /usr/local/libexec/ipop3d ipop3d
-imap4 stream tcp nowait root /usr/local/libexec/imapd imapd
+pop2 stream tcp nowait root %%PREFIX%%/libexec/ipop2d ipop2d
+pop3 stream tcp nowait root %%PREFIX%%/libexec/ipop3d ipop3d
+imap4 stream tcp nowait root %%PREFIX%%/libexec/imapd imapd
If PAM authentication support has been compiled in you will need to add
something like the following lines to /etc/pam.conf (PAM authentication is