aboutsummaryrefslogtreecommitdiff
path: root/mail/james
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 13:23:14 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 13:23:14 +0000
commit9cf935fb63dcff0760eed08824ee5bffccf07199 (patch)
treea131ee344ec52ade52d9eebdbfb807369055fc11 /mail/james
parentc63e0b22490fe205cdcadefacd7b78863c885479 (diff)
downloadports-9cf935fb63dcff0760eed08824ee5bffccf07199.tar.gz
ports-9cf935fb63dcff0760eed08824ee5bffccf07199.zip
Stagify.
Notes
Notes: svn path=/head/; revision=357017
Diffstat (limited to 'mail/james')
-rw-r--r--mail/james/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/mail/james/Makefile b/mail/james/Makefile
index 20fc6faa362e..a4ac255bb951 100644
--- a/mail/james/Makefile
+++ b/mail/james/Makefile
@@ -28,7 +28,6 @@ SUB_LIST= JAVA_HOME=${JAVA_HOME} \
JAMES_HOME=${APP_HOME} \
JAMES_VERSION=${PORTVERSION:S/.//g}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-patch:
@@ -44,17 +43,17 @@ post-patch:
do-install:
@${ECHO_MSG} -n ">> Creating destination directory..."
- @${MKDIR} ${APP_HOME}
+ @${MKDIR} ${STAGEDIR}${APP_HOME}
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} ">> Copying files to destination directory..."
- @${CP} -R ${WRKSRC}/* ${APP_HOME}
- @${MKDIR} ${APP_HOME}/logs
- @${MKDIR} ${APP_HOME}/apps
+ @${CP} -R ${WRKSRC}/* ${STAGEDIR}${APP_HOME}
+ @${MKDIR} ${STAGEDIR}${APP_HOME}/logs
+ @${MKDIR} ${STAGEDIR}${APP_HOME}/apps
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Creating symlink to tools.jar..."
- @${LN} -sf ${JAVA_HOME}/lib/tools.jar ${APP_HOME}/lib/tools.jar
+ @${LN} -sf ${JAVA_HOME}/lib/tools.jar ${STAGEDIR}${APP_HOME}/lib/tools.jar
@${ECHO_MSG} " [ DONE ]"
post-install: