aboutsummaryrefslogtreecommitdiff
path: root/mail/junkfilter
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-01-02 11:09:59 +0000
committerStefan Eßer <se@FreeBSD.org>2020-01-02 11:09:59 +0000
commit0a7a14fdb431c1d716f0d5ea7887be38dabf0183 (patch)
treea05628a99aaa4d813060bd4fa29270958505d228 /mail/junkfilter
parent555ead1322938fa59cb92fd2a5f8baa3fdea7433 (diff)
downloadports-0a7a14fdb431c1d716f0d5ea7887be38dabf0183.tar.gz
ports-0a7a14fdb431c1d716f0d5ea7887be38dabf0183.zip
Fix regular expression to support dates after year 2019.
While here I have also fixed portlint and poudriere testport complaints: - add LICENSE - add NO_ARCH - remove DISTFILES definition to its default value Submitted by: kargl (RE fix) Approved by: antoine (implicit)
Notes
Notes: svn path=/head/; revision=521827
Diffstat (limited to 'mail/junkfilter')
-rw-r--r--mail/junkfilter/Makefile9
-rw-r--r--mail/junkfilter/files/patch-junkfilter.three11
2 files changed, 17 insertions, 3 deletions
diff --git a/mail/junkfilter/Makefile b/mail/junkfilter/Makefile
index f07d039c7c86..dbde148f4611 100644
--- a/mail/junkfilter/Makefile
+++ b/mail/junkfilter/Makefile
@@ -3,22 +3,25 @@
PORTNAME= junkfilter
PORTVERSION= 20030115
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF \
http://junkfilter.zer0.org/pkg/${PORTVERSION}/
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-
MAINTAINER= gsutter@zer0.org
COMMENT= Spam filtering software for procmail
-PORTSCOUT= limit:^20
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= procmail:mail/procmail
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
BINDIR= ${PREFIX}/etc/${PORTNAME}
+NO_ARCH= yes
+
+PORTSCOUT= limit:^20
JFFILES= LICENSE Makefile README TODO addresses bodychk dialups \
headers ip jf jf-addresses jf-bodychk jf-dialups jf-domains \
diff --git a/mail/junkfilter/files/patch-junkfilter.three b/mail/junkfilter/files/patch-junkfilter.three
new file mode 100644
index 000000000000..8d1b7a72f338
--- /dev/null
+++ b/mail/junkfilter/files/patch-junkfilter.three
@@ -0,0 +1,11 @@
+--- junkfilter.three.orig 2002-06-11 15:41:26 UTC
++++ junkfilter.three
+@@ -56,7 +56,7 @@ JFSEC=3
+ * ! $ ^Date:$JFWS((Sun|Mon|Tue|Wed|Thu|Fri|Sat),$JFWS)?\
+ (0?[1-9]|[12][0-9]|3[01])$JFWS\
+ (Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)$JFWS\
+- ((19)?[789][0-9]|(20)?[01][0-9])$JFWS\
++ ((19)?[789][0-9]|(20)?[012][0-9])$JFWS\
+ (0?[0-9]|1[0-9]|2[0-3]):(0?|[1-5])[0-9](:(0?|[1-5])[0-9])?$JFWS\
+ (([+-][0-1][0-4]([03]0|45))|("?\(?(UT|GMT|EST|EDT|CST|CDT|MST|MDT|PST|PDT|[A-I]|[K-Z])\)?"?))?
+ { JFMATCH="$JFSEC: Bad Date line" INCLUDERC=$JFDIR/junkfilter.match }