aboutsummaryrefslogtreecommitdiff
path: root/mail/libesmtp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-23 01:46:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-23 01:46:49 +0000
commita27aa8714695ad4dd57cf39de03f5529fd286346 (patch)
tree904661ef85fe61b27cf67af20414ebed8507801b /mail/libesmtp/Makefile
parentc52abba0b39b681dded084dc7d09ac696856ed0e (diff)
downloadports-a27aa8714695ad4dd57cf39de03f5529fd286346.tar.gz
ports-a27aa8714695ad4dd57cf39de03f5529fd286346.zip
- Update to 1.0.6
PR: 168041 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=297236
Diffstat (limited to 'mail/libesmtp/Makefile')
-rw-r--r--mail/libesmtp/Makefile39
1 files changed, 19 insertions, 20 deletions
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 764d546dd790..2c3ff3075052 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -5,40 +5,37 @@
# $FreeBSD$
PORTNAME= libesmtp
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTVERSION= 1.0.6
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.stafford.uklinux.net/libesmtp/ \
http://ftp.osuosl.org/pub/blfs/svn/l/ \
- ftp://ftp.linux.ee/pub/gentoo/distfiles/distfiles/
+ GENTOO/distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for posting electronic mail
+LICENSE= LGPL21
+
+OPTIONS= OPENSSL "Enable TLS support" on \
+ DEBUG "Enables debugging support" off
+
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
-
# require-all-recipients (implied by enable-all) is required for Balsa
CONFIGURE_ARGS= --enable-all --disable-isoc
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-OPTIONS= OPENSSL "Enable TLS support" on \
- DEBUG "Enables debugging support" off
-
-DOCS= AUTHORS ChangeLog NEWS Notes README TODO
-EXAMPLES= examples/*
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_OPENSSL)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
PLIST_SUB+= NEED_OPENSSL=""
.else
@@ -51,13 +48,15 @@ CONFIGURE_ARGS+= --enable-debug
.endif
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/${EXAMPLES} ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for f in ${DOCS}
+.for f in AUTHORS ChangeLog NEWS Notes README TODO
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>