aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-03-02 08:34:40 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-03-02 08:34:40 +0000
commit240fff7e0bfb05ba19935588360a22ceaf6d5516 (patch)
tree31a30a84086889c1d71559ec5965c42bda3e216e /mail/mailman/Makefile
parent536a7e97be6ef9f6a786998b68c3c2a3e55abb4f (diff)
downloadports-240fff7e0bfb05ba19935588360a22ceaf6d5516.tar.gz
ports-240fff7e0bfb05ba19935588360a22ceaf6d5516.zip
Preserve some kinds of signatures, reenable HTDIG option.
Pull upstream change 1629 to fix Launchpad Bug #1551075 <https://bugs.launchpad.net/mailman/+bug/1551075>. This fix improves preservation of OpenPGP MIME multipart signatures, by not collapsing a multipart with a single sub-part inside multipart/signed parts. See the Launchpad bug report for details. EXPERIMENTAL feature: Reenable HTDIG support by rolling the patch on our own, and laying down instructions to do so in the Makefile. Mark Sapiro no longer maintains the patch. Bump PORTREVISION to 3. Note that the upstream maintainer considers another release in a few weeks' time, and called for help with updating translations. If you want to help, see <http://www.mail-archive.com/mailman-users%40python.org/msg68036.html>
Notes
Notes: svn path=/head/; revision=409916
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index f1b32e203c1d..e85767d5e65d 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,11 +3,12 @@
PORTNAME= mailman
DISTVERSION= 2.1.21
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
https://launchpad.net/mailman/${DISTVERSION:R}/${DISTVERSION}/+download/
+PATCH_SITES= LOCAL/mandree
DIST_SUBDIR= mailman
PATCH_DIST_STRIP= -p1
@@ -64,7 +65,7 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
OPTIONS_SINGLE= MTA
OPTIONS_SINGLE_MTA= COURIER EXIM4 OPENSMTPD POSTFIX SENDMAIL
-OPTIONS_DEFINE= NAMAZU2 NLS DOCS # HTDIG defunct in 2.1.21
+OPTIONS_DEFINE= HTDIG NAMAZU2 NLS DOCS
OPTIONS_DEFAULT= SENDMAIL
COURIER_DESC= for use with courier
EXIM4_DESC= for use with exim4
@@ -109,9 +110,13 @@ MAIL_GID?= _smtpd
.endif
.if ${PORT_OPTIONS:MHTDIG}
-PATCH_SITES+= http://www.msapiro.net/mm/
-PATCHFILES+= index_htdig.patch.2.1.20
PKGNAMESUFFIX+= -with-htdig
+# how to create PATCHFILES:
+#X fetch http://bazaar.launchpad.net/~msapiro/mailman/htdig/tarball/1632?start_revid=1632
+#X unpack this tarball, and the original distfile
+#X diff -NEur original-unpack bazaar-unpack | xz --best -c >msapiro-htdig-1632.patch.xz
+#X upload the latter with mode 0644 or similar to freefall's public_distfiles/ directory
+PATCHFILES+= msapiro-htdig-1632.patch.xz
RUN_DEPENDS+= htdig:${PORTSDIR}/textproc/htdig
PLIST_SUB+= SUB_HTDIG=""
.else