aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-regex
diff options
context:
space:
mode:
authorDaniel Hartmeier <dhartmei@FreeBSD.org>2004-04-07 15:44:50 +0000
committerDaniel Hartmeier <dhartmei@FreeBSD.org>2004-04-07 15:44:50 +0000
commit2725630efaa8dce235b29b652e72aa2efd0ab14f (patch)
treee5d012d03628793d789f63554e1c90cbf786bbf5 /mail/milter-regex
parent98c7bd4779c7b553ba1656d1855ad63faf4b7189 (diff)
downloadports-2725630efaa8dce235b29b652e72aa2efd0ab14f.tar.gz
ports-2725630efaa8dce235b29b652e72aa2efd0ab14f.zip
Update to 1.5
Notes
Notes: svn path=/head/; revision=106427
Diffstat (limited to 'mail/milter-regex')
-rw-r--r--mail/milter-regex/Makefile17
-rw-r--r--mail/milter-regex/distinfo4
-rw-r--r--mail/milter-regex/pkg-descr19
-rw-r--r--mail/milter-regex/pkg-install11
4 files changed, 30 insertions, 21 deletions
diff --git a/mail/milter-regex/Makefile b/mail/milter-regex/Makefile
index 7193fcfb6efe..0e73bdaa282b 100644
--- a/mail/milter-regex/Makefile
+++ b/mail/milter-regex/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= milter_regex
-PORTVERSION= 0.8
+PORTVERSION= 1.5
CATEGORIES= mail
MASTER_SITES= http://www.benzedrine.cx/
DISTNAME= milter-regex-${PORTVERSION}
@@ -15,6 +15,8 @@ DISTNAME= milter-regex-${PORTVERSION}
MAINTAINER= dhartmei@FreeBSD.org
COMMENT= Milter plugin to sendmail for regular expression filtering
+USE_REINPLACE= yes
+MAILUSER?= mailnull
MAN8= milter-regex.8
PLIST_FILES= libexec/milter-regex
@@ -25,10 +27,15 @@ pre-everything::
.endif
post-patch:
- @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
- @${SED} -e "s:-lpthread:${PTHREAD_LIBS}:g; \
- s:-I/usr/src/gnu/usr.sbin/sendmail/include:${PTHREAD_CFLAGS}:g; \
- s/-Werror//g" < ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ "s:/etc/milter-regex.conf:/usr/local/etc/milter-regex.conf:g; \
+ s:_milter-regex:${MAILUSER}:g;" ${WRKSRC}/milter-regex.c
+ @${REINPLACE_CMD} -e \
+ "s:/etc/milter-regex.conf:/usr/local/etc/milter-regex.conf:g; \
+ s:mailstats 1:mailstats 8:;" ${WRKSRC}/milter-regex.8
+ @${REINPLACE_CMD} -e "s:-lpthread:${PTHREAD_LIBS}:g; \
+ s:-I/usr/src/gnu/usr.sbin/sendmail/include:${PTHREAD_CFLAGS}:g; \
+ s/-Werror//g" ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/milter-regex ${PREFIX}/libexec
diff --git a/mail/milter-regex/distinfo b/mail/milter-regex/distinfo
index 6ea65a7d8dda..6a21614f0f0b 100644
--- a/mail/milter-regex/distinfo
+++ b/mail/milter-regex/distinfo
@@ -1,2 +1,2 @@
-MD5 (milter-regex-0.8.tar.gz) = 61f69271320e30765c88ca799a9a8751
-SIZE (milter-regex-0.8.tar.gz) = 9398
+MD5 (milter-regex-1.5.tar.gz) = 56f0a4648e46943e9f19256332211a17
+SIZE (milter-regex-1.5.tar.gz) = 15784
diff --git a/mail/milter-regex/pkg-descr b/mail/milter-regex/pkg-descr
index 6d7404578c12..9412fa98be89 100644
--- a/mail/milter-regex/pkg-descr
+++ b/mail/milter-regex/pkg-descr
@@ -1,16 +1,13 @@
-from the OpenBSD port:
+Milter-regex is a sendmail milter plugin that allows to reject mail
+based on regular expressions matching SMTP envelope parameters and
+mail headers and body.
- milter-regex is a sendmail milter plugin that allows to reject mail
- based on regular expressions matching SMTP envelope parameters and
- mail headers and body.
+In order to build milter-regex, sendmail needs to be compiled with
+milter support, installing the libmilter library.
- In order to build milter-regex, sendmail needs to be compiled with
- milter support, installing the libmilter library.
+This is the default for the sendmail in the base system.
+Some of the sendmail ports omit libmilter by default (SENDMAIL_WITHOUT_MILTER).
-This is the default for the sendmail in the base system. Some of the sendmail
-ports omit libmilter by default.
-
-This port is in an experimental, untested state on FreeBSD. Please tell the
-maintainer about your results, whether successful or unsuccessful.
+This program is developed on OpenBSD by the maintainer.
WWW: http://www.benzedrine.cx/milter-regex.html
diff --git a/mail/milter-regex/pkg-install b/mail/milter-regex/pkg-install
index a5f814c7edbc..1d4ae61441d0 100644
--- a/mail/milter-regex/pkg-install
+++ b/mail/milter-regex/pkg-install
@@ -1,11 +1,13 @@
-#! /bin/sh
-# $OpenBSD$
+#!/bin/sh
+#
+# $FreeBSD$
#
-# Pre/post-installation setup of milter-regex
set -e
PATH=/bin:/usr/bin:/sbin:/usr/sbin
PREFIX=${PKG_PREFIX:-/usr/local}
+MAILUSER=mailnull
+SPOOLDIR=/var/spool/milter-regex
do_notice()
{
@@ -39,6 +41,9 @@ case $2 in
PRE-INSTALL)
;;
POST-INSTALL)
+ if [ ! -d $SPOOLDIR ]; then
+ install -d -o $MAILUSER -g daemon -m 0700 $SPOOLDIR
+ fi
do_notice
;;
*)