aboutsummaryrefslogtreecommitdiff
path: root/mail/milter-skem
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-08 12:07:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-08 12:07:09 +0000
commit8da335f97b8421284474e5a55cd30d1939ab05bb (patch)
tree1b5264d09a694c4bf17b4a433854626384002764 /mail/milter-skem
parent5ca09a9d3be358dcf769d31d2cc67201e4aeb1f6 (diff)
downloadports-8da335f97b8421284474e5a55cd30d1939ab05bb.tar.gz
ports-8da335f97b8421284474e5a55cd30d1939ab05bb.zip
getopt() returns `int' according to the standard, but was assigned to `char'
variable, and this can break the == -1 check. It works on i386, but not on PowerPC, where `char' is unsigned by default. Use variable of correct type (int) to hold the return value of getopt(3).
Notes
Notes: svn path=/head/; revision=396375
Diffstat (limited to 'mail/milter-skem')
-rw-r--r--mail/milter-skem/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/mail/milter-skem/Makefile b/mail/milter-skem/Makefile
index 1b133c3176c5..e846b2eac534 100644
--- a/mail/milter-skem/Makefile
+++ b/mail/milter-skem/Makefile
@@ -30,10 +30,6 @@ OPTIONS_DEFAULT= SKEM_NETINET
.include <bsd.port.options.mk>
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
-
MAKE_ENV+= PTHREAD_LIBS="-lpthread"
.for o in ${PORT_OPTIONS:MSKEM_*}
@@ -42,4 +38,7 @@ MAKE_ARGS+= -D$o
. endif
.endfor
+post-patch:
+ @${REINPLACE_CMD} -E 's/char[[:blank:]]+c;/int c;/' ${WRKSRC}/milter.c
+
.include <bsd.port.mk>