aboutsummaryrefslogtreecommitdiff
path: root/mail/mmh
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-05-05 09:16:52 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-05-05 09:16:52 +0000
commit08db3b55d213671fa45501a51293f23f6bc0cd96 (patch)
tree12671d7fcdfc193a03b0f7d566472730fff175a1 /mail/mmh
parentb2b052630aa6ddaea7438694285b2fb5f559ce27 (diff)
downloadports-08db3b55d213671fa45501a51293f23f6bc0cd96.tar.gz
ports-08db3b55d213671fa45501a51293f23f6bc0cd96.zip
New port: mail/mmh
Mmh is a modified version of the electronic mail handling system nmh. Nmh (new MH) itself was originally based on the package MH-6.8.3, and was intended to be a (mostly) compatible drop-in replacement for MH. In contrast, mmh is not intended to be a drop-in replacement for nmh, but rather aims for the modernization and simplification of nmh, accepting reduced compatiblity if it, at the same time, allows to achieve greater goals from mmh's point of view. WWW: http://marmaro.de/prog/mmh/ PR: 245346 Submitted by: satanist+freebsd@bureaucracy.de
Notes
Notes: svn path=/head/; revision=534046
Diffstat (limited to 'mail/mmh')
-rw-r--r--mail/mmh/Makefile50
-rw-r--r--mail/mmh/distinfo3
-rw-r--r--mail/mmh/files/patch-man_Makefile.in11
-rw-r--r--mail/mmh/files/patch-uip_Makefile.in68
-rw-r--r--mail/mmh/pkg-descr9
-rw-r--r--mail/mmh/pkg-plist140
6 files changed, 281 insertions, 0 deletions
diff --git a/mail/mmh/Makefile b/mail/mmh/Makefile
new file mode 100644
index 000000000000..dd31de8daccb
--- /dev/null
+++ b/mail/mmh/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= mmh
+PORTVERSION= 0.4
+CATEGORIES= mail
+MASTER_SITES= http://marmaro.de/prog/mmh/files/
+
+MAINTAINER= satanist+freebsd@bureaucracy.de
+COMMENT= CLI mail user agent, fork from nmh
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USE= iconv ncurses
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/mmh \
+ --sysconfdir=${ETCDIR} \
+ --bindir=${PREFIX}/bin \
+ --mandir=${PREFIX}/man \
+ --docdir=${DOCSDIR} \
+
+OPTIONS_SINGLE= LOCKING
+OPTIONS_SINGLE_LOCKING= DOT FCNTL FLOCK LOCKF
+
+DOT_DESC= Dot file locking
+DOT_CONFIGURE_ON= --with-locking=dot
+FCNTL_DESC= fcntl() file locking
+FCNTL_CONFIGURE_ON= --with-locking=fcntl
+FLOCK_DESC= flock() file locking
+FLOCK_CONFIGURE_ON= --with-locking=flock
+LOCKF_DESC= lockf file locking
+LOCKF_CONFIGURE_ON= --with-locking=lockf
+
+OPTIONS_DEFAULT= FLOCK
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+LDFLAGS+= -g
+DEBUG_FLAGS+= -O0 -Wall -Wextra -g
+.endif
+
+CONFLICTS= ja-mh-[0-9]* nmh-[0-9]* p5-Dist-Joseki-*
+
+post-install:
+ @${FIND} ${STAGEDIR}${ETCDIR} -type f -exec ${MV} {} {}.sample \;
+
+.include <bsd.port.mk>
diff --git a/mail/mmh/distinfo b/mail/mmh/distinfo
new file mode 100644
index 000000000000..b370001e13a4
--- /dev/null
+++ b/mail/mmh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585964548
+SHA256 (mmh-0.4.tar.gz) = cda8005bfd490c260d55edd8aa1d90f99a7997daf5e4271a91e423691929108e
+SIZE (mmh-0.4.tar.gz) = 1493406
diff --git a/mail/mmh/files/patch-man_Makefile.in b/mail/mmh/files/patch-man_Makefile.in
new file mode 100644
index 000000000000..145e9b00e820
--- /dev/null
+++ b/mail/mmh/files/patch-man_Makefile.in
@@ -0,0 +1,11 @@
+--- man/Makefile.in.orig 2020-04-04 04:12:02 UTC
++++ man/Makefile.in
+@@ -51,7 +51,7 @@ SEDMAN = $(SED) -f man.sed $< > $@
+
+ # man pages to install in $(mandir)/$(manext1)
+ MAN1SRC = ali. anno. burst. comp. dist. flist. flists. folder. folders. \
+- forw. inc. mark. mhbuild. mhl. mhlist. mhsign. mhpgp. mmh. mmhwrap. \
++ forw. inc. mark. mhbuild. mhl. mhlist. mhsign. mhpgp. mmh. \
+ mhmail. mhparam. mhpath. mhstore. new. fnext. \
+ fprev. unseen. next. packf. pick. prev. prompter. rcvdist. rcvpack. \
+ rcvstore. refile. repl. rmf. rmm. scan. send. sendfiles. \
diff --git a/mail/mmh/files/patch-uip_Makefile.in b/mail/mmh/files/patch-uip_Makefile.in
new file mode 100644
index 000000000000..f9217db4da09
--- /dev/null
+++ b/mail/mmh/files/patch-uip_Makefile.in
@@ -0,0 +1,68 @@
+--- uip/Makefile.in.orig 2019-01-06 17:33:10 UTC
++++ uip/Makefile.in
+@@ -50,17 +50,20 @@ SETGID_MAIL = @SETGID_MAIL@
+ $(COMPILE) $<
+
+ # commands to build
+-CMDS = ali anno burst comp dist flist folder forw mmh mark \
+- mhbuild mhl mhsign mhpgp \
++CMDS = ali anno burst comp dist flist folder forw mark \
++ mhbuild mhl \
+ mhlist mhmail mhparam mhpath mhstore new packf pick \
+- print-mimetype prompter rcvdist rcvpack rcvstore refile repl rmf \
+- rmm send sendfiles show slocal sortm spost whatnow whatnow2 whom
++ prompter rcvdist rcvpack rcvstore refile repl rmf \
++ rmm send show slocal sortm spost whatnow whom
+
++# commands that are written in shell
++# this is need to avoid call strip on this scripts
++SHELLSCRIPTS = mmh mhsign mhpgp sendfiles print-mimetype whatnow2
+ # commands that are links to other commands
+ LCMDS = flists folders next prev fnext fprev unseen scan
+
+ # misc support binaries
+-MISC = ap dp fmtdump mhtest mmhwrap
++MISC = ap dp fmtdump mhtest
+
+ # commands with 'S'pecial installation needs
+ SCMDS = inc
+@@ -68,7 +71,7 @@ SCMDS = inc
+ # source files
+ SRCS = ali.c aliasbr.c anno.c ap.c burst.c comp.c \
+ dist.c distsbr.c dp.c dropsbr.c flist.c fmtdump.c \
+- folder.c forw.c inc.c mark.c mmh.sh mmhwrap.sh mhbuild.c \
++ folder.c forw.c inc.c mark.c mmh.sh mhbuild.c \
+ mhfree.c mhl.c mhlist.c mhlistsbr.c mhsign.sh mhpgp.sh \
+ mhmail.c mhmisc.c mhoutsbr.c mhparam.c mhparse.c \
+ mhpath.c mhshow.c mhshowsbr.c mhstore.c mhtest.c \
+@@ -80,7 +83,7 @@ SRCS = ali.c aliasbr.c anno.c ap.c burst.c comp.c \
+
+ # ========== DEFAULT TARGET ==========
+
+-all: $(CMDS) $(MISC) $(SCMDS)
++all: $(CMDS) $(MISC) $(SCMDS) $(SHELLSCRIPTS)
+
+ # ========= DEPENDENCIES FOR BUILDING ==========
+
+@@ -231,13 +234,20 @@ whom: whom.o $(LOCALLIBS)
+ # ========== DEPENDENCIES FOR INSTALLING ==========
+
+ # install everything
+-install: install-cmds install-misc install-lcmds install-scmds
++install: install-cmds install-misc install-lcmds install-scmds install-shell
+
+ # install commands
+ install-cmds:
+ mkdir -p $(DESTDIR)$(bindir)
+ for cmd in $(CMDS); do \
+ $(INSTALL_PROGRAM) $$cmd $(DESTDIR)$(bindir)/$$cmd; \
++ done
++
++# install shellscripts
++install-shell:
++ mkdir -p $(DESTDIR)$(bindir)
++ for cmd in $(SHELLSCRIPTS); do \
++ $(INSTALL) $$cmd $(DESTDIR)$(bindir)/$$cmd; \
+ done
+
+ # install links
diff --git a/mail/mmh/pkg-descr b/mail/mmh/pkg-descr
new file mode 100644
index 000000000000..ce3ce5423c41
--- /dev/null
+++ b/mail/mmh/pkg-descr
@@ -0,0 +1,9 @@
+Mmh is a modified version of the electronic mail handling system nmh.
+Nmh (new MH) itself was originally based on the package MH-6.8.3, and
+was intended to be a (mostly) compatible drop-in replacement for MH.
+In contrast, mmh is not intended to be a drop-in replacement for nmh,
+but rather aims for the modernization and simplification of nmh,
+accepting reduced compatiblity if it, at the same time, allows to
+achieve greater goals from mmh's point of view.
+
+WWW: http://marmaro.de/prog/mmh/
diff --git a/mail/mmh/pkg-plist b/mail/mmh/pkg-plist
new file mode 100644
index 000000000000..1956098cc451
--- /dev/null
+++ b/mail/mmh/pkg-plist
@@ -0,0 +1,140 @@
+bin/ali
+bin/anno
+bin/burst
+bin/comp
+bin/dist
+bin/flist
+bin/flists
+bin/fnext
+bin/folder
+bin/folders
+bin/forw
+bin/fprev
+bin/inc
+bin/mark
+bin/mhbuild
+bin/mhl
+bin/mhlist
+bin/mhmail
+bin/mhparam
+bin/mhpath
+bin/mhpgp
+bin/mhsign
+bin/mhstore
+bin/mmh
+bin/new
+bin/next
+bin/packf
+bin/pick
+bin/prev
+bin/print-mimetype
+bin/prompter
+bin/rcvdist
+bin/rcvpack
+bin/rcvstore
+bin/refile
+bin/repl
+bin/rmf
+bin/rmm
+bin/scan
+bin/send
+bin/sendfiles
+bin/show
+bin/slocal
+bin/sortm
+bin/spost
+bin/unseen
+bin/whatnow
+bin/whatnow2
+bin/whom
+@sample %%ETCDIR%%/components.sample
+@sample %%ETCDIR%%/digestcomps.sample
+@sample %%ETCDIR%%/distcomps.sample
+@sample %%ETCDIR%%/forwcomps.sample
+@sample %%ETCDIR%%/mhl.body.sample
+@sample %%ETCDIR%%/mhl.format.sample
+@sample %%ETCDIR%%/mhl.forward.sample
+@sample %%ETCDIR%%/mhl.headers.sample
+@sample %%ETCDIR%%/mhl.reply.sample
+@sample %%ETCDIR%%/mhl.whatnow2.sample
+@sample %%ETCDIR%%/mhn.defaults.sample
+@sample %%ETCDIR%%/pick.default.sample
+@sample %%ETCDIR%%/rcvdistcomps.outbox.sample
+@sample %%ETCDIR%%/rcvdistcomps.sample
+@sample %%ETCDIR%%/replcomps.sample
+@sample %%ETCDIR%%/replgroupcomps.sample
+@sample %%ETCDIR%%/repllistcomps.sample
+@sample %%ETCDIR%%/scan.MMDDYY.sample
+@sample %%ETCDIR%%/scan.YYYYMMDD.sample
+@sample %%ETCDIR%%/scan.default.sample
+@sample %%ETCDIR%%/scan.mailx.sample
+@sample %%ETCDIR%%/scan.meillo.sample
+@sample %%ETCDIR%%/scan.nmh.sample
+@sample %%ETCDIR%%/scan.nomime.sample
+@sample %%ETCDIR%%/scan.size.sample
+@sample %%ETCDIR%%/scan.time.sample
+@sample %%ETCDIR%%/scan.timely.sample
+@sample %%ETCDIR%%/scan.unseen.sample
+libexec/mmh/ap
+libexec/mmh/dp
+libexec/mmh/fmtdump
+libexec/mmh/mhtest
+man/man1/ali.1.gz
+man/man1/anno.1.gz
+man/man1/burst.1.gz
+man/man1/comp.1.gz
+man/man1/dist.1.gz
+man/man1/flist.1.gz
+man/man1/flists.1.gz
+man/man1/fnext.1.gz
+man/man1/folder.1.gz
+man/man1/folders.1.gz
+man/man1/forw.1.gz
+man/man1/fprev.1.gz
+man/man1/inc.1.gz
+man/man1/mark.1.gz
+man/man1/mhbuild.1.gz
+man/man1/mhl.1.gz
+man/man1/mhlist.1.gz
+man/man1/mhmail.1.gz
+man/man1/mhparam.1.gz
+man/man1/mhpath.1.gz
+man/man1/mhpgp.1.gz
+man/man1/mhsign.1.gz
+man/man1/mhstore.1.gz
+man/man1/mmh.1.gz
+man/man1/new.1.gz
+man/man1/next.1.gz
+man/man1/packf.1.gz
+man/man1/pick.1.gz
+man/man1/prev.1.gz
+man/man1/prompter.1.gz
+man/man1/rcvdist.1.gz
+man/man1/rcvpack.1.gz
+man/man1/rcvstore.1.gz
+man/man1/refile.1.gz
+man/man1/repl.1.gz
+man/man1/rmf.1.gz
+man/man1/rmm.1.gz
+man/man1/scan.1.gz
+man/man1/send.1.gz
+man/man1/sendfiles.1.gz
+man/man1/show.1.gz
+man/man1/slocal.1.gz
+man/man1/sortm.1.gz
+man/man1/unseen.1.gz
+man/man1/whatnow.1.gz
+man/man1/whatnow2.1.gz
+man/man1/whom.1.gz
+man/man5/mh-alias.5.gz
+man/man5/mh-format.5.gz
+man/man5/mh-mail.5.gz
+man/man5/mh-profile.5.gz
+man/man7/mh-chart.7.gz
+man/man7/mh-draft.7.gz
+man/man7/mh-sequence.7.gz
+man/man7/mmh-intro.7.gz
+man/man8/ap.8.gz
+man/man8/dp.8.gz
+man/man8/fmtdump.8.gz
+man/man8/spost.8.gz