aboutsummaryrefslogtreecommitdiff
path: root/mail/mmr
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1997-11-01 14:15:14 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1997-11-01 14:15:14 +0000
commit9bc44cdb645b2518becb6088b1f4a6fd6aa4e5c0 (patch)
tree4d6f1f65bb29678ec196d22109bd9d3b1b82e3bc /mail/mmr
parent8e37d0b22951c6928f18e5e27340f2ff27fee7be (diff)
downloadports-9bc44cdb645b2518becb6088b1f4a6fd6aa4e5c0.tar.gz
ports-9bc44cdb645b2518becb6088b1f4a6fd6aa4e5c0.zip
Import of port for mmr 1.5.1
"My Mailer" is an incarnation of a UNIX text-based mailer designed to be an intermediate step between mail and pine. PR: ports/4831 Submitted by: andy@icc.surw.chel.su
Notes
Notes: svn path=/head/; revision=8432
Diffstat (limited to 'mail/mmr')
-rw-r--r--mail/mmr/Makefile21
-rw-r--r--mail/mmr/distinfo1
-rw-r--r--mail/mmr/files/patch-aa21
-rw-r--r--mail/mmr/files/patch-ab10
-rw-r--r--mail/mmr/files/patch-ac14
-rw-r--r--mail/mmr/pkg-comment1
-rw-r--r--mail/mmr/pkg-descr22
-rw-r--r--mail/mmr/pkg-plist1
8 files changed, 91 insertions, 0 deletions
diff --git a/mail/mmr/Makefile b/mail/mmr/Makefile
new file mode 100644
index 000000000000..a50a9e391b60
--- /dev/null
+++ b/mail/mmr/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: mmr
+# Version required: 1.5.1
+# Date created: 23 October 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= mmr-1.5.1
+CATEGORIES= mail
+MASTER_SITE_SUBDIR= system/mail/mua
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+
+MAINTAINER= andy@icc.surw.chel.su
+
+ALL_TARGET= mmr
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/mmr ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/mmr/distinfo b/mail/mmr/distinfo
new file mode 100644
index 000000000000..fbb187028cd0
--- /dev/null
+++ b/mail/mmr/distinfo
@@ -0,0 +1 @@
+MD5 (mmr-1.5.1.tar.gz) = ef6848e16a3957e6cbb08203a2316b56
diff --git a/mail/mmr/files/patch-aa b/mail/mmr/files/patch-aa
new file mode 100644
index 000000000000..086490a8d447
--- /dev/null
+++ b/mail/mmr/files/patch-aa
@@ -0,0 +1,21 @@
+--- Makefile.orig Mon Sep 22 16:20:20 1997
++++ Makefile Sat Nov 1 08:55:42 1997
+@@ -7,15 +7,15 @@
+ # (Toggled at runtime with ^T)
+ # -DMAILPATH=\"/some/path\"
+ # Set the default mail spool directory
+-DEFS = -DTHREADMAIL
++DEFS = -DTHREADMAIL -DMAILPATH=\"/var/mail\"
+
+ OBJS = main.o rcfile.o listing.o handlemail.o commands.o terminal.o mailmsg.o \
+ mime.o mimetype.o base64.o filemap.o iobottle.o my_regex.o outgoing.o \
+ md5/libmd5.a
+-LIBS = -lncurses
++LIBS = -lncurses -lcompat
+ CXX = g++
+ INCDIRS = -Imd5 -I/usr/include/ncurses
+-CXXFLAGS = $(DEFS) $(INCDIRS) -g
++CXXFLAGS = $(DEFS) $(INCDIRS) $(CFLAGS)
+
+ # Remind 'make' how to make C++ files.. *sigh*
+ include .c++howto
diff --git a/mail/mmr/files/patch-ab b/mail/mmr/files/patch-ab
new file mode 100644
index 000000000000..fa7c84e71873
--- /dev/null
+++ b/mail/mmr/files/patch-ab
@@ -0,0 +1,10 @@
+--- headers.h.orig Tue Feb 18 13:39:00 1997
++++ headers.h Sat Nov 1 08:55:42 1997
+@@ -12,4 +12,7 @@
+ #include <signal.h>
+ #include <errno.h>
+ #include <sys/ioctl.h>
++#ifdef __FreeBSD__
++extern char* cuserid(char*);
++#endif
+ }
diff --git a/mail/mmr/files/patch-ac b/mail/mmr/files/patch-ac
new file mode 100644
index 000000000000..f8e63a5f10e6
--- /dev/null
+++ b/mail/mmr/files/patch-ac
@@ -0,0 +1,14 @@
+--- terminal.h.orig Mon Jun 23 13:49:40 1997
++++ terminal.h Sat Nov 1 08:55:42 1997
+@@ -13,7 +13,11 @@
+ extern "C" {
+ #include <stdlib.h>
+ #include <stdarg.h>
++#ifdef __FreeBSD__
++#include <ncurses.h>
++#else
+ #include <curses.h>
++#endif
+ }
+
+ /* Note that screen coordinates start at (1,1) */
diff --git a/mail/mmr/pkg-comment b/mail/mmr/pkg-comment
new file mode 100644
index 000000000000..b7b6ee3f0216
--- /dev/null
+++ b/mail/mmr/pkg-comment
@@ -0,0 +1 @@
+A curses based MIME aware mailer
diff --git a/mail/mmr/pkg-descr b/mail/mmr/pkg-descr
new file mode 100644
index 000000000000..9d003c9a954f
--- /dev/null
+++ b/mail/mmr/pkg-descr
@@ -0,0 +1,22 @@
+ "My Mailer" is an incarnation of a UNIX text-based mailer
+designed to be an intermediate step between mail and pine.
+
+ Features:
+
+ MIME aware -- While this mailer does not implement a full set of
+the MIME mail extensions, it should handle most MIME mail.
+It also handles some Sun mail attachment formats.
+
+ Threaded messages -- Articles by default are threaded by subject.
+This allows one to plow through huge mailing list discussions,
+sometimes spanning weeks, with very little effort.
+
+ Automatic detection of a modified mail file, and the changes will
+then be merged with the current message listing.
+
+ Automatically uncompresses and recompresses gzipped mailfiles
+
+ Searchable message listings, including search through message text
+
+ Automatic ignoring of certain MIME types.
+ Get rid of those Micrsoft Exchange MIME trailers.
diff --git a/mail/mmr/pkg-plist b/mail/mmr/pkg-plist
new file mode 100644
index 000000000000..f0f613d4508e
--- /dev/null
+++ b/mail/mmr/pkg-plist
@@ -0,0 +1 @@
+bin/mmr