aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2019-04-04 04:07:17 +0000
committerAlex Kozlov <ak@FreeBSD.org>2019-04-04 04:07:17 +0000
commit257ee95ea262e37966669ea42adde4fcc5caa8a1 (patch)
tree2805736710d448c7587e4279586c54a81534156b /mail/mutt/Makefile
parentbded1c3784d29917b4c31f09c7a9c151fa610f04 (diff)
downloadports-257ee95ea262e37966669ea42adde4fcc5caa8a1.tar.gz
ports-257ee95ea262e37966669ea42adde4fcc5caa8a1.zip
- Cleanup LDFLAGS, CONFIGURE_ENV [1]
- Fix non-default LOCALBASE for aspell [1] - Remove unused extra-patch-parent-child-match PR: 236189 Submitted by: John Hein <jcfyecrayz@liamekaens.com> [1] Approved by: Derek Schrock <dereks@lifeofadishwasher.com> (maintainer)
Notes
Notes: svn path=/head/; revision=497785
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 65db75a46c06..6ac1ed3e7d97 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -30,7 +30,6 @@ USES= cpe shebangfix ssl
CONFLICTS= ja-mutt-[0-9]* ja-mutt-devel-[0-9]* mutt-1.4* mutt-devel-lite-[0-9]* mutt-lite-[0-9]* zh-mutt-devel-[0-9]*
-CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include"
CONFIGURE_ARGS= --disable-fcntl --with-ssl=${OPENSSLBASE} \
--with-docdir=${DOCSDIR} --sysconfdir=${PREFIX}/etc \
--enable-external-dotlock --enable-pop --enable-imap \
@@ -130,20 +129,19 @@ GSSAPI_NONE_CONFIGURE_ON= --without-gss
HCACHE_NONE_CONFIGURE_ON= --disable-hcache
HCACHE_NONE_CONFIGURE_OFF= --enable-hcache --without-qdbm --without-gdbm
-HCACHE_BDB_CONFIGURE_WITH= bdb
+HCACHE_BDB_CONFIGURE_WITH= bdb=${LOCALBASE}
HCACHE_BDB_USES= bdb:42+
-HCACHE_TOKYOCABINET_CONFIGURE_WITH= tokyocabinet
+HCACHE_TOKYOCABINET_CONFIGURE_WITH= tokyocabinet=${LOCALBASE}
HCACHE_TOKYOCABINET_LIB_DEPENDS= libtokyocabinet.so:databases/tokyocabinet
-HCACHE_KYOTOCABINET_CONFIGURE_WITH= kyotocabinet
+HCACHE_KYOTOCABINET_CONFIGURE_WITH= kyotocabinet=${LOCALBASE}
HCACHE_KYOTOCABINET_LIB_DEPENDS= libkyotocabinet.so:databases/kyotocabinet
ICONV_USES= iconv:translit
ICONV_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
ICONV_CONFIGURE_OFF= --disable-iconv
-ASPELL_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aspell
REVERSE_REPLY_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-reverse_reply
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
@@ -158,7 +156,7 @@ LOCALES_FIX_CONFIGURE_ON= --enable-locales-fix
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
-IDN_CONFIGURE_WITH= idn2
+IDN_CONFIGURE_WITH= idn2=${LOCALBASE}
IDN_IMPLIES= ICONV
IFDEF_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ifdef
@@ -197,8 +195,6 @@ VVV_PATCH_VERSION= ${PORTVERSION}
GREETING_PATCH_VERSION= ${PORTVERSION}
.endif
-LDFLAGS+= -L${LOCALBASE}/lib -Wl,-rpath=${LOCALBASE}/lib:/usr/lib -ltinfow
-
post-patch-NNTP-on:
# Restore timestamps for autotools sources
@${TOUCH} -r ${WRKSRC}/configure.ac.orig ${WRKSRC}/configure.ac
@@ -241,6 +237,11 @@ pre-configure::
@${REINPLACE_CMD} -e 's#$$(docdir)/samples#${EXAMPLESDIR}#g' \
${WRKSRC}/contrib/Makefile.in
+pre-configure-ASPELL-on:
+ @${REINPLACE_CMD} -e '/^# append-hook/p' \
+ -e 's/^# append-hook.*$$/set ispell="aspell --mode=email check"/' \
+ ${WRKSRC}/doc/Muttrc.head
+
pre-configure-HCACHE_BDB-on:
@${REINPLACE_CMD} -E -e 's/BDB_VERSIONS="/&${BDB_LIB_NAME} db${BDB_VER} /' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}