aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2018-05-21 20:39:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2018-05-21 20:39:16 +0000
commit4dad82591b9974ef451cccb3180dd0091322c55c (patch)
treed2f8332924d428983daf79812181be74123881d9 /mail/mutt/Makefile
parent3c652549d38450e0f34388d7226c9273e3a90f23 (diff)
downloadports-4dad82591b9974ef451cccb3180dd0091322c55c.tar.gz
ports-4dad82591b9974ef451cccb3180dd0091322c55c.zip
Update to 1.10.0
PR: 228387 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=470574
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index c2a47d73d4d9..116555d1b425 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= mutt
-DISTVERSION= 1.9.5
-PORTREVISION?= 1
+DISTVERSION= 1.10.0
+PORTREVISION?= 0
CATEGORIES+= mail ipv6
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
@@ -11,7 +11,6 @@ MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.demon.co.uk/pub/mirrors/mutt/ \
http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
http://www2.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= mutt
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -174,8 +173,8 @@ FLOCK_CONFIGURE_ENABLE= flock
LOCALES_FIX_CONFIGURE_ON= --enable-locales-fix
-IDN_LIB_DEPENDS= libidn.so:dns/libidn
-IDN_CONFIGURE_WITH= idn
+IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
+IDN_CONFIGURE_WITH= idn2
IDN_IMPLIES= ICONV
IFDEF_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ifdef
@@ -192,6 +191,7 @@ GREETING_PATCH_PATCHFILES= mutt-${GREETING_PATCH_VERSION}.vc.greeting:vc
QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.gz:vvv \
patch-${VVV_PATCH_VERSION}.vvv.quote.gz:vvv
+NNTP_BROKEN= NNTP Patch needs updated for 1.10.x
NNTP_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.nntp.gz:-p1:vvv
NNTP_CONFIGURE_ON= --enable-nntp
NNTP_VARS= XML_NEEDED=yes
@@ -203,8 +203,8 @@ DOCS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-doc-ref
.include <bsd.port.options.mk>
# un/comment as each VERSION is created for PORTVERSION
-#VVV_PATCH_VERSION= 1.9.5
-#GREETING_PATCH_VERSION= 1.9.5
+VVV_PATCH_VERSION= 1.9.5
+GREETING_PATCH_VERSION= 1.9.5
.if !defined(VVV_PATCH_VERSION)
VVV_PATCH_VERSION= ${PORTVERSION}