aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1996-11-10 09:37:26 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1996-11-10 09:37:26 +0000
commita3612b8f34213db347203a720f7f58517fcb9df4 (patch)
treeb9c58ce787d934c6b9c9f7f441cc256b7f55575a /mail/mutt/Makefile
parentbd990e6999d23a4ac713737af7fc03b713f29041 (diff)
downloadports-a3612b8f34213db347203a720f7f58517fcb9df4.tar.gz
ports-a3612b8f34213db347203a720f7f58517fcb9df4.zip
Mutt -- "The Mongrel of Mail User Agents" (part Elm, part Pine, part mh,
part everything else) is an interactive screen-oriented mailer program that supersedes Elm, Pine, mail and mailx. This version of the port does *not* support PGP. The author considers the distfile with PGP hooks to be covered under ITAR. I have a PGP suporting mutt port that I will commit later.
Notes
Notes: svn path=/head/; revision=4368
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
new file mode 100644
index 000000000000..79c46f4c47f5
--- /dev/null
+++ b/mail/mutt/Makefile
@@ -0,0 +1,49 @@
+# ex:ts=8
+# New ports collection makefile for: mutt
+# Version required: 0.xy
+# Date created: Thur July 25, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id$
+
+DISTNAME= ${PKGNAME}-export
+PKGNAME= mutt-0.49
+CATEGORIES+= mail
+MASTER_SITES= ftp://cs.hmc.edu/pub/me/mutt/ \
+ ftp://ftp.ibp.fr/pub/unix/mail/mutt/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
+ ftp://ftp.teuto.de/pub/user/lmb/ \
+ ftp://ftp.funet.fi/pub/unix/mail/mutt/ \
+PATCH_SITES= ftp://nuxi.cs.ucdavis.edu/pub/mutt/${PKGNAME:S/^mutt-//}/ \
+ http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
+ http://www.math.fu-berlin.fr/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
+ http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
+ ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/
+PATCHFILES= 03.typo.PATCH \
+ 04.man.PATCH \
+ 05.michael.PATCH \
+ 06.newmail.PATCH \
+ 07.pop.PATCH \
+ 09.search.PATCH \
+ 10.mimefwd.PATCH
+DIST_SUBDIR= Mutt_${PKGNAME:S/^mutt-//}
+
+MAINTAINER= obrien@cs.ucdavis.edu
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+PATCH_DIST_STRIP=
+GNU_CONFIGURE= yes
+
+
+post-install:
+ @#### don't strip until out of beta peroid
+ @#strip ${PREFIX}/bin/mutt
+ @gzip -9nf ${PREFIX}/man/man1/mutt.1
+.if !defined(NOPORTDOCS)
+ @${ECHO} "Installing Mutt documentation"
+ @${MKDIR} ${PREFIX}/share/doc/mutt && chmod a+rx ${PREFIX}/share/doc/mutt
+ @${INSTALL_DATA} ${WRKSRC}/doc/*.html ${WRKSRC}/doc/*.txt \
+ ${PREFIX}/share/doc/mutt
+.endif
+
+.include <bsd.port.mk>