aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-10-31 10:51:43 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-10-31 10:51:43 +0000
commitef24f19ee87c0a94a3074c3a5b31afca7249b65c (patch)
tree4a48443688f6a7003ae28be1ef7a4517ed47a902 /mail/mutt/Makefile
parent9d2925a1dc137ba17145ce6094e60857a2130550 (diff)
downloadports-ef24f19ee87c0a94a3074c3a5b31afca7249b65c.tar.gz
ports-ef24f19ee87c0a94a3074c3a5b31afca7249b65c.zip
Add compressed and encrypted folders support.
Submitted by: ru
Notes
Notes: svn path=/head/; revision=34488
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index f65873e48395..88742eec74a5 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -21,12 +21,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}i
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} charmaps-0.0.tar.gz
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-PATCH_SITES= http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
+PATCH_SITES= http://www.spinnaker.de/mutt/compressed/ \
+ http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
http://www.math.fu-berlin.de/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
ftp://riemann.iam.uni-bonn.de/pub/mutt/
-PATCHFILES=
+PATCHFILES= patch-${PORTVERSION}.rr.compressed.1.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= obrien@FreeBSD.org
@@ -62,7 +63,8 @@ CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
--with-sharedir=${PREFIX}/share/mutt \
- --with-docdir=${PREFIX}/share/doc/mutt --with-charmaps
+ --with-docdir=${PREFIX}/share/doc/mutt --with-charmaps \
+ --enable-compressed
.if defined(WITH_LOCALES_FIX)
CONFIGURE_ARGS+= --enable-locales-fix
.endif