aboutsummaryrefslogtreecommitdiff
path: root/mail/nmh
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2013-01-03 20:57:17 +0000
committerCy Schubert <cy@FreeBSD.org>2013-01-03 20:57:17 +0000
commit37c4c9da748413d16c3370c625327b6b7f2a6713 (patch)
treea413b83e6e8624e53a5b5b23b58ab05af0c248de /mail/nmh
parentcc2e0c5bf52ab34bf8c92e107a24a6e4d2ecd2c0 (diff)
downloadports-37c4c9da748413d16c3370c625327b6b7f2a6713.tar.gz
ports-37c4c9da748413d16c3370c625327b6b7f2a6713.zip
update 1.3 --> 1.5.
Assume maintainership. PR: 174312 Submitted by: cy Approved by: Maintainer timeout
Notes
Notes: svn path=/head/; revision=309906
Diffstat (limited to 'mail/nmh')
-rw-r--r--mail/nmh/Makefile18
-rw-r--r--mail/nmh/distinfo4
-rw-r--r--mail/nmh/files/extra-patch-utmpx62
-rw-r--r--mail/nmh/files/patch-Makefile.in44
-rw-r--r--mail/nmh/files/patch-etc_Makefile_in26
-rw-r--r--mail/nmh/pkg-plist32
6 files changed, 84 insertions, 102 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index 6addc780943a..0061039bc431 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -52,18 +52,16 @@
#
PORTNAME= nmh
-PORTVERSION= 1.3
-PORTREVISION= 1
+PORTVERSION= 1.5
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= nmh
-MAINTAINER= scott+ports@sabami.seaslug.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= A cleaned up MH mailer suite
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
--sysconfdir=${PREFIX}/etc/nmh
.ifdef NMH_EDITOR
@@ -100,23 +98,21 @@ OPTIONS= SASL2 "Cyrus SASL2" OFF
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 900007
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-utmpx
-.endif
+CONFIGURE_ARGS+= --docdir=${DOCSDIR}
.if defined(WITH_SASL2)
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-cyrus-sasl=${PREFIX}
.endif
-MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 flist.1 flists.1 \
- folder.1 folders.1 forw.1 inc.1 install-mh.1 mark.1 \
+MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 flist.1 flists.1 fnext.1 \
+ folder.1 folders.1 forw.1 fprev.1 inc.1 install-mh.1 mark.1 \
mh-chart.1 mhbuild.1 mhl.1 mhlist.1 mhmail.1 mhn.1 \
mhparam.1 mhpath.1 mhshow.1 mhstore.1 msgchk.1 msh.1 \
- next.1 nmh.1 packf.1 pick.1 prev.1 prompter.1 rcvdist.1 \
+ next.1 new.1 nmh.1 packf.1 pick.1 prev.1 prompter.1 rcvdist.1 \
rcvpack.1 rcvstore.1 rcvtty.1 refile.1 repl.1 rmf.1 rmm.1 \
scan.1 send.1 sendfiles.1 show.1 slocal.1 \
- sortm.1 whatnow.1 whom.1
+ sortm.1 unseen.1 whatnow.1 whom.1
MAN5= mh-alias.5 mh-draft.5 mh-format.5 mh-mail.5 mh-profile.5 \
mh-sequence.5 mh-tailor.5 mts.conf.5
diff --git a/mail/nmh/distinfo b/mail/nmh/distinfo
index 174474e0944a..6f724b1bfaff 100644
--- a/mail/nmh/distinfo
+++ b/mail/nmh/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nmh-1.3.tar.gz) = 9f16848424489b5a9f7c1402c87665dc56dcadecf6e5c44fb608aef0d1b03b47
-SIZE (nmh-1.3.tar.gz) = 847614
+SHA256 (nmh-1.5.tar.gz) = af5342de8fe9fba5d615caccc9fbcb43cac60b6eb71432f7e112d43850d31c39
+SIZE (nmh-1.5.tar.gz) = 935919
diff --git a/mail/nmh/files/extra-patch-utmpx b/mail/nmh/files/extra-patch-utmpx
deleted file mode 100644
index 5f23dbe7f934..000000000000
--- a/mail/nmh/files/extra-patch-utmpx
+++ /dev/null
@@ -1,62 +0,0 @@
---- uip/rcvtty.c.orig 2011-06-01 20:53:01.000000000 -0400
-+++ uip/rcvtty.c 2011-06-01 20:54:30.000000000 -0400
-@@ -23,7 +23,7 @@
- #include <signal.h>
- #include <fcntl.h>
-
--#include <utmp.h>
-+#include <utmpx.h>
-
- #ifndef HAVE_GETUTENT
- # ifndef UTMP_FILE
-@@ -95,7 +95,7 @@
- #ifdef HAVE_GETUTENT
- struct utmp * utp;
- #else
-- struct utmp ut;
-+ struct utmpx ut;
- register FILE *uf;
- #endif
-
-@@ -193,8 +193,8 @@
- if ((uf = fopen (UTMP_FILE, "r")) == NULL)
- exit (RCV_MBX);
- while (fread ((char *) &ut, sizeof(ut), 1, uf) == 1)
-- if (ut.ut_name[0] != 0
-- && strncmp (user, ut.ut_name, sizeof(ut.ut_name)) == 0) {
-+ if (ut.ut_user[0] != 0
-+ && strncmp (user, ut.ut_user, sizeof(ut.ut_user)) == 0) {
- strncpy (tty, ut.ut_line, sizeof(ut.ut_line));
- alert (tty, md);
- }
---- uip/slocal.c.orig 2011-06-01 20:54:37.000000000 -0400
-+++ uip/slocal.c 2011-06-01 20:55:56.000000000 -0400
-@@ -56,7 +56,7 @@
- #include NDBM_HEADER
- #endif
-
--#include <utmp.h>
-+#include <utmpx.h>
-
- #ifndef HAVE_GETUTENT
- # ifndef UTMP_FILE
-@@ -979,7 +979,7 @@
- static int
- logged_in (void)
- {
-- struct utmp ut;
-+ struct utmpx ut;
- FILE *uf;
-
- if (utmped)
-@@ -989,8 +989,8 @@
- return NOTOK;
-
- while (fread ((char *) &ut, sizeof(ut), 1, uf) == 1) {
-- if (ut.ut_name[0] != 0
-- && strncmp (user, ut.ut_name, sizeof(ut.ut_name)) == 0) {
-+ if (ut.ut_user[0] != 0
-+ && strncmp (user, ut.ut_user, sizeof(ut.ut_user)) == 0) {
- if (debug)
- continue;
- fclose (uf);
diff --git a/mail/nmh/files/patch-Makefile.in b/mail/nmh/files/patch-Makefile.in
new file mode 100644
index 000000000000..f652f934a21a
--- /dev/null
+++ b/mail/nmh/files/patch-Makefile.in
@@ -0,0 +1,44 @@
+--- Makefile.in.orig 2012-12-09 14:41:01.479883313 -0800
++++ Makefile.in 2012-12-09 14:48:13.430726025 -0800
+@@ -3573,16 +3573,16 @@
+ @list='$(dist_sysconf_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
+- echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
++ echo " $(dist_sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f-dist'"; \
++ $(dist_sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f-dist"; \
+ done
+
+ uninstall-dist_sysconfDATA:
+ @$(NORMAL_UNINSTALL)
+ @list='$(dist_sysconf_DATA)'; for p in $$list; do \
+ f=$(am__strip_dir) \
+- echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- rm -f "$(DESTDIR)$(sysconfdir)/$$f"; \
++ echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f-dist'"; \
++ rm -f "$(DESTDIR)$(sysconfdir)/$$f-dist"; \
+ done
+ install-sysconfDATA: $(sysconf_DATA)
+ @$(NORMAL_INSTALL)
+@@ -3590,16 +3590,16 @@
+ @list='$(sysconf_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
+- echo " $(sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- $(sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f"; \
++ echo " $(sysconfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(sysconfdir)/$$f-dist'"; \
++ $(sysconfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(sysconfdir)/$$f-dist"; \
+ done
+
+ uninstall-sysconfDATA:
+ @$(NORMAL_UNINSTALL)
+ @list='$(sysconf_DATA)'; for p in $$list; do \
+ f=$(am__strip_dir) \
+- echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f'"; \
+- rm -f "$(DESTDIR)$(sysconfdir)/$$f"; \
++ echo " rm -f '$(DESTDIR)$(sysconfdir)/$$f-dist'"; \
++ rm -f "$(DESTDIR)$(sysconfdir)/$$f-dist"; \
+ done
+
+ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
diff --git a/mail/nmh/files/patch-etc_Makefile_in b/mail/nmh/files/patch-etc_Makefile_in
deleted file mode 100644
index 795a5f176004..000000000000
--- a/mail/nmh/files/patch-etc_Makefile_in
+++ /dev/null
@@ -1,26 +0,0 @@
---- etc/Makefile.in.orig 2006-03-04 17:14:18.000000000 -0500
-+++ etc/Makefile.in 2011-06-01 20:41:11.000000000 -0400
-@@ -100,22 +100,7 @@
- for path in $$INSTALL_FILES; do \
- file=`basename $$path`; \
- echo "Installing $$file..."; \
-- if [ -f $(DESTDIR)$(etcdir)/$$file ]; then \
-- mv $(DESTDIR)$(etcdir)/$$file $(DESTDIR)$(etcdir)/$$file.prev; \
-- $(INSTALL_DATA) $$path $(DESTDIR)$(etcdir)/$$file; \
-- if diff $(DESTDIR)$(etcdir)/$$file.prev $(DESTDIR)$(etcdir)/$$file; then \
-- rm $(DESTDIR)$(etcdir)/$$file.prev; \
-- else \
-- echo; \
-- echo " Previous version of $$file saved as $$file.prev due\c";\
-- echo " to diffs."; \
-- echo " Please merge any local config changes into the new\c"; \
-- echo " $$file."; \
-- echo; \
-- fi; \
-- else \
-- $(INSTALL_DATA) $$path $(DESTDIR)$(etcdir)/$$file; \
-- fi; \
-+ $(INSTALL_DATA) $$path $(DESTDIR)$(etcdir)/$$file-dist; \
- done
-
- uninstall: uninstall-bin-files uninstall-etc-files
diff --git a/mail/nmh/pkg-plist b/mail/nmh/pkg-plist
index 5a6265852cca..885c1d06d81a 100644
--- a/mail/nmh/pkg-plist
+++ b/mail/nmh/pkg-plist
@@ -5,9 +5,11 @@ bin/comp
bin/dist
bin/flist
bin/flists
+bin/fnext
bin/folder
bin/folders
bin/forw
+bin/fprev
bin/inc
bin/install-mh
bin/mark
@@ -22,6 +24,7 @@ bin/mhstore
bin/msgchk
bin/msh
bin/next
+bin/new
bin/packf
bin/pick
bin/prev
@@ -35,6 +38,7 @@ bin/send
bin/sendfiles
bin/show
bin/sortm
+bin/unseen
bin/whatnow
bin/whom
@unexec if cmp -s %D/etc/nmh/MailAliases %D/etc/nmh/MailAliases-dist; then rm -f %D/etc/nmh/MailAliases; else echo 'Local changes: %D/etc/nmh/MailAliases (not removed)' >&2; fi
@@ -88,6 +92,7 @@ etc/nmh/replcomps-dist
@unexec if cmp -s %D/etc/nmh/replgroupcomps %D/etc/nmh/replgroupcomps-dist; then rm -f %D/etc/nmh/replgroupcomps; else echo 'Local changes: %D/etc/nmh/replgroupcomps (not removed)' >&2; fi
etc/nmh/replgroupcomps-dist
@exec [ -f %D/etc/nmh/replgroupcomps ] || cp %D/etc/nmh/replgroupcomps-dist %D/etc/nmh/replgroupcomps
+@unexec if cmp -s %D/etc/nmh/scan.MMDDYY %D/etc/nmh/scan-dist; then rm -f %D/etc/nmh/scan; else echo 'Local changes: %D/etc/nmh/scan (not removed)' >&2; fi
@unexec if cmp -s %D/etc/nmh/scan.MMDDYY %D/etc/nmh/scan.MMDDYY-dist; then rm -f %D/etc/nmh/scan.MMDDYY; else echo 'Local changes: %D/etc/nmh/scan.MMDDYY (not removed)' >&2; fi
etc/nmh/scan.MMDDYY-dist
@exec [ -f %D/etc/nmh/scan.MMDDYY ] || cp %D/etc/nmh/scan.MMDDYY-dist %D/etc/nmh/scan.MMDDYY
@@ -129,5 +134,30 @@ libexec/nmh/rcvtty
libexec/nmh/slocal
libexec/nmh/spost
libexec/nmh/viamail
-@dirrm etc/nmh
+%%DOCSDIR%%/README.about
+%%DOCSDIR%%/MAILING-LISTS
+%%DOCSDIR%%/README.SASL
+%%DOCSDIR%%/COPYRIGHT
+%%DOCSDIR%%/README.manpages
+%%DOCSDIR%%/MAIL.FILTERING
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README-components
+%%DOCSDIR%%/README-ATTACHMENTS
+%%DOCSDIR%%/COMPLETION-ZSH
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README-HOOKS
+%%DOCSDIR%%/FAQ
+%%DOCSDIR%%/contrib/build_nmh
+%%DOCSDIR%%/contrib/nmh.spec
+%%DOCSDIR%%/contrib/replyfilter
+%%DOCSDIR%%/DIFFERENCES
+%%DOCSDIR%%/COMPLETION-BASH
+%%DOCSDIR%%/README.developers
+%%DOCSDIR%%/COMPLETION-TCSH
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/TODO
+%%DOCSDIR%%/VERSION
+@dirrmtry etc/nmh
@dirrm libexec/nmh
+@dirrm %%DOCSDIR%%/contrib
+@dirrm %%DOCSDIR%%