aboutsummaryrefslogtreecommitdiff
path: root/mail/nmh
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-04-27 14:02:23 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-04-27 14:02:23 +0000
commit49d0280e093b4756714f7233962036ba5976607d (patch)
treee3af57a4e1592d41dd6a87e4bbb86185a1788f71 /mail/nmh
parentf500c5ce375ba301aee74ec2fed0083835c6ad0a (diff)
downloadports-49d0280e093b4756714f7233962036ba5976607d.tar.gz
ports-49d0280e093b4756714f7233962036ba5976607d.zip
- Update to 1.0.4.
- Add a couple Makefile knobs to go with some new configure script options. PR: ports/18035 Submitted by: MAINTAINER - Get rid of an insecure command (`chmod +w configure') and whole pre-configure target, which seems unnecessary now. (the port successfully builds without it) - Use tab instead of space in suitable points. - Use `${...}' instead of `$(...)'.
Notes
Notes: svn path=/head/; revision=28039
Diffstat (limited to 'mail/nmh')
-rw-r--r--mail/nmh/Makefile59
-rw-r--r--mail/nmh/distinfo2
-rw-r--r--mail/nmh/pkg-plist2
3 files changed, 40 insertions, 23 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index f60bb90310dc..9bd242a82450 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -30,20 +30,32 @@
# NMH_LOCKING - specify the style of locking to be used by nmh for the
# users' spool files (e.g. the 'inc' command). Must match the
# locking style used by your MTA - the default is FLOCK_LOCKING
-# (the documented behavior for the 'mail.local' delivery
-# program).
+# (the documented behavior for the 'mail.local' delivery program).
+# Do a 'make patch', then look in the source directory (currently
+# the config.h.in file) for more information on different locking
+# settings. Current valid settings are:
+# DOT_LOCKING FCNTL_LOCKING LOCKF_LOCKING FLOCK_LOCKING
+#
+# NMH_MASQUERADE - specify the type(s) of masquerading to allow. This
+# is passed through to nmh's "--enable-masquerade" configure
+# option and the current syntax for that string is:
+# 'draft_from[ mmailid[ username_extension]]'
+#
+# NMH_SMTPSERVERS - specify a blank-separated list of SMTP servers -
+# passed through to nmh's configure scripts '--with-smtpservers'
+# option.
#
PORTNAME= nmh
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= mail
MASTER_SITES= ftp://ftp.mhost.com/pub/nmh/ \
http://people.FreeBSD.org/~jkoshy/PORTS/
-MAINTAINER= Scott.Blachowicz@seaslug.org
+MAINTAINER= Scott.Blachowicz@seaslug.org
-USE_AUTOCONF= yes
-CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
+USE_AUTOCONF= yes
+CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
--sysconfdir=${PREFIX}/etc/nmh --enable-nmh-pop
.ifdef NMH_MTS
CONFIGURE_ARGS+= --with-mts=${NMH_MTS}
@@ -51,34 +63,37 @@ CONFIGURE_ARGS+= --with-mts=${NMH_MTS}
.ifdef NMH_EDITOR
CONFIGURE_ARGS+= --with-editor=${NMH_EDITOR}
.endif
+.ifdef NMH_MASQUERADE
+CONFIGURE_ARGS+= --enable-masquerade="${NMH_MASQUERADE}"
+.endif
.ifdef NMH_PAGER
CONFIGURE_ARGS+= --with-pager=${NMH_PAGER}
.endif
+.ifdef NMH_SMTPSERVERS
+CONFIGURE_ARGS+= --with-smtpservers="${NMH_SMTPSERVERS}"
+.endif
.ifndef NMH_LOCKING
NMH_LOCKING=FLOCK_LOCKING
.endif
-CFLAGS+= -D$(NMH_LOCKING)
-
-MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 flist.1 folder.1 forw.1 \
- inc.1 mark.1 mh-chart.1 mhbuild.1 mhl.1 mhlist.1 mhmail.1 \
- mhn.1 mhparam.1 mhpath.1 mhshow.1 mhstore.1 msgchk.1 msh.1 \
- next.1 nmh.1 packf.1 pick.1 prev.1 prompter.1 rcvdist.1 \
- rcvpack.1 rcvstore.1 rcvtty.1 refile.1 repl.1 rmf.1 rmm.1 \
- scan.1 send.1 sendfiles.1 show.1 slocal.1 sortm.1 \
- vmh.1 whatnow.1 whom.1
+CFLAGS+= -D${NMH_LOCKING}
-MAN5= mh-alias.5 mh-draft.5 mh-format.5 mh-mail.5 mh-profile.5 \
- mh-sequence.5 mh-tailor.5
-MLINKS= mh-profile.5 mh_profile.5
+MAN1= ali.1 anno.1 burst.1 comp.1 dist.1 flist.1 folder.1 forw.1 \
+ inc.1 mark.1 mh-chart.1 mhbuild.1 mhl.1 mhlist.1 mhmail.1 \
+ mhn.1 mhparam.1 mhpath.1 mhshow.1 mhstore.1 msgchk.1 msh.1 \
+ next.1 nmh.1 packf.1 pick.1 prev.1 prompter.1 rcvdist.1 \
+ rcvpack.1 rcvstore.1 rcvtty.1 refile.1 repl.1 rmf.1 rmm.1 \
+ scan.1 send.1 sendfiles.1 show.1 slocal.1 sortm.1 \
+ vmh.1 whatnow.1 whom.1
-MAN8= ap.8 conflict.8 dp.8 fmtdump.8 install-mh.8 mh-mts.8 post.8
+MAN5= mh-alias.5 mh-draft.5 mh-format.5 mh-mail.5 mh-profile.5 \
+ mh-sequence.5 mh-tailor.5
+MLINKS= mh-profile.5 mh_profile.5
-pre-configure:
- cd ${WRKSRC}; chmod +w configure
+MAN8= ap.8 conflict.8 dp.8 fmtdump.8 install-mh.8 mh-mts.8 post.8
post-install:
- @PKG_PREFIX='${PREFIX}' sh ${PKGDIR}/INSTALL
+ @PKG_PREFIX='${PREFIX}' ${SH} ${PKGDIR}/INSTALL
chgrp mail ${PREFIX}/bin/inc
${CHMOD} g+s ${PREFIX}/bin/inc
diff --git a/mail/nmh/distinfo b/mail/nmh/distinfo
index 4d7dd673daf9..7cdbcaee8c96 100644
--- a/mail/nmh/distinfo
+++ b/mail/nmh/distinfo
@@ -1 +1 @@
-MD5 (nmh-1.0.3.tar.gz) = 02519bf8f7ff8590ecfbee9f9500ea07
+MD5 (nmh-1.0.4.tar.gz) = fd0dc5c84f67cfbcdfdc1196a5298e47
diff --git a/mail/nmh/pkg-plist b/mail/nmh/pkg-plist
index 7fe0d44cb194..1ccf5264b9ef 100644
--- a/mail/nmh/pkg-plist
+++ b/mail/nmh/pkg-plist
@@ -54,6 +54,8 @@ etc/nmh/rcvdistcomps
etc/nmh/rcvdistcomps.outbox
etc/nmh/replcomps
etc/nmh/replgroupcomps
+etc/nmh/scan.MMDDYY
+etc/nmh/scan.YYYYMMDD
etc/nmh/scan.default
etc/nmh/scan.mailx
etc/nmh/scan.nomime