aboutsummaryrefslogtreecommitdiff
path: root/mail/nmh
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-07-03 19:45:00 +0000
committerCy Schubert <cy@FreeBSD.org>2019-07-03 19:45:00 +0000
commitfb99a1bf170fb64c0d29940ce70cfe43fac0095a (patch)
treea6b03ca9dafc4e4a46489a7aa2ef5b06ef40ce15 /mail/nmh
parentf802e843f666c8f7889c29401b7f71fd31a51d30 (diff)
downloadports-fb99a1bf170fb64c0d29940ce70cfe43fac0095a.tar.gz
ports-fb99a1bf170fb64c0d29940ce70cfe43fac0095a.zip
Add text-based browser dependency options. Text-based browsers are used
to render HTML. The dependencies are build and run dependencies, build dependencies because nmh auto-configures itself at build time for text based browsers it finds. The nmh upstream developer, Ken Hornstein <kenh@cmf.nrl.navy.mil>, prefers w3m but any text-based browser will do. The browser option is not default in order to satisfy minimalist install rerequirements. Reported by: Ken Hornstein <kenh@cmf.nrl.navy.mil> (upstream) MFH: 2019Q3
Notes
Notes: svn path=/head/; revision=505784
Diffstat (limited to 'mail/nmh')
-rw-r--r--mail/nmh/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/mail/nmh/Makefile b/mail/nmh/Makefile
index a962cb2e79be..b38b4c0108a3 100644
--- a/mail/nmh/Makefile
+++ b/mail/nmh/Makefile
@@ -21,9 +21,11 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/libexec/nmh \
LIB_DEPENDS= libcurl.so:ftp/curl
OPTIONS_DEFINE= DOCS HASH_BKP SASL2 TLS REPLYFILTER
+OPTIONS_RADIO= MIME_HTML
OPTIONS_SINGLE= MTS LOCKING
OPTIONS_SINGLE_MTS= SMTP SENDMAIL_SMTP SENDMAIL_PIPE
OPTIONS_SINGLE_LOCKING= DOT FCNTL FLOCK LOCKF
+OPTIONS_RADIO_MIME_HTML= LINKS ELINKS LYNX W3M
SASL2_DESC= SASL2 support
SASL2_CONFIGURE_WITH= cyrus-sasl
@@ -56,6 +58,25 @@ FLOCK_CONFIGURE_ON= --with-locking=flock
LOCKF_DESC= lockf file locking
LOCKF_CONFIGURE_ON= --with-locking=lockf
+# The reason for BUILD_DEPENDS is nmh detects and configures itself for
+# whichever text-based browser is installed.
+
+ELINKS_DESC= Install dependencies for www/elinks
+ELINKS_BUILD_DEPENDS= links>=0:www/elinks
+ELINKS_RUN_DEPENDS= links>=0:www/elinks
+
+LINKS_DESC= Install dependencies for www/links
+LINKS_BUILD_DEPENDS= links>=0:www/links
+LINKS_RUN_DEPENDS= links>=0:www/links
+
+LYNX_DESC= Install dependencies for www/lynx
+LYNX_BUILD_DEPENDS= lynx>=0:www/lynx
+LYNX_RUN_DEPENDS= lynx>=0:www/lynx
+
+W3M_DESC= Install dependencies for www/w3m
+W3M_BUILD_DEPENDS= w3m>=0:www/w3m
+W3M_RUN_DEPENDS= w3m>=0:www/w3m
+
OPTIONS_DEFAULT= SMTP FLOCK
.include <bsd.port.options.mk>