aboutsummaryrefslogtreecommitdiff
path: root/mail/nmzmail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 20:28:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 20:28:44 +0000
commitb909b36b384b3e984e92e018d993cb673da2f3ed (patch)
treef5ee8dc4f4d2f4b54286e36e16a46edb2d35e860 /mail/nmzmail
parent9934cc8832e6d99b6cd29bff045d7d53636635e0 (diff)
downloadports-b909b36b384b3e984e92e018d993cb673da2f3ed.tar.gz
ports-b909b36b384b3e984e92e018d993cb673da2f3ed.zip
nmzmail is a tool to use the namazu2 search engine from within the mutt mail
reader to search mail stored in maildir folders. Based on the result of the namazu query, nmzmail generates a maildir folder containing symbolic links to the mails matching the query. A simple mutt macro makes easy to use nmzmail from within mutt. PR: ports/76102 Submitted by: Fernan Aguero <fernan@iib.unsam.edu.ar>
Notes
Notes: svn path=/head/; revision=133078
Diffstat (limited to 'mail/nmzmail')
-rw-r--r--mail/nmzmail/Makefile40
-rw-r--r--mail/nmzmail/distinfo2
-rw-r--r--mail/nmzmail/pkg-descr15
3 files changed, 57 insertions, 0 deletions
diff --git a/mail/nmzmail/Makefile b/mail/nmzmail/Makefile
new file mode 100644
index 000000000000..c0bf2350083b
--- /dev/null
+++ b/mail/nmzmail/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# New ports collection Makefile for: nmzmail
+# Date created: 7 January 2005
+# Whom: fernan@iib.unsam.edu.ar
+#
+# $FreeBSD$
+#
+
+PORTNAME= nmzmail
+PORTVERSION= 0.1.2
+CATEGORIES= mail
+MASTER_SITES= http://www.ecademix.com/JohannesHofmann/
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Fast mail searching for mutt
+
+RUN_DEPENDS= namazu:${PORTSDIR}/databases/namazu2 \
+ mutt:${PORTSDIR}/mail/mutt
+
+USE_GMAKE= yes
+ALL_TARGET= # empty
+PLIST_FILES= bin/nmzmail
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500018
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nmzmail ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/nmzmail/distinfo b/mail/nmzmail/distinfo
new file mode 100644
index 000000000000..ac3d830c53b9
--- /dev/null
+++ b/mail/nmzmail/distinfo
@@ -0,0 +1,2 @@
+MD5 (nmzmail-0.1.2.tar.gz) = 18f5b4e9cc44c5ae9611d4130fc47fa6
+SIZE (nmzmail-0.1.2.tar.gz) = 3930
diff --git a/mail/nmzmail/pkg-descr b/mail/nmzmail/pkg-descr
new file mode 100644
index 000000000000..a7050767a4e4
--- /dev/null
+++ b/mail/nmzmail/pkg-descr
@@ -0,0 +1,15 @@
+nmzmail is a tool to use the namazu2 search engine from within the mutt
+mail reader to search mail stored in maildir folders. Based on the
+result of the namazu query, nmzmail generates a maildir folder
+containing symbolic links to the mails matching the query. A simple mutt
+macro makes easy to use nmzmail from within mutt.
+
+Features:
+ * fast mail searching even with large number of mails
+ * incremental index building
+ * rich query language including regular expressions (see the
+ namazu documentation)
+ * integrates nicely into mutt
+ * query history
+
+WWW: http://www.ecademix.com/JohannesHofmann/#nmzmail