aboutsummaryrefslogtreecommitdiff
path: root/mail/notmuch/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2019-06-13 21:27:41 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2019-06-13 21:27:41 +0000
commit826ff513f1d056c9ea9f51a1207214f51197e031 (patch)
treef7e6d4be7b148d3849b85eb918956c06a6a63ddf /mail/notmuch/Makefile
parent0162af96edfceebbe4a7efffbc7e76cfd916b64d (diff)
downloadports-826ff513f1d056c9ea9f51a1207214f51197e031.tar.gz
ports-826ff513f1d056c9ea9f51a1207214f51197e031.zip
mail/notmuch: update to 0.29.1
- The sources are now compressed with xz instead of gzip. - Support for GMime 2.6 was dropped and GMime 3.0.3 or later is required now. - drop workaround for info(1) on FreeBSD 10 since it's no longer supported - drop workaround for Sphinx since another one was included in notmuch's upstream ChangeLog: https://notmuchmail.org/pipermail/notmuch/2019/028257.html PR: 238418 Submitted by: seschwar@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=504137
Diffstat (limited to 'mail/notmuch/Makefile')
-rw-r--r--mail/notmuch/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 994e033d06d9..8b6781d2b2d7 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.28.2
+PORTVERSION= 0.29.1
CATEGORIES?= mail
MASTER_SITES= https://notmuchmail.org/releases/
@@ -13,7 +13,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/${WRKSRC_SUBDIR:C/[^\/]+/../g}/COPYING-GPL-3
.ifndef MASTERDIR
-LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
+LIB_DEPENDS= libgmime-3.0.so:mail/gmime30 \
libxapian.so:databases/xapian-core \
libtalloc.so:devel/talloc
TEST_DEPENDS= bash:shells/bash \
@@ -30,7 +30,11 @@ TEST_DEPENDS= bash:shells/bash \
USES= compiler:c++11-lang gmake gnome pkgconfig python:build,test
USE_GNOME= glib20
USE_LDCONFIG= yes
+.endif
+
+USES+= tar:xz
+.ifndef MASTERDIR
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --infodir=${PREFIX}/${INFO_PATH} \
--mandir=${MANPREFIX}/man \
@@ -60,20 +64,17 @@ DOXYGEN_CONFIGURE_WITH= api-docs
MANPAGES_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
MANPAGES_CONFIGURE_WITH= docs
-post-patch:
# Avoid conflict with C++20 <version> by ignoring <...> under WRKSRC
+post-patch:
@${REINPLACE_CMD} -i .c++20 's/-I$$(srcdir)/-iquote$$(srcdir)/' \
${WRKSRC}/*/Makefile.local
-# Install bash completions without incurring a dependcy on
-# shells/bash-completion. Also avoid automatic installation of
-# info pages on FreeBSD 10.
+# Install bash completions without incurring a dependency on
+# shells/bash-completion.
post-configure:
${REINPLACE_CMD} \
-e '/^BASH_ABSOLUTE[[:blank:]]*=/s|=.*|=${LOCALBASE}/bin/bash|' \
-e '/^HAVE_BASH[[:blank:]]*=/s/=.*/=1/' \
- -e '/^HAVE_INSTALL_INFO[[:blank:]]*=/s/=.*/=0/' \
- -e '/^HAVE_MAKEINFO[[:blank:]]*=/s/=.*/=0/' \
-e '/^WITH_BASH[[:blank:]]*=/s/=.*/=1/' \
${WRKSRC}/Makefile.config
@@ -81,7 +82,7 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notmuch
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnotmuch.so.?*.?*.?*
-# keep poudriere testport happy
+# Keep poudriere-testport(8) happy.
post-install-MANPAGES-on:
@${RM} ${STAGEDIR}${MANPREFIX}/man/man1/notmuch-emacs-mua.1.gz
.endif