aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-04-22 15:58:56 +0000
committerRene Ladan <rene@FreeBSD.org>2014-04-22 15:58:56 +0000
commit1e50287cd095038372ea4d8e8274edbbcc63e2ea (patch)
treeb068c02c0dbc2253459050560632cf6803231c81 /mail/opendkim
parenta87d6675250e56455dd4ba28d109365ae2e62ffe (diff)
downloadports-1e50287cd095038372ea4d8e8274edbbcc63e2ea.tar.gz
ports-1e50287cd095038372ea4d8e8274edbbcc63e2ea.zip
- Add an option for DEBUG
- Shebang fixes for perl scripts - Properly handle conditional manual pages Part of PR already committed in r351697 PR: ports/188266 Submitted by: Danilo G. Baio <dbaio@bsd.com.br> Approved by: maintainer timeout (<umq@ueo.co.jp> , 18 days)
Notes
Notes: svn path=/head/; revision=351857
Diffstat (limited to 'mail/opendkim')
-rw-r--r--mail/opendkim/Makefile10
-rw-r--r--mail/opendkim/pkg-plist15
2 files changed, 18 insertions, 7 deletions
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 99b4266c5904..bd8154575ee3 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -25,6 +25,7 @@ NO_OPTIONS_SORT=yes
USES= pkgconfig perl5 shebangfix
USE_PERL5= run
SHEBANG_FILES= opendkim/opendkim-genkey.in
+SHEBANG_FILES= opendkim/opendkim-genkey* reputation/opendkim-* stats/opendkim-*
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -33,7 +34,7 @@ PORTDOCS= *
OPTIONS_SINGLE= RESOLV
OPTIONS_SINGLE_RESOLV= STOCK_RESOLVER UNBOUND
OPTIONS_DEFINE= FILTER GNUTLS LUA MEMCACHED BDB_BASE OPENDBX OPENLDAP \
- POPAUTH QUERY_CACHE STATS
+ POPAUTH QUERY_CACHE STATS DEBUG
OPTIONS_DEFAULT= FILTER LUA UNBOUND
STOCK_RESOLVER_DESC= Use the stock resolver library
@@ -48,6 +49,7 @@ OPENLDAP_DESC= Store filter policies in LDAP
POPAUTH_DESC= Use POP authentication DB
QUERY_CACHE_DESC= Cache DNS query results locally
STATS_DESC= Setup statistics tools
+DEBUG_DESC= Build with debug symbols
MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
@@ -86,12 +88,6 @@ CONFIGURE_ARGS+=--docdir=${WRKDIR}/doc
.if ${PORT_OPTIONS:MSTATS}
CONFIGURE_ARGS+= --enable-stats
-MAN8+= opendkim-expire.8 opendkim-gengraphs.8 \
- opendkim-genstats.8 opendkim-stats.8
-. if ${PORT_OPTIONS:MOPENDBX}
-MAN1+= opendkim-spam.1
-MAN8+= opendkim-importstats.8
-. endif
PLIST_SUB+= STATS=""
.else
PLIST_SUB+= STATS="@comment "
diff --git a/mail/opendkim/pkg-plist b/mail/opendkim/pkg-plist
index 67ed4ad20e60..0d1fa1b7113e 100644
--- a/mail/opendkim/pkg-plist
+++ b/mail/opendkim/pkg-plist
@@ -77,3 +77,18 @@ sbin/opendkim-testmsg
@dirrm include/opendkim
%%DKIMREP%%@dirrm include/dkim-rep
@dirrmtry etc/mail
+%%FILTER%%man/man5/opendkim.conf.5.gz
+%%LUA%%man/man8/miltertest.8.gz
+man/man8/opendkim-genkey.8.gz
+man/man8/opendkim-genzone.8.gz
+man/man8/opendkim-testadsp.8.gz
+man/man8/opendkim-testkey.8.gz
+man/man8/opendkim-testmsg.8.gz
+%%FILTER%%man/man8/opendkim.8.gz
+%%LUA%%%%FILTER%%man/man3/opendkim-lua.3.gz
+%%STATS%%man/man8/opendkim-expire.8.gz
+%%STATS%%man/man8/opendkim-gengraphs.8.gz
+%%STATS%%man/man8/opendkim-genstats.8.gz
+%%STATS%%man/man8/opendkim-stats.8.gz
+%%STATS%%%%ODBX%%man/man1/opendkim-spam.1.gz
+%%STATS%%%%ODBX%%man/man8/opendkim-importstats.8.gz