aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd-extras
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2016-06-06 12:18:16 +0000
committerDima Panov <fluffy@FreeBSD.org>2016-06-06 12:18:16 +0000
commitd4233dc6f92d9b1a98c2e3fd42f85968ce89d12e (patch)
tree636ebbb31befbc77f3966dbcea75316359c791b7 /mail/opensmtpd-extras
parent51453d4e17fb48d95d3c50d763823f5d8a0fddbe (diff)
downloadports-d4233dc6f92d9b1a98c2e3fd42f85968ce89d12e.tar.gz
ports-d4233dc6f92d9b1a98c2e3fd42f85968ce89d12e.zip
Install missing ready-to-use OpenSMTPD-extras components:
- filter-monkey - table-ldap - tools-stats Also install experimental components (corresponding groups labelled as "experimental"): - filter bindings to lua, perl and python languages - queue and scheduler bindings to perl and python languages Submitted by: myself Reviewed by: gahr, adamw, miwi Approved by: gahr, adamw, miwi (mentor, implicit) Sponsored by: milk and cookies Differential Revision: https://reviews.freebsd.org/D6084
Notes
Notes: svn path=/head/; revision=416455
Diffstat (limited to 'mail/opensmtpd-extras')
-rw-r--r--mail/opensmtpd-extras/Makefile107
1 files changed, 76 insertions, 31 deletions
diff --git a/mail/opensmtpd-extras/Makefile b/mail/opensmtpd-extras/Makefile
index d55635b9c157..b7770a6ba610 100644
--- a/mail/opensmtpd-extras/Makefile
+++ b/mail/opensmtpd-extras/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opensmtpd-extras
PORTVERSION= 201605232202
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES+= mail
MASTER_SITES= http://www.opensmtpd.org/archives/
@@ -23,6 +23,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir="${PREFIX}/etc/mail"
+NO_OPTIONS_SORT= yes
+
# NB: Please *DO NOT* add the following; they are NOT for end-users:
# filter-stub, filter-trace, filter-void
# queue-null, queue-stub
@@ -41,50 +43,93 @@ OPENSMTP_DEVEL_BUILD_DEPENDS= smtpctl:${PORTSDIR}/mail/opensmtpd-devel
OPENSMTP_DEVEL_RUN_DEPENDS= smtpctl:${PORTSDIR}/mail/opensmtpd-devel
.if empty(SLAVE_PORT)
-OPTIONS_GROUP= FILTER TABLE
-OPTIONS_GROUP_FILTER= CLAMAV DKIM DNSBL PAUSE REGEX SPAMASSASSIN
-OPTIONS_GROUP_TABLE= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
-OPTIONS_DEFAULT= ${OPTIONS_GROUP_FILTER} ${OPTIONS_GROUP_TABLE}
+OPTIONS_GROUP= TOOLS TABLE FILTER FILTER_EXP QUEUE SCHEDULER
+OPTIONS_GROUP_FILTER= FILTER_CLAMAV FILTER_DKIM FILTER_DNSBL FILTER_MONKEY FILTER_PAUSE FILTER_REGEX FILTER_SPAMASSASSIN
+OPTIONS_GROUP_FILTER_EXP= FILTER_LUA FILTER_PERL FILTER_PYTHON
+OPTIONS_GROUP_QUEUE= QUEUE_PYTHON QUEUE_RAM
+OPTIONS_GROUP_SCHEDULER= SCHEDULER_PYTHON SCHEDULER_RAM
+OPTIONS_GROUP_TABLE= TABLE_LDAP TABLE_MYSQL TABLE_PASSWD TABLE_PGSQL TABLE_PYTHON TABLE_REDIS TABLE_SOCKETMAP TABLE_SQLITE
+OPTIONS_GROUP_TOOLS= TOOL_STATS
+OPTIONS_DEFAULT= ${OPTIONS_GROUP_FILTER} ${OPTIONS_GROUP_TABLE} ${OPTIONS_GROUP_TOOLS}
# Groups
FILTER_DESC= BASE FILTERS
+FILTER_EXP_DESC= EXPERIMENTAL FILTERS
+QUEUE_DESC= EXPERIMENTAL QUEUES
+SCHEDULER_DESC= EXPERIMENTAL SCHEDULERS
TABLE_DESC= BASE TABLES
+TOOLS_DESC= BASE TOOLS
# Filters
-CLAMAV_DESC= Check messages with ClamAV
-DKIM_DESC= Sign messages with DKIM
-DNSBL_DESC= Check messages against DNSBLs
-PAUSE_DESC= Pause incoming messages to reduce spam
-SPAMASSASSIN_DESC= Check messages with SpamAssassin
+FILTER_CLAMAV_DESC= Check messages with ClamAV
+FILTER_DKIM_DESC= Sign messages with DKIM
+FILTER_DNSBL_DESC= Check incoming senders against DNSBLs
+FILTER_LUA_DESC= Lua-filter interface
+FILTER_MONKEY_DESC= Filter to arbitrary reject or delay mails
+FILTER_PAUSE_DESC= Pause before SMTP greeting to reduce spam
+FILTER_PERL_DESC= Perl-filter interface
+FILTER_PYTHON_DESC= Python-filter interface
+FILTER_REGEX_DESC= ${REGEX_DESC}
+FILTER_SPAMASSASSIN_DESC= Check messages with SpamAssassin
+
+# Queues
+QUEUE_PYTHON_DESC= The queue-python
+QUEUE_RAM_DESC= The queue-ram
+
+# Schedulers
+SCHEDULER_PYTHON_DESC= The scheduler-python
+SCHEDULER_RAM_DESC= The scheduler-ram
+
# Tables
-PASSWD_DESC= passwd(5) table support
-SMAP_DESC= Socketmap protocol support
+TABLE_LDAP_DESC= LDAP table support
+TABLE_MYSQL_DESC= MySQL table support
+TABLE_PASSWD_DESC= passwd(5) table support
+TABLE_PGSQL_DESC= PgSQL table support
+TABLE_PYTHON_DESC= Python table support
+TABLE_REDIS_DESC= REDIS table support
+TABLE_SOCKETMAP_DESC= Socketmap protocol support
+TABLE_SQLITE_DESC= SQLite table support
-PLIST_FILES= man/man3/filter_api.3.gz
-INSTALL_DIR= ${LOCALBASE}/libexec/opensmtpd
+# Tools
+TOOL_STATS_DESC= Stats tool for OpenSMTPD
+
+PLIST_FILES= man/man3/filter_api.3.gz
+INSTALL_DIR= ${LOCALBASE}/libexec/opensmtpd
NO_ARCH= yes
-#
# Filters
-#
-CLAMAV_RUN_DEPENDS= ${INSTALL_DIR}/filter-clamav:mail/opensmtpd-extras-filter-clamav
-DKIM_RUN_DEPENDS= ${INSTALL_DIR}/filter-dkim-signer:mail/opensmtpd-extras-filter-dkim
-DNSBL_RUN_DEPENDS= ${INSTALL_DIR}/filter-dnsbl:mail/opensmtpd-extras-filter-dnsbl
-PAUSE_RUN_DEPENDS= ${INSTALL_DIR}/filter-pause:mail/opensmtpd-extras-filter-pause
-REGEX_RUN_DEPENDS= ${INSTALL_DIR}/filter-regex:mail/opensmtpd-extras-filter-regex
-SPAMASSASSIN_RUN_DEPENDS= ${INSTALL_DIR}/filter-spamassassin:mail/opensmtpd-extras-filter-spamassassin
+FILTER_CLAMAV_RUN_DEPENDS= ${INSTALL_DIR}/filter-clamav:mail/opensmtpd-extras-filter-clamav
+FILTER_DKIM_RUN_DEPENDS= ${INSTALL_DIR}/filter-dkim-signer:mail/opensmtpd-extras-filter-dkim
+FILTER_DNSBL_RUN_DEPENDS= ${INSTALL_DIR}/filter-dnsbl:mail/opensmtpd-extras-filter-dnsbl
+FILTER_LUA_RUN_DEPENDS= ${INSTALL_DIR}/filter-lua:mail/opensmtpd-extras-filter-lua
+FILTER_MONKEY_RUN_DEPENDS= ${INSTALL_DIR}/filter-monkey:mail/opensmtpd-extras-filter-monkey
+FILTER_PAUSE_RUN_DEPENDS= ${INSTALL_DIR}/filter-pause:mail/opensmtpd-extras-filter-pause
+FILTER_PERL_RUN_DEPENDS= ${INSTALL_DIR}/filter-perl:mail/opensmtpd-extras-filter-perl
+FILTER_PYTHON_RUN_DEPENDS= ${INSTALL_DIR}/filter-python:mail/opensmtpd-extras-filter-python
+FILTER_REGEX_RUN_DEPENDS= ${INSTALL_DIR}/filter-regex:mail/opensmtpd-extras-filter-regex
+FILTER_SPAMASSASSIN_RUN_DEPENDS= ${INSTALL_DIR}/filter-spamassassin:mail/opensmtpd-extras-filter-spamassassin
+
+# Queues
+QUEUE_PYTHON_RUN_DEPENDS= ${INSTALL_DIR}/queue-python:mail/opensmtpd-extras-queue-python
+QUEUE_RAM_RUN_DEPENDS= ${INSTALL_DIR}/queue-ram:mail/opensmtpd-extras-queue-ram
+
+# Schedulers
+SCHEDULER_PYTHON_RUN_DEPENDS= ${INSTALL_DIR}/scheduler-python:mail/opensmtpd-extras-scheduler-python
+SCHEDULER_RAM_RUN_DEPENDS= ${INSTALL_DIR}/scheduler-ram:mail/opensmtpd-extras-scheduler-ram
-#
# Tables
-#
-MYSQL_RUN_DEPENDS= ${INSTALL_DIR}/table-mysql:mail/opensmtpd-extras-table-mysql
-PASSWD_RUN_DEPENDS= ${INSTALL_DIR}/table-passwd:mail/opensmtpd-extras-table-passwd
-PGSQL_RUN_DEPENDS= ${INSTALL_DIR}/table-postgres:mail/opensmtpd-extras-table-postgresql
-PYTHON_RUN_DEPENDS= ${INSTALL_DIR}/table-python:mail/opensmtpd-extras-table-python
-REDIS_RUN_DEPENDS= ${INSTALL_DIR}/table-redis:mail/opensmtpd-extras-table-redis
-SMAP_RUN_DEPENDS= ${INSTALL_DIR}/table-socketmap:mail/opensmtpd-extras-table-socketmap
-SQLITE_RUN_DEPENDS= ${INSTALL_DIR}/table-sqlite:mail/opensmtpd-extras-table-sqlite
+TABLE_LDAP_RUN_DEPENDS= ${INSTALL_DIR}/table-ldap:mail/opensmtpd-extras-table-ldap
+TABLE_MYSQL_RUN_DEPENDS= ${INSTALL_DIR}/table-mysql:mail/opensmtpd-extras-table-mysql
+TABLE_PASSWD_RUN_DEPENDS= ${INSTALL_DIR}/table-passwd:mail/opensmtpd-extras-table-passwd
+TABLE_PGSQL_RUN_DEPENDS= ${INSTALL_DIR}/table-postgres:mail/opensmtpd-extras-table-postgresql
+TABLE_PYTHON_RUN_DEPENDS= ${INSTALL_DIR}/table-python:mail/opensmtpd-extras-table-python
+TABLE_REDIS_RUN_DEPENDS= ${INSTALL_DIR}/table-redis:mail/opensmtpd-extras-table-redis
+TABLE_SOCKETMAP_RUN_DEPENDS= ${INSTALL_DIR}/table-socketmap:mail/opensmtpd-extras-table-socketmap
+TABLE_SQLITE_RUN_DEPENDS= ${INSTALL_DIR}/table-sqlite:mail/opensmtpd-extras-table-sqlite
+
+# Tools
+TOOL_STATS_RUN_DEPENDS= tool-stats:${PORTSDIR}/mail/opensmtpd-extras-tool-stats
.else
# Only install this for the opensmtpd-extras master port