aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd-extras
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2016-05-27 18:29:53 +0000
committerDima Panov <fluffy@FreeBSD.org>2016-05-27 18:29:53 +0000
commite1a0c39c75e269ea8640c4b0d5bca1fd9af80153 (patch)
treeb2c75ab3e4c649561a288f61bcd9e6e7482af579 /mail/opensmtpd-extras
parente728417c0b3ff5f4905c8ab6c8c37bca9b7c44d9 (diff)
downloadports-e1a0c39c75e269ea8640c4b0d5bca1fd9af80153.tar.gz
ports-e1a0c39c75e269ea8640c4b0d5bca1fd9af80153.zip
- Unconditionally define PORTREVISION in subports
to skip unneccessary bump slaves by master port touching - Pass master's CONFIGURE_ARGS to slaves - Option to select mail/opensmtpd[-devel] as build/run dependency (and corresponding libasr via this) - Pass pkgconfig dependency only to subports which need it. - Adjust dependencies in subports Submitted by: myself Reviewed by: adamw, gahr Approved by: adamw, gahr, miwi (mentor, implicit) Sponsored by: milk and cookies Differential Revision: https://reviews.freebsd.org/D6607
Notes
Notes: svn path=/head/; revision=415954
Diffstat (limited to 'mail/opensmtpd-extras')
-rw-r--r--mail/opensmtpd-extras/Makefile29
1 files changed, 24 insertions, 5 deletions
diff --git a/mail/opensmtpd-extras/Makefile b/mail/opensmtpd-extras/Makefile
index 8fa6517d2d0d..d55635b9c157 100644
--- a/mail/opensmtpd-extras/Makefile
+++ b/mail/opensmtpd-extras/Makefile
@@ -3,34 +3,53 @@
PORTNAME= opensmtpd-extras
PORTVERSION= 201605232202
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= mail
MASTER_SITES= http://www.opensmtpd.org/archives/
+# NB: Please reset PORTREVISION to 0 in all slave subports
+# while updating PORTVERSION for master port
+
MAINTAINER?= gahr@FreeBSD.org
COMMENT?= Addons for OpenSMTPD
LICENSE?= ISCL
LIB_DEPENDS+= libevent.so:devel/libevent2
-RUN_DEPENDS+= ${LOCALBASE}/sbin/smtpctl:mail/opensmtpd
-USES+= autoreconf libtool pkgconfig
+USES+= autoreconf libtool
USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --sysconfdir="${PREFIX}/etc/mail"
+
# NB: Please *DO NOT* add the following; they are NOT for end-users:
-# filter-monkey, filter-stub, filter-trace, filter-void
+# filter-stub, filter-trace, filter-void
# queue-null, queue-stub
# scheduler-stub
# table-stub
+
+#
+# Pass OpenSMTPD branch selection to all extras
+#
+OPTIONS_DEFINE= OPENSMTP_DEVEL
+
+OPENSMTP_DEVEL_DESC= Depend on opensmtpd-devel (opensmtpd if off)
+OPENSMTP_DEVEL_BUILD_DEPENDS_OFF= smtpctl:${PORTSDIR}/mail/opensmtpd
+OPENSMTP_DEVEL_RUN_DEPENDS_OFF= smtpctl:${PORTSDIR}/mail/opensmtpd
+OPENSMTP_DEVEL_BUILD_DEPENDS= smtpctl:${PORTSDIR}/mail/opensmtpd-devel
+OPENSMTP_DEVEL_RUN_DEPENDS= smtpctl:${PORTSDIR}/mail/opensmtpd-devel
+
.if empty(SLAVE_PORT)
OPTIONS_GROUP= FILTER TABLE
OPTIONS_GROUP_FILTER= CLAMAV DKIM DNSBL PAUSE REGEX SPAMASSASSIN
OPTIONS_GROUP_TABLE= LDAP MYSQL PASSWD PGSQL PYTHON REDIS SMAP SQLITE
OPTIONS_DEFAULT= ${OPTIONS_GROUP_FILTER} ${OPTIONS_GROUP_TABLE}
+# Groups
+FILTER_DESC= BASE FILTERS
+TABLE_DESC= BASE TABLES
+
# Filters
CLAMAV_DESC= Check messages with ClamAV
DKIM_DESC= Sign messages with DKIM