aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-Address-XS
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-07-26 18:19:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-07-26 18:19:33 +0000
commit9bbd3d1f5e5196cbf5a616fc3feb65f7f7ca64d6 (patch)
treed3e544cbb936dc08dd6404e47d056fe67a7e74e4 /mail/p5-Email-Address-XS
parentebe6abf5004ab96b02494a640e8fba145c42694f (diff)
downloadports-9bbd3d1f5e5196cbf5a616fc3feb65f7f7ca64d6.tar.gz
ports-9bbd3d1f5e5196cbf5a616fc3feb65f7f7ca64d6.zip
Add p5-Email-Address-XS 1.00
This module implements RFC 2822 parser and formatter of email addresses and groups. It parses an input string from email headers which contain a list of email addresses or a groups of email addresses (like From, To, Cc, Bcc, Reply-To, Sender, ...). Also it can generate a string value for those headers from a list of email addresses objects. Parser and formatter functionality is implemented in XS and uses shared code from Dovecot IMAP server. It is a drop-in replacement for the Email::Address module which has several security issues. Existing applications that use Email::Address module could be easily switched to Email::Address::XS module. In most cases only changing use Email::Address to use Email::Address::XS and replacing every Email::Address occurrence with Email::Address::XS is sufficient. So unlike Email::Address, this module does not use regular expressions for parsing but instead native XS implementation parses input string sequentially according to RFC 2822 grammar. Additionally it has support also for named groups and so can be use instead of the Email::Address::List module. WWW: http://search.cpan.org/dist/Email-Address-XS/
Notes
Notes: svn path=/head/; revision=446673
Diffstat (limited to 'mail/p5-Email-Address-XS')
-rw-r--r--mail/p5-Email-Address-XS/Makefile22
-rw-r--r--mail/p5-Email-Address-XS/distinfo3
-rw-r--r--mail/p5-Email-Address-XS/pkg-descr23
-rw-r--r--mail/p5-Email-Address-XS/pkg-plist3
4 files changed, 51 insertions, 0 deletions
diff --git a/mail/p5-Email-Address-XS/Makefile b/mail/p5-Email-Address-XS/Makefile
new file mode 100644
index 000000000000..c6d733378848
--- /dev/null
+++ b/mail/p5-Email-Address-XS/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Email-Address-XS
+PORTVERSION= 1.00
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse and format RFC 2822 email addresses and groups
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USE_PERL5= configure
+USES= perl5
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Email/Address/XS/XS.so
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Address-XS/distinfo b/mail/p5-Email-Address-XS/distinfo
new file mode 100644
index 000000000000..cd29a416cf39
--- /dev/null
+++ b/mail/p5-Email-Address-XS/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501088953
+SHA256 (Email-Address-XS-1.00.tar.gz) = 52d5a1f8c3bace4bae6d25b123a00213d6de027cac0da6666f1ed4f7b6bebd18
+SIZE (Email-Address-XS-1.00.tar.gz) = 24104
diff --git a/mail/p5-Email-Address-XS/pkg-descr b/mail/p5-Email-Address-XS/pkg-descr
new file mode 100644
index 000000000000..e59190c82e7c
--- /dev/null
+++ b/mail/p5-Email-Address-XS/pkg-descr
@@ -0,0 +1,23 @@
+This module implements RFC 2822 parser and formatter of email addresses and
+groups. It parses an input string from email headers which contain a list of
+email addresses or a groups of email addresses (like From, To, Cc, Bcc,
+Reply-To, Sender, ...). Also it can generate a string value for those headers
+from a list of email addresses objects.
+
+Parser and formatter functionality is implemented in XS and uses shared code
+from Dovecot IMAP server.
+
+It is a drop-in replacement for the Email::Address module which has several
+security issues. Existing applications that use Email::Address module could be
+easily switched to Email::Address::XS module. In most cases only changing use
+Email::Address to use Email::Address::XS and replacing every Email::Address
+occurrence with Email::Address::XS is sufficient.
+
+So unlike Email::Address, this module does not use regular expressions for
+parsing but instead native XS implementation parses input string sequentially
+according to RFC 2822 grammar.
+
+Additionally it has support also for named groups and so can be use instead of
+the Email::Address::List module.
+
+WWW: http://search.cpan.org/dist/Email-Address-XS/
diff --git a/mail/p5-Email-Address-XS/pkg-plist b/mail/p5-Email-Address-XS/pkg-plist
new file mode 100644
index 000000000000..a7808796f696
--- /dev/null
+++ b/mail/p5-Email-Address-XS/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Email/Address/XS.pm
+%%SITE_ARCH%%/auto/Email/Address/XS/XS.so
+%%PERL5_MAN3%%/Email::Address::XS.3.gz