aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-IMAP-Client
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 04:00:58 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 04:00:58 +0000
commit7162ee42cd15177978504aa081dc42f2c13c8164 (patch)
tree4146d1ac233ee0abc99c1eeb971289f57328e13c /mail/p5-IMAP-Client
parentb0fafe134b8c94ddd49b8817f1ca82a2e79ce475 (diff)
downloadports-7162ee42cd15177978504aa081dc42f2c13c8164.tar.gz
ports-7162ee42cd15177978504aa081dc42f2c13c8164.zip
Add p5-IMAP-Client 0.11, advanced manipulation of IMAP services w/
referral support. PR: ports/101831 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=170524
Diffstat (limited to 'mail/p5-IMAP-Client')
-rw-r--r--mail/p5-IMAP-Client/Makefile36
-rw-r--r--mail/p5-IMAP-Client/distinfo3
-rw-r--r--mail/p5-IMAP-Client/pkg-descr21
-rw-r--r--mail/p5-IMAP-Client/pkg-plist6
4 files changed, 66 insertions, 0 deletions
diff --git a/mail/p5-IMAP-Client/Makefile b/mail/p5-IMAP-Client/Makefile
new file mode 100644
index 000000000000..f331fc7f9428
--- /dev/null
+++ b/mail/p5-IMAP-Client/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-IMAP-Client
+# Date created: 2006-08-12
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IMAP-Client
+PORTVERSION= 0.11
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IMAP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Advanced manipulation of IMAP services w/ referral support
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/URI/imap.pm:${PORTSDIR}/mail/p5-URI-imap
+
+PERL_CONFIGURE= yes
+
+MAN3= IMAP::Client.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/INET.pm:${PORTSDIR}/devel/p5-IO
+.endif
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-IMAP-Client/distinfo b/mail/p5-IMAP-Client/distinfo
new file mode 100644
index 000000000000..57375066cc72
--- /dev/null
+++ b/mail/p5-IMAP-Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (IMAP-Client-0.11.tar.gz) = 4980910d15c78b7949cc748da11da487
+SHA256 (IMAP-Client-0.11.tar.gz) = bba63271645444d21f988d0f6a38b2b5ac6d6f8c996c1bcb637606beec1c8126
+SIZE (IMAP-Client-0.11.tar.gz) = 77430
diff --git a/mail/p5-IMAP-Client/pkg-descr b/mail/p5-IMAP-Client/pkg-descr
new file mode 100644
index 000000000000..16ed31411a08
--- /dev/null
+++ b/mail/p5-IMAP-Client/pkg-descr
@@ -0,0 +1,21 @@
+This module was created as a low-level inteface to any IMAP server. It
+was built to be a 'clear box' solution to working with an IMAP
+environment. The idea is that anything an IMAP client should be able
+to do, and any information available via the IMAP specs, should be
+available to a client interface and user. This way, the full strength
+of the IMAP protocol and data can be utilized, ideally in the most
+network-efficient mannger possible, rather than being contrained only
+to a subset of commands or data-limited responses. If the server says
+it, the client should be able to see it.
+
+This module also takes steps to be able to handle anticipated
+situations for the user rather than forcing a per-implementation
+behavior for such expected events, such as referrals. IMAP::Client
+will fully support referrals, and will transparently handle them for
+whatever command is issued to them (so long as the referral s for
+anonymous or the same user with the same password - a new user or
+different password would require a new username/password to be
+obtained. As of 0.01, this is not supported, however the framework is
+down.
+
+WWW: http://search.cpan.org/dist/IMAP-Client/
diff --git a/mail/p5-IMAP-Client/pkg-plist b/mail/p5-IMAP-Client/pkg-plist
new file mode 100644
index 000000000000..288783857e4f
--- /dev/null
+++ b/mail/p5-IMAP-Client/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IMAP/Client/.packlist
+%%SITE_PERL%%/IMAP/Client.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IMAP/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IMAP
+@dirrmtry %%SITE_PERL%%/IMAP