aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-MIME-Fast
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-04-24 16:52:29 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-04-24 16:52:29 +0000
commitf0da482d08556d39b5c31a536dad637d838eae82 (patch)
tree57ef524a5f52fa7b6deca9f865afab02d5093c68 /mail/p5-MIME-Fast
parent0eed30f27f2e616d79248a6c9c014b94ebb711f1 (diff)
downloadports-f0da482d08556d39b5c31a536dad637d838eae82.tar.gz
ports-f0da482d08556d39b5c31a536dad637d838eae82.zip
Fix build with 5.18+. Rename a patch to follow makepatch naming.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=384668
Diffstat (limited to 'mail/p5-MIME-Fast')
-rw-r--r--mail/p5-MIME-Fast/Makefile11
-rw-r--r--mail/p5-MIME-Fast/files/patch-Fast_Part.xs (renamed from mail/p5-MIME-Fast/files/patch-Part.xs)0
-rw-r--r--mail/p5-MIME-Fast/files/patch-Fast_Stream.xs12
3 files changed, 13 insertions, 10 deletions
diff --git a/mail/p5-MIME-Fast/Makefile b/mail/p5-MIME-Fast/Makefile
index d16dcdcae667..a8e2a8451737 100644
--- a/mail/p5-MIME-Fast/Makefile
+++ b/mail/p5-MIME-Fast/Makefile
@@ -19,13 +19,4 @@ USES= perl5
USE_PERL5= configure
CONFIGURE_ENV= PREFIX="${PREFIX}" CCFLAGS="${CCFLAGS}"
-DEPRECATED= Does not work with 5.18 or above
-EXPIRATION_DATE=2015-07-31
-
-.include <bsd.port.pre.mk>
-
-.if ${PERL_VER} >= 5.18
-BROKEN= Does not build with Perl 5.18 or above
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-MIME-Fast/files/patch-Part.xs b/mail/p5-MIME-Fast/files/patch-Fast_Part.xs
index fdb5d88f7d58..fdb5d88f7d58 100644
--- a/mail/p5-MIME-Fast/files/patch-Part.xs
+++ b/mail/p5-MIME-Fast/files/patch-Fast_Part.xs
diff --git a/mail/p5-MIME-Fast/files/patch-Fast_Stream.xs b/mail/p5-MIME-Fast/files/patch-Fast_Stream.xs
new file mode 100644
index 000000000000..7f6db9c7e160
--- /dev/null
+++ b/mail/p5-MIME-Fast/files/patch-Fast_Stream.xs
@@ -0,0 +1,12 @@
+--- Fast/Stream.xs.orig 2003-06-23 08:57:12 UTC
++++ Fast/Stream.xs
+@@ -218,8 +218,7 @@ g_mime_stream_read(mime_stream, buf, len
+ if (SvREADONLY(buf) && PL_curcop != &PL_compiling)
+ croak("MIME::Fast::Stream->read: buffer parameter is read-only");
+ else
+- if (!SvUPGRADE(buf, SVt_PV))
+- croak("MIME::Fast::Stream->read: cannot use buf argument as lvalue");
++ SvUPGRADE(buf, SVt_PV);
+ SvPOK_only(buf);
+ SvCUR_set(buf, 0);
+