aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-SpamAssassin/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-05-26 16:50:34 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-05-26 16:50:34 +0000
commit7ce88f287541190cbf37060f178e7e94a0964337 (patch)
treede73143d01a1d88ae034195ba5434055d8e82021 /mail/p5-Mail-SpamAssassin/Makefile
parent3bbc20030de60d3997d19b7fec091e051e9ba538 (diff)
downloadports-7ce88f287541190cbf37060f178e7e94a0964337.tar.gz
ports-7ce88f287541190cbf37060f178e7e94a0964337.zip
- Make depends on razor-agents optional
PR: ports/81112 Submitted by: Jeremy Chadwick <freebsd@jdc.parodius.com>
Notes
Notes: svn path=/head/; revision=136185
Diffstat (limited to 'mail/p5-Mail-SpamAssassin/Makefile')
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 91212c83bfbc..8228e16e955e 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Mail-SpamAssassin
PORTVERSION= 3.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:S/$/:apache/} ${MASTER_SITE_PERL_CPAN:S/$/:cpan/}
MASTER_SITE_SUBDIR= spamassassin/:apache Mail/:cpan
@@ -20,8 +20,7 @@ COMMENT= A highly efficient mail filter for identifying spam
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/Mail/Internet.pm:${PORTSDIR}/mail/p5-Mail-Tools
-RUN_DEPENDS= ${BUILD_DEPENDS} \
- razor-client:${PORTSDIR}/mail/razor-agents
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
CONFIGURE_ARGS= SYSCONFDIR="${PREFIX}/etc" \
@@ -32,6 +31,7 @@ OPTIONS= AS_ROOT "Run spamd as root (recommended)" on \
SSL "Build with SSL support for spamd/spamc" on \
MYSQL "Add MySQL support" off \
PGSQL "Add PostreSQL support" off \
+ RAZOR "Add Vipul's Razor support" on \
SPF_QUERY "Add SPF query support" off \
TOOLS "Install SpamAssassin tools" off
@@ -62,6 +62,10 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
USE_SQLDB= yes
.endif
+.if !defined(WITHOUT_RAZOR)
+RUN_DEPENDS+= razor-client:${PORTSDIR}/mail/razor-agents
+.endif
+
.if defined(WITH_TOOLS)
RUN_DEPENDS+= ${SITE_PERL}/Parse/Syslog.pm:${PORTSDIR}/textproc/p5-Parse-Syslog \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \