aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Net-SMTP-Server/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
commit927c9c2190303cbf488da40b21aa8f687198bb23 (patch)
treeb50875b389c063d1bcadc768e710973b1992efd2 /mail/p5-Net-SMTP-Server/Makefile
parent2a6d3bd8e2df3f99bd5bc37be426951c272419b9 (diff)
downloadports-927c9c2190303cbf488da40b21aa8f687198bb23.tar.gz
ports-927c9c2190303cbf488da40b21aa8f687198bb23.zip
Conditionalize dependencies for moudules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. 17 + 29 + 234 = 280 PRs. It's about time he starts doing the work himself! PR: ports/50588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=78882
Diffstat (limited to 'mail/p5-Net-SMTP-Server/Makefile')
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
index 88d1cce3627e..68113abf0600 100644
--- a/mail/p5-Net-SMTP-Server/Makefile
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -16,16 +16,22 @@ DISTNAME= SMTP-Server-${PORTVERSION}
MAINTAINER= erwin@lansing.dk
COMMENT= A native Perl SMTP Server
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
MASTER_SITE_BACKUP+= http://www.macgyver.org/software/perl/
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SMTP::Server.3 \
Net::SMTP::Server::Client.3 \
Net::SMTP::Server::Relay.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
+.endif
+
+.include <bsd.port.post.mk>