aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Net-SMTP-Server
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-03-23 10:37:24 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-03-23 10:37:24 +0000
commit907b83ddc490b91a548ef2405121e5061c85cf94 (patch)
tree735574d1a39cec4629ad9fd00f34f8ff4c268334 /mail/p5-Net-SMTP-Server
parent16895f4eaa5ea7feacb20cd48f9842a7f17af088 (diff)
downloadports-907b83ddc490b91a548ef2405121e5061c85cf94.tar.gz
ports-907b83ddc490b91a548ef2405121e5061c85cf94.zip
Initial import of p5-Net-SMTP-Server 1.1.
This is a native Perl SMTP Server. PR: 36203 Submitted by: Kimura Fuyuki <fuyuki@mj.0038.net>
Notes
Notes: svn path=/head/; revision=56474
Diffstat (limited to 'mail/p5-Net-SMTP-Server')
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile27
-rw-r--r--mail/p5-Net-SMTP-Server/distinfo1
-rw-r--r--mail/p5-Net-SMTP-Server/pkg-comment1
-rw-r--r--mail/p5-Net-SMTP-Server/pkg-descr6
-rw-r--r--mail/p5-Net-SMTP-Server/pkg-plist18
5 files changed, 53 insertions, 0 deletions
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
new file mode 100644
index 000000000000..4eee435c3d93
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-SMTP-Server
+# Date created: 22 March 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMTP-Server
+PORTVERSION= 1.1
+CATEGORIES= mail perl5
+MASTER_SITES= http://www.macgyver.org/software/perl/
+PKGNAMEPREFIX= p5-
+DISTNAME= SMTP-Server-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::SMTP::Server.3 \
+ Net::SMTP::Server::Client.3 \
+ Net::SMTP::Server::Relay.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Net-SMTP-Server/distinfo b/mail/p5-Net-SMTP-Server/distinfo
new file mode 100644
index 000000000000..10821ec440ef
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/distinfo
@@ -0,0 +1 @@
+MD5 (SMTP-Server-1.1.tar.gz) = 29539763294a4cbe88d3e520b3de45c1
diff --git a/mail/p5-Net-SMTP-Server/pkg-comment b/mail/p5-Net-SMTP-Server/pkg-comment
new file mode 100644
index 000000000000..7516ec5a4ac1
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/pkg-comment
@@ -0,0 +1 @@
+A native Perl SMTP Server
diff --git a/mail/p5-Net-SMTP-Server/pkg-descr b/mail/p5-Net-SMTP-Server/pkg-descr
new file mode 100644
index 000000000000..4a2655e215fb
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/pkg-descr
@@ -0,0 +1,6 @@
+This module is a complete, RFC 821 compliant, SMTP server
+implementation written entirely in Perl. It has powerful extensively
+and customization facilities that allow for a variety of potential
+uses.
+
+WWW: http://www.macgyver.org/software/perl/
diff --git a/mail/p5-Net-SMTP-Server/pkg-plist b/mail/p5-Net-SMTP-Server/pkg-plist
new file mode 100644
index 000000000000..a0b294ed30d3
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/pkg-plist
@@ -0,0 +1,18 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP/Server/Client.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP/Server/Relay.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP/Server/Client/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP/Server/Relay/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP/Server/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMTP/Server/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP/Server
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP/Server/Client
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP/Server/Relay
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP/Server
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Net/SMTP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Net 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMTP/Server
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMTP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true