aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-SES
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 12:02:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 12:02:58 +0000
commit219fdec8c7850695b49b78ded04250971fcda95d (patch)
tree37a30ea6f416808b5bf00d0a415953c74c319944 /mail/p5-SES
parent8edf9bbad86b8d2ee5c49e24e333a38f51454031 (diff)
downloadports-219fdec8c7850695b49b78ded04250971fcda95d.tar.gz
ports-219fdec8c7850695b49b78ded04250971fcda95d.zip
- Support staging
- Use shebangfix
Notes
Notes: svn path=/head/; revision=343040
Diffstat (limited to 'mail/p5-SES')
-rw-r--r--mail/p5-SES/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/mail/p5-SES/Makefile b/mail/p5-SES/Makefile
index b5e70d0a72d1..a5d804d1d330 100644
--- a/mail/p5-SES/Makefile
+++ b/mail/p5-SES/Makefile
@@ -20,25 +20,24 @@ RUN_DEPENDS= p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=6:${PORTSDIR}/www/p5-libwww
+USES= perl5 shebangfix
NO_BUILD= yes
-USES= perl5
USE_PERL5= run
USE_ZIP= yes
+
WRKSRC= ${WRKDIR}/bin
PLIST_FILES= bin/ses-get-stats.pl \
bin/ses-send-email.pl \
bin/ses-verify-email-address.pl \
%%SITE_PERL%%/SES.pm
+SHEBANG_FILES= *.pl
SCRIPTS= ses-get-stats.pl ses-send-email.pl ses-verify-email-address.pl
-NO_STAGE= yes
-post-extract:
- @cd ${WRKSRC} && ${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${SCRIPTS}
-
do-install:
- cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/SES.pm ${PREFIX}/${SITE_PERL_REL}/
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${INSTALL_DATA} ${WRKSRC}/SES.pm ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
.include <bsd.port.mk>