aboutsummaryrefslogtreecommitdiff
path: root/mail/pathalias
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-09 00:38:46 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-09 00:38:46 +0000
commitcae685eaf036d6c3ee4b14ad2bd5dc540a5da162 (patch)
treeb5409473205c0eec6ee2ea3378a8503424871c1a /mail/pathalias
parenta9c880d5f2da984db1dd7ca552bb04269c75177c (diff)
downloadports-cae685eaf036d6c3ee4b14ad2bd5dc540a5da162.tar.gz
ports-cae685eaf036d6c3ee4b14ad2bd5dc540a5da162.zip
Initial import of pathalias version 9.11.
PR: 5202 Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org>
Notes
Notes: svn path=/head/; revision=12355
Diffstat (limited to 'mail/pathalias')
-rw-r--r--mail/pathalias/Makefile29
-rw-r--r--mail/pathalias/distinfo1
-rw-r--r--mail/pathalias/files/patch-aa14
-rw-r--r--mail/pathalias/files/patch-ab23
-rw-r--r--mail/pathalias/pkg-comment1
-rw-r--r--mail/pathalias/pkg-descr14
-rw-r--r--mail/pathalias/pkg-plist2
7 files changed, 84 insertions, 0 deletions
diff --git a/mail/pathalias/Makefile b/mail/pathalias/Makefile
new file mode 100644
index 000000000000..312d19a3b189
--- /dev/null
+++ b/mail/pathalias/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pathalias
+# Version required: 9.11
+# Date created: 03 Dec 1997
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $Id$
+
+DISTNAME= pathalias11
+PKGNAME= pathalias-9.11
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.dinoex.sub.de/pub/approved/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+ALL_TARGET= pathalias
+
+MAN8= pathalias.8
+BIN8= pathalias
+
+do-install:
+.for i in ${BIN8}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${PREFIX}/man/man8
+.endfor
+
+.include <bsd.port.mk>
diff --git a/mail/pathalias/distinfo b/mail/pathalias/distinfo
new file mode 100644
index 000000000000..30d5c8000df2
--- /dev/null
+++ b/mail/pathalias/distinfo
@@ -0,0 +1 @@
+MD5 (pathalias11.tar.Z) = 7f4114d1cee45cac1fc0ece4604cb04d
diff --git a/mail/pathalias/files/patch-aa b/mail/pathalias/files/patch-aa
new file mode 100644
index 000000000000..f5273eb04826
--- /dev/null
+++ b/mail/pathalias/files/patch-aa
@@ -0,0 +1,14 @@
+*** ./mapit.c Sat Jun 9 12:32:18 1990
+--- ../../m/mapit.c Thu Feb 10 07:00:02 1994
+***************
+*** 298,303 ****
+--- 298,306 ----
+ || (NETDIR(l) == LRIGHT && (prev->n_flag & HASLEFT)))
+ cost += INF; /* mixed syntax */
+ }
++ /* Dirk meyer 10.02.94 */
++ if ( cost < 0 ) /* Overflow, more than 31 bit */
++ cost = INF; /* Limit, to avoid recursive paths */
+
+ return cost;
+ }
diff --git a/mail/pathalias/files/patch-ab b/mail/pathalias/files/patch-ab
new file mode 100644
index 000000000000..a531d8e4c164
--- /dev/null
+++ b/mail/pathalias/files/patch-ab
@@ -0,0 +1,23 @@
+diff -c ./printit.c ../../m/printit.c
+*** ./printit.c Sat Jun 9 12:32:26 1990
+--- ../../m/printit.c Thu Feb 10 07:08:42 1994
+***************
+*** 27,33 ****
+ STATIC int printable();
+
+ /* in practice, even the longest paths are < 100 bytes */
+! #define PATHSIZE 512
+
+ void
+ printit()
+--- 27,36 ----
+ STATIC int printable();
+
+ /* in practice, even the longest paths are < 100 bytes */
+! /* Dirk meyer 10.02.94 */
+! /* in reality we have reached paths up to 200 bytes */
+! /* the path must fit two times in the buffer */
+! #define PATHSIZE 4096
+
+ void
+ printit()
diff --git a/mail/pathalias/pkg-comment b/mail/pathalias/pkg-comment
new file mode 100644
index 000000000000..c4356c3698b5
--- /dev/null
+++ b/mail/pathalias/pkg-comment
@@ -0,0 +1 @@
+pathalias - mail routing tools
diff --git a/mail/pathalias/pkg-descr b/mail/pathalias/pkg-descr
new file mode 100644
index 000000000000..d1369c47727e
--- /dev/null
+++ b/mail/pathalias/pkg-descr
@@ -0,0 +1,14 @@
+
+Pathalias computes the shortest paths and corresponding
+routes from one host (computer system) to all other known,
+reachable hosts. Pathalias reads host-to-host connectiv-
+ity information on standard input or in the named files,
+and writes a list of host-route pairs on the standard out-
+put.
+
+pathalias, written by steve bellovin and peter honeyman, is in the
+public domain, and may be used by any person or organization, in
+any way and for any purpose.
+
+- ported and bugfixed
+dirk,meyer@dinoex.sub.org
diff --git a/mail/pathalias/pkg-plist b/mail/pathalias/pkg-plist
new file mode 100644
index 000000000000..4fc0bfac5711
--- /dev/null
+++ b/mail/pathalias/pkg-plist
@@ -0,0 +1,2 @@
+bin/pathalias
+man/man8/pathalias.8.gz