aboutsummaryrefslogtreecommitdiff
path: root/mail/pear-Net_IMAP/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /mail/pear-Net_IMAP/Makefile
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'mail/pear-Net_IMAP/Makefile')
-rw-r--r--mail/pear-Net_IMAP/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/pear-Net_IMAP/Makefile b/mail/pear-Net_IMAP/Makefile
index 840e5bb4a1b5..e9579b8b7bb0 100644
--- a/mail/pear-Net_IMAP/Makefile
+++ b/mail/pear-Net_IMAP/Makefile
@@ -10,8 +10,8 @@ COMMENT= PEAR class that provides an implementation of the IMAP protocol
LICENSE= PHP301
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/Auth/SASL.php:security/pear-Auth_SASL
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/Auth/SASL.php:security/pear-Auth_SASL@${PHP_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= pear