aboutsummaryrefslogtreecommitdiff
path: root/mail/perdition/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-08 13:46:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-08 13:46:50 +0000
commitf037e396011534f1ed63b7b625f818aaba3b07b6 (patch)
tree509f9c56f6c9e206681219518e92866874b3ae54 /mail/perdition/Makefile
parent8d571a7a02a3fde266288ca6716fa8521b8ab0a0 (diff)
downloadports-f037e396011534f1ed63b7b625f818aaba3b07b6.tar.gz
ports-f037e396011534f1ed63b7b625f818aaba3b07b6.zip
USE_BDB cleanup.
- USE_BDB=4x+ -> USES=bdb. - USE_BDB=yes -> USES=bdb. - USE_BDB=xx -> USES=bdb:xx. Other modernisations when I see them. PR: 209183 Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=419843
Diffstat (limited to 'mail/perdition/Makefile')
-rw-r--r--mail/perdition/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index d75830915797..6ce4af317db7 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -42,7 +42,7 @@ POSIX_REGEX_DESC= Native regex support
.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --enable-ssl
-USE_OPENSSL= yes
+USES+= ssl
.else
CONFIGURE_ARGS+= --disable-ssl
.endif
@@ -68,7 +68,7 @@ PLIST_SUB+= DAEMONMAP="@comment "
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
CONFIGURE_ARGS+= --enable-bdb
PLIST_SUB+= BDB=""
-USE_BDB= yes
+USES+= bdb
.else
CONFIGURE_ARGS+= --disable-bdb
PLIST_SUB+= BDB="@comment "
@@ -92,7 +92,7 @@ PLIST_SUB+= GDBM="@comment "
.endif
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
+USES+= mysql
CONFIGURE_ARGS+= --enable-mysql
PLIST_SUB+= MYSQL=""
.else