aboutsummaryrefslogtreecommitdiff
path: root/mail/pine-pgp-filters
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2005-10-29 07:13:29 +0000
committerDoug Barton <dougb@FreeBSD.org>2005-10-29 07:13:29 +0000
commitcfda064524df95df7a3a4bcc39d53de830654a3a (patch)
tree0b5d354ef722c309198f41c36abd681847e2234f /mail/pine-pgp-filters
parent4aa008339dac2682d3d541f91c3b92cab1323cd4 (diff)
downloadports-cfda064524df95df7a3a4bcc39d53de830654a3a.tar.gz
ports-cfda064524df95df7a3a4bcc39d53de830654a3a.zip
For the ports that I maintain, do the following as appropriate:
1. Add myself as a backup master site (Sourceforge and CPAN ports already have good enough coverage, so skip them). 2. For all ports that have them, download the PGP signature files. 3. For ports in 2, add a verify target to the Makefile 4. For ports where I was already providing a master site, update the URL. 5. Pet portlint in a couple of places.
Notes
Notes: svn path=/head/; revision=146646
Diffstat (limited to 'mail/pine-pgp-filters')
-rw-r--r--mail/pine-pgp-filters/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail/pine-pgp-filters/Makefile b/mail/pine-pgp-filters/Makefile
index 0d5a2bed8d6d..0bb4503813d7 100644
--- a/mail/pine-pgp-filters/Makefile
+++ b/mail/pine-pgp-filters/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pine-pgp-filters
PORTVERSION= 1.2
CATEGORIES= mail security
-MASTER_SITES= http://dougbarton.net/FreeBSD/Downloads/ \
+MASTER_SITES= http://dougbarton.us/Downloads/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dougb
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -17,6 +17,9 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= DougB@FreeBSD.org
COMMENT= Simple, fast, sh-based filters to integrate Pine with gnupg, or pgp6
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
do-build:
cd ${WRKSRC} && ./configure --prefix=${PREFIX}