aboutsummaryrefslogtreecommitdiff
path: root/mail/policyd2/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /mail/policyd2/Makefile
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'mail/policyd2/Makefile')
-rw-r--r--mail/policyd2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/policyd2/Makefile b/mail/policyd2/Makefile
index 40bede30eb5a..7d1e01e3684f 100644
--- a/mail/policyd2/Makefile
+++ b/mail/policyd2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= policyd2
PORTVERSION= 2.0.12
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://devlabs.linuxassist.net/attachments/download/${DOWNLOAD_FOLDER}/
DISTNAME= cluebringer-${PORTVERSION}
@@ -58,7 +58,7 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR} \
- ${STAGEDIR}${SITE_PERL}/cbp \
+ ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/cbp \
${STAGEDIR}${DATADIR} \
${STAGEDIR}${DOCSDIR}
${INSTALL_SCRIPT} ${WRKSRC}/cbpadmin ${STAGEDIR}${PREFIX}/bin
@@ -66,7 +66,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/cluebringer.conf \
${STAGEDIR}${PREFIX}/etc/cluebringer.conf.sample
(cd ${WRKSRC}/webui && ${COPYTREE_SHARE} \* ${STAGEDIR}${WWWDIR})
- (cd ${WRKSRC}/cbp && ${COPYTREE_SHARE} \* ${STAGEDIR}${SITE_PERL}/cbp)
+ (cd ${WRKSRC}/cbp && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/cbp)
(cd ${WRKSRC} && ${COPYTREE_SHARE} contrib ${STAGEDIR}${DATADIR})
(cd ${WRKSRC} && ${COPYTREE_SHARE} database ${STAGEDIR}${DATADIR})
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})