aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current
diff options
context:
space:
mode:
authorHerbert J. Skuhra <herbert@gojira.at>2024-02-23 07:37:22 +0000
committerJuraj Lutter <otis@FreeBSD.org>2024-02-23 07:41:27 +0000
commit1fabd73f472b3db14977e4914657b266f126a1fe (patch)
tree1164dca82c626069d9adbfc06fe6092a405b1cf0 /mail/postfix-current
parentdceadb6b0011e8151b11a4859b6b0cac7e2bb523 (diff)
downloadports-1fabd73f472b3db14977e4914657b266f126a1fe.tar.gz
ports-1fabd73f472b3db14977e4914657b266f126a1fe.zip
mail/postfix-current: Update to 3.9-20240218 and add MongoDB support
MongoDB support was added in upstream on 20240208.
Diffstat (limited to 'mail/postfix-current')
-rw-r--r--mail/postfix-current/Makefile30
-rw-r--r--mail/postfix-current/distinfo6
-rw-r--r--mail/postfix-current/pkg-plist4
3 files changed, 33 insertions, 7 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index c2a4cf9b3a5c..d74cb048ab1a 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -1,5 +1,5 @@
PORTNAME= postfix
-DISTVERSION= 3.9-20240121
+DISTVERSION= 3.9-20240218
PORTREVISION?= 0
PORTEPOCH= 6
CATEGORIES= mail
@@ -23,39 +23,52 @@ LICENSE_NAME_IPL10= IBM PUBLIC LICENSE VERSION 1.0
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS_IPL10= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-FLAVORS= default ldap mysql pgsql sasl sqlite
+FLAVORS= default ldap mongo mysql pgsql sasl sqlite
default_CONFLICTS_INSTALL= postfix-current-base-ldap postfix-current-base-sasl \
postfix-current-ldap postfix-current-sasl \
+ postfix-current-mongo postfix-current-base-mongo \
postfix-current-mysql postfix-current-base-mysql \
postfix-current-pgsql postfix-current-base-pgsql \
postfix-current-sqlite postfix-current-base-sqlite
ldap_PKGNAMESUFFIX= -current-ldap
ldap_CONFLICTS_INSTALL= postfix-current postfix-current-base \
postfix-current-base-sasl postfix-current-sasl \
+ postfix-current-mongo postfix-current-base-mongo \
postfix-current-mysql postfix-current-base-mysql \
postfix-current-pgsql postfix-current-base-pgsql \
postfix-current-sqlite postfix-current-base-sqlite
+mongo_PKGNAMESUFFIX= -current-mongo
+mongo_CONFLICTS_INSTALL= postfix-current postfix-current-base \
+ postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-mysql postfix-current-base-mysql \
+ postfix-current-pgsql postfix-current-base-pgsql \
+ postfix-current-sasl postfix-current-base-sasl \
+ postfix-current-sqlite postfix-current-base-sqlite
mysql_PKGNAMESUFFIX= -current-mysql
mysql_CONFLICTS_INSTALL= postfix-current postfix-current-base \
postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-mongo postfix-current-base-mongo \
postfix-current-pgsql postfix-current-base-pgsql \
postfix-current-sasl postfix-current-base-sasl \
postfix-current-sqlite postfix-current-base-sqlite
pgsql_PKGNAMESUFFIX= -current-pgsql
pgsql_CONFLICTS_INSTALL= postfix-current postfix-current-base \
postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-mongo postfix-current-base-mongo \
postfix-current-mysql postfix-current-base-mysql \
postfix-current-sasl postfix-current-base-sasl \
postfix-current-sqlite postfix-current-base-sqlite
sasl_PKGNAMESUFFIX= -current-sasl
sasl_CONFLICTS_INSTALL= postfix-current postfix-current-base \
postfix-current-base-ldap postfix-current-ldap \
+ postfix-current-mongo postfix-current-base-mongo \
postfix-current-mysql postfix-current-base-mysql \
postfix-current-pgsql postfix-current-base-pgsql \
postfix-current-sqlite postfix-current-base-sqlite
sqlite_PKGNAMESUFFIX= -current-sqlite
sqlite_CONFLICTS_INSTALL= postfix-current postfix-current-base \
postfix-current-ldap postfix-current-base-ldap \
+ postfix-current-mongo postfix-current-base-mongo \
postfix-current-mysql postfix-current-base-mysql \
postfix-current-pgsql postfix-current-base-pgsql \
postfix-current-sasl postfix-current-base-sasl
@@ -79,8 +92,8 @@ CONFLICTS_INSTALL= courier-0.* opensmtpd opensmtpd-devel \
USERS= postfix
GROUPS= mail maildrop postfix
-OPTIONS_DEFINE= BDB BLACKLISTD CDB DOCS EAI INST_BASE LDAP LMDB MYSQL \
- NIS PCRE2 PGSQL SASL SQLITE TEST TLS
+OPTIONS_DEFINE= BDB BLACKLISTD CDB DOCS EAI INST_BASE LDAP LMDB MONGO \
+ MYSQL NIS PCRE2 PGSQL SASL SQLITE TEST TLS
OPTIONS_DEFAULT?= BLACKLISTD EAI PCRE2 TLS
OPTIONS_RADIO= RG1
OPTIONS_RADIO_RG1= SASLKMIT SASLKRB5
@@ -113,6 +126,8 @@ CDB_LIB_DEPENDS= libcdb.so:databases/tinycdb
EAI_LIB_DEPENDS= libicuuc.so:devel/icu
LDAP_USES= ldap
LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
+MONGO_LIB_DEPENDS= libbson-1.0.so:devel/libbson \
+ libmongoc-1.0.so:devel/mongo-c-driver
MYSQL_USES?= mysql
PCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
PGSQL_USES= pgsql
@@ -261,6 +276,13 @@ IGNORE= blacklistd is only supported on FreeBSD
. endif
.endif
+.if ${PORT_OPTIONS:MMONGO}
+DYN_EXT+= mongodb
+POSTFIX_CCARGS+= -DHAS_MONGODB -I${LOCALBASE}/include/libmongoc-1.0 \
+ -I${LOCALBASE}/include/libbson-1.0
+POSTFIX_DYN_AUXLIBS+= "AUXLIBS_MONGODB=-L${LOCALBASE}/lib -lmongoc-1.0 -lbson-1.0"
+.endif
+
.if ${PORT_OPTIONS:MMYSQL}
DYN_EXT+= mysql
POSTFIX_CCARGS+= -DHAS_MYSQL -I${LOCALBASE}/include/mysql
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index e0d91244bd98..5dcaa0f34802 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1705933136
-SHA256 (postfix/postfix-3.9-20240121.tar.gz) = 03eed15a6705e39398d85601f49347f23a1ece9f3d1b253740bf8ed38865fc33
-SIZE (postfix/postfix-3.9-20240121.tar.gz) = 4914071
+TIMESTAMP = 1708672440
+SHA256 (postfix/postfix-3.9-20240218.tar.gz) = 48b4e16cd767d3154c2a4ed24bc3cf21305b096d4c02bf08b21b139a264f2890
+SIZE (postfix/postfix-3.9-20240218.tar.gz) = 4927676
diff --git a/mail/postfix-current/pkg-plist b/mail/postfix-current/pkg-plist
index 0bc26f8b07fb..1bd4e6b2708c 100644
--- a/mail/postfix-current/pkg-plist
+++ b/mail/postfix-current/pkg-plist
@@ -28,6 +28,7 @@ lib/postfix/libpostfix-util.so
%%CDB%%lib/postfix/postfix-cdb.so
%%LDAP%%lib/postfix/postfix-ldap.so
%%LMDB%%lib/postfix/postfix-lmdb.so
+%%MONGO%%lib/postfix/postfix-mongodb.so
%%MYSQL%%lib/postfix/postfix-mysql.so
%%PCRE2%%lib/postfix/postfix-pcre.so
%%PGSQL%%lib/postfix/postfix-pgsql.so
@@ -41,6 +42,7 @@ libexec/postfix/dynamicmaps.cf
%%CDB%%libexec/postfix/dynamicmaps.cf.d/cdb.cf
%%LDAP%%libexec/postfix/dynamicmaps.cf.d/ldap.cf
%%LMDB%%libexec/postfix/dynamicmaps.cf.d/lmdb.cf
+%%MONGO%%libexec/postfix/dynamicmaps.cf.d/mongodb.cf
%%MYSQL%%libexec/postfix/dynamicmaps.cf.d/mysql.cf
%%PCRE2%%libexec/postfix/dynamicmaps.cf.d/pcre.cf
%%PGSQL%%libexec/postfix/dynamicmaps.cf.d/pgsql.cf
@@ -62,6 +64,7 @@ libexec/postfix/postfix-files
%%CDB%%libexec/postfix/postfix-files.d/cdb-files
%%LDAP%%libexec/postfix/postfix-files.d/ldap-files
%%LMDB%%libexec/postfix/postfix-files.d/lmdb-files
+%%MONGO%%libexec/postfix/postfix-files.d/mongodb-files
%%MYSQL%%libexec/postfix/postfix-files.d/mysql-files
%%PCRE2%%libexec/postfix/postfix-files.d/pcre-files
%%PGSQL%%libexec/postfix/postfix-files.d/pgsql-files
@@ -119,6 +122,7 @@ share/man/man5/ldap_table.5.gz
share/man/man5/lmdb_table.5.gz
share/man/man5/master.5.gz
share/man/man5/memcache_table.5.gz
+share/man/man5/mongodb_table.5.gz
share/man/man5/mysql_table.5.gz
share/man/man5/nisplus_table.5.gz
share/man/man5/pcre_table.5.gz