aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-current
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-02-20 06:21:36 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-02-20 06:21:36 +0000
commitd188c90c0336647ed8b5fa49884445b33c78b3f9 (patch)
tree83fc5d6f563f22dff715baeede638ab6476b2541 /mail/postfix-current
parent4443818f1f69e29a55d6b5db6dcc87953a4ebe68 (diff)
downloadports-d188c90c0336647ed8b5fa49884445b33c78b3f9.tar.gz
ports-d188c90c0336647ed8b5fa49884445b33c78b3f9.zip
Update to 2.9-20110219, update CONFLICTS, alphabetically
sort packing list, and tweak PKGNAMESUFFIX when INST_BASE is defined. Also, sync OPTIONS with mail/postfix to warn users trying to build this port with unsupported options. Finally, modify pkg-install script to check if Postfix is already enabled in mailer.conf. PR: ports/154495 Submitted by: ohauer Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=269371
Diffstat (limited to 'mail/postfix-current')
-rw-r--r--mail/postfix-current/Makefile39
-rw-r--r--mail/postfix-current/distinfo4
-rw-r--r--mail/postfix-current/files/pkg-install.in32
-rw-r--r--mail/postfix-current/pkg-plist34
4 files changed, 72 insertions, 37 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 195bb7e88a57..f31ae1db546d 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-DISTVERSION= 2.8-20101108
+DISTVERSION= 2.9-20110219
PORTEPOCH= 4
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/experimental/ \
@@ -21,9 +21,14 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= mnag@FreeBSD.org
COMMENT= A secure alternative to widely-used Sendmail
-CONFLICTS= courier-0.* postfix-1.* postfix-2.* postfix-current-2.[0-79]* \
+CONFLICTS= courier-0.* postfix-1.* postfix-2.* postfix-base-2.* \
+ postfix-current-2.[0-8]* postfix-current-base-2.[0-8]* \
sendmail-8.* sendmail+*-8.* smail-3.* zmailer-2.*
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+IS_INTERACTIVE= yes
+.endif
+
MAKE_JOBS_SAFE= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
@@ -31,7 +36,7 @@ SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL2 SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test SPF
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -42,19 +47,22 @@ STATUS_${o}=on
OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
SASL2 "Cyrus SASLv2 (Simple Auth. and Sec. Layer)" ${STATUS_SASL2} \
- DOVECOT "Dovecot SASL authentication method" off \
+ DOVECOT "Dovecot 1.x SASL authentication method" off \
+ DOVECOT2 "Dovecot 2.x SASL authentication method" off \
SASLKRB5 "If your SASL req. Kerberos5 select this option" ${STATUS_SASLKRB5} \
SASLKMIT "If your SASL req. MIT Kerberos5 select this option" ${STATUS_SASLKRB5MIT} \
TLS "Enable SSL and TLS support" ${STATUS_TLS} \
BDB "Berkeley DB (choose version with WITH_BDB_VER)" ${STATUS_BDB} \
MYSQL "MySQL maps (choose version with WITH_MYSQL_VER)" ${STATUS_MySQL} \
- PGSQL "PostgreSQL maps (choose with DEFAULT_PGSQL_VER)" ${STATUS_PgSQL} \
+ PGSQL "PostgreSQL maps (pick ver. with DEFAULT_PGSQL_VER)" ${STATUS_PgSQL} \
SQLITE "SQLite maps" off \
OPENLDAP "OpenLDAP maps (choose ver. with WITH_OPENLDAP_VER)" ${STATUS_OpenLDAP} \
+ LDAP_SASL "Enable OpenLDAP client-to-server auth via SASL" off \
CDB "CDB maps lookups" ${STATUS_CDB} \
NIS "NIS maps lookups" ${STATUS_NIS} \
VDA "VDA (Virtual Delivery Agent 32Bit)" ${STATUS_VDA} \
TEST "SMTP/LMTP test server and generator" ${STATUS_Test} \
+ SPF "SPF support (via libspf2 1.2.x)" ${STATUS_SPF} \
INST_BASE "Install into /usr and /etc/postfix" off
.include <bsd.port.options.mk>
@@ -70,7 +78,7 @@ MAN5= access.5 aliases.5 bounce.5 canonical.5 cidr_table.5 generic.5 \
MAN8= anvil.8 bounce.8 cleanup.8 discard.8 dnsblog.8 error.8 flush.8 local.8 master.8 \
oqmgr.8 pickup.8 pipe.8 postscreen.8 proxymap.8 qmgr.8 qmqpd.8 scache.8 showq.8 \
- smtp.8 smtpd.8 spawn.8 tlsmgr.8 trivial-rewrite.8 verify.8 virtual.8
+ smtp.8 smtpd.8 spawn.8 tlsmgr.8 tlsproxy.8 trivial-rewrite.8 verify.8 virtual.8
MLINKS= sendmail.1 mailq.1 \
sendmail.1 newaliases.1 \
@@ -119,8 +127,16 @@ POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${LOCALBASE}/include -I${LOC
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lsasl2 -lpam -lcrypt
.endif
+.if defined(WITH_DOVECOT) && defined(WITH_DOVECOT2)
+BROKEN= Select only one Dovecot option
+.endif
+
+.if defined(WITH_DOVECOT) || defined(WITH_DOVECOT2)
.if defined(WITH_DOVECOT)
RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot
+.else
+RUN_DEPENDS+= dovecot:${PORTSDIR}/mail/dovecot2
+.endif
POSTFIX_CCARGS+= -DUSE_SASL_AUTH -DDEF_SERVER_SASL_TYPE=\\\"dovecot\\\"
_REQUIRE+= dovecot
.endif
@@ -149,6 +165,10 @@ POSTFIX_CCARGS+= -DUSE_TLS -I${OPENSSLINC}
POSTFIX_AUXLIBS+= -L${OPENSSLLIB} ${LDFLAGS} -lssl -lcrypto
.endif
+.if defined(WITH_SPF)
+BROKEN= At the moment, SPF support is unavailable for ${PORTNAME}-${DISTVERSION}
+.endif
+
.if defined(WITH_BDB)
USE_BDB= yes
POSTFIX_CCARGS+= -I${BDB_INCLUDE_DIR}
@@ -183,6 +203,9 @@ WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
POSTFIX_CCARGS+= -DHAS_LDAP -I${LOCALBASE}/include
POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lldap -llber
_REQUIRE+= slapd
+.if defined(WITH_LDAP_SASL)
+POSTFIX_CCARGS+= -DUSE_LDAP_SASL
+.endif
.endif
.if defined(WITH_CDB)
@@ -197,7 +220,7 @@ _REQUIRE+= ypserv
.endif
.if defined(WITH_VDA)
-BROKEN= At the moment there is no VDA patch for ${PORTNAME}-${DISTVERSION} available
+BROKEN= At the moment, VDA support is unavailable for ${PORTNAME}-${DISTVERSION}
.endif
.if defined(WITH_TEST)
@@ -210,7 +233,7 @@ PLIST_SUB+= TEST="@comment "
.endif
.if defined(WITH_INST_BASE)
-PKGNAMESUFFIX+= -base
+PKGNAMESUFFIX= -current-base
PREFIX= /usr
ETCDIR= /etc/postfix
USE_RCORDER= postfix.sh
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index 3797c1b9893e..c1dba413069d 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postfix/postfix-2.8-20101108.tar.gz) = da355c6b68de6c5d79b847cc7c566f6595ef4b3fde991cee55f297325316d065
-SIZE (postfix/postfix-2.8-20101108.tar.gz) = 3548784
+SHA256 (postfix/postfix-2.9-20110219.tar.gz) = 0146816869862f86243cd05a61d8cf319c95c2a9d40c9fe193998944b3dec7d9
+SIZE (postfix/postfix-2.9-20110219.tar.gz) = 3651218
diff --git a/mail/postfix-current/files/pkg-install.in b/mail/postfix-current/files/pkg-install.in
index 3e90b486cb71..b85eb41930a0 100644
--- a/mail/postfix-current/files/pkg-install.in
+++ b/mail/postfix-current/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix-current/files/pkg-install.in,v 1.1 2010-07-30 03:39:18 sahil Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix-current/files/pkg-install.in,v 1.2 2011-02-20 06:21:36 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -13,6 +13,7 @@ DAEMONDIR=${DAEMONDIR:=%%DAEMONDIR%%}
READMEDIR=${READMEDIR:=%%READMEDIR%%}
BATCH=${BATCH:=no}
POSTFIX_DEFAULT_MTA=${POSTFIX_DEFAULT_MTA:=no}
+MC=/etc/mail/mailer.conf
if [ "${POSTFIX_DEFAULT_MTA}" = "no" ]; then
DEFAULT_REPLACE_MAILERCONF=n
@@ -144,15 +145,24 @@ replace() {
}
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^mailq.*${PREFIX}/sbin/sendmail" ${MC} && \
+ egrep -q "^newaliases.*${PREFIX}/sbin/sendmail" ${MC}
+ ret=$?
+ if [ ${ret} -ne 0 ]; then
+ if yesno "Would you like to activate Postfix in ${MC}" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f ${MC} ${MC}.old
+ echo "#" > ${MC}
+ echo -n "# Execute the Postfix sendmail program" >> ${MC}
+ echo ", named ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "#" >> ${MC}
+ echo "sendmail ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "send-mail ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "mailq ${PREFIX}/sbin/sendmail" >> ${MC}
+ echo "newaliases ${PREFIX}/sbin/sendmail" >> ${MC}
+ fi
+ else
+ echo "Postfix already activated in ${MC}"
fi
fi
diff --git a/mail/postfix-current/pkg-plist b/mail/postfix-current/pkg-plist
index 8f3c3ad97937..8b519972d9ec 100644
--- a/mail/postfix-current/pkg-plist
+++ b/mail/postfix-current/pkg-plist
@@ -1,5 +1,13 @@
@unexec if cmp -s %D/libexec/postfix/main.cf %%PFETC%%/main.cf; then rm -f %%PFETC%%/main.cf; fi
@unexec if cmp -s %D/libexec/postfix/master.cf %%PFETC%%/master.cf; then rm -f %%PFETC%%/master.cf; fi
+bin/mailq
+bin/newaliases
+%%TEST%%bin/qmqp-sink
+%%TEST%%bin/qmqp-source
+bin/qshape
+bin/rmail
+%%TEST%%bin/smtp-sink
+%%TEST%%bin/smtp-source
libexec/postfix/anvil
libexec/postfix/bounce
libexec/postfix/cleanup
@@ -30,19 +38,11 @@ libexec/postfix/showq
libexec/postfix/smtp
libexec/postfix/smtpd
libexec/postfix/spawn
+libexec/postfix/tlsmgr
+libexec/postfix/tlsproxy
libexec/postfix/trivial-rewrite
libexec/postfix/verify
libexec/postfix/virtual
-libexec/postfix/tlsmgr
-@dirrm libexec/postfix
-bin/mailq
-bin/newaliases
-bin/qshape
-bin/rmail
-%%TEST%%bin/qmqp-sink
-%%TEST%%bin/qmqp-source
-%%TEST%%bin/smtp-sink
-%%TEST%%bin/smtp-source
sbin/postalias
sbin/postcat
sbin/postconf
@@ -91,8 +91,6 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.html
%%PORTDOCS%%%%DOCSDIR%%/IPV6_README
%%PORTDOCS%%%%DOCSDIR%%/IPV6_README.html
-%%PORTDOCS%%%%DOCSDIR%%/TLS_README
-%%PORTDOCS%%%%DOCSDIR%%/TLS_README.html
%%PORTDOCS%%%%DOCSDIR%%/LDAP_README
%%PORTDOCS%%%%DOCSDIR%%/LDAP_README.html
%%PORTDOCS%%%%DOCSDIR%%/LINUX_README
@@ -144,6 +142,8 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/STRESS_README.html
%%PORTDOCS%%%%DOCSDIR%%/TLS_LEGACY_README
%%PORTDOCS%%%%DOCSDIR%%/TLS_LEGACY_README.html
+%%PORTDOCS%%%%DOCSDIR%%/TLS_README
+%%PORTDOCS%%%%DOCSDIR%%/TLS_README.html
%%PORTDOCS%%%%DOCSDIR%%/TUNING_README
%%PORTDOCS%%%%DOCSDIR%%/TUNING_README.html
%%PORTDOCS%%%%DOCSDIR%%/ULTRIX_README
@@ -171,6 +171,7 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/dnsblog.8.html
%%PORTDOCS%%%%DOCSDIR%%/error.8.html
%%PORTDOCS%%%%DOCSDIR%%/flush.8.html
+%%PORTDOCS%%%%DOCSDIR%%/generic.5.html
%%PORTDOCS%%%%DOCSDIR%%/header_checks.5.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/ldap_table.5.html
@@ -180,8 +181,8 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/master.5.html
%%PORTDOCS%%%%DOCSDIR%%/master.8.html
%%PORTDOCS%%%%DOCSDIR%%/mysql_table.5.html
-%%PORTDOCS%%%%DOCSDIR%%/nisplus_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/newaliases.1.html
+%%PORTDOCS%%%%DOCSDIR%%/nisplus_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/oqmgr.8.html
%%PORTDOCS%%%%DOCSDIR%%/pcre_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/pgsql_table.5.html
@@ -213,8 +214,8 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/qshape.1.html
%%PORTDOCS%%%%DOCSDIR%%/regexp_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/relocated.5.html
-%%PORTDOCS%%%%DOCSDIR%%/sendmail.1.html
%%PORTDOCS%%%%DOCSDIR%%/scache.8.html
+%%PORTDOCS%%%%DOCSDIR%%/sendmail.1.html
%%PORTDOCS%%%%DOCSDIR%%/showq.8.html
%%PORTDOCS%%%%DOCSDIR%%/smtp-sink.1.html
%%PORTDOCS%%%%DOCSDIR%%/smtp-source.1.html
@@ -223,15 +224,16 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/spawn.8.html
%%PORTDOCS%%%%DOCSDIR%%/sqlite_table.5.html
%%PORTDOCS%%%%DOCSDIR%%/tcp_table.5.html
+%%PORTDOCS%%%%DOCSDIR%%/tlsmgr.8.html
+%%PORTDOCS%%%%DOCSDIR%%/tlsproxy.8.html
%%PORTDOCS%%%%DOCSDIR%%/trace.8.html
%%PORTDOCS%%%%DOCSDIR%%/transport.5.html
%%PORTDOCS%%%%DOCSDIR%%/trivial-rewrite.8.html
%%PORTDOCS%%%%DOCSDIR%%/verify.8.html
%%PORTDOCS%%%%DOCSDIR%%/virtual.5.html
%%PORTDOCS%%%%DOCSDIR%%/virtual.8.html
-%%PORTDOCS%%%%DOCSDIR%%/tlsmgr.8.html
-%%PORTDOCS%%%%DOCSDIR%%/generic.5.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm libexec/postfix
%%BASE%%@cwd /
etc/postfix/LICENSE
etc/postfix/TLS_LICENSE