aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix27
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-03-22 03:50:45 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-03-22 03:50:45 +0000
commit9ad50695f9408f466065fa675daf8be09c746a64 (patch)
tree201b5f1ecf52ca26c472e709529b131cc6fc7b63 /mail/postfix27
parentb15311b1c11cdf9665de0d927b4483f640c24d07 (diff)
downloadports-9ad50695f9408f466065fa675daf8be09c746a64.tar.gz
ports-9ad50695f9408f466065fa675daf8be09c746a64.zip
Add an option to install into the base, and related support
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=251357
Diffstat (limited to 'mail/postfix27')
-rw-r--r--mail/postfix27/Makefile17
-rw-r--r--mail/postfix27/pkg-plist17
2 files changed, 23 insertions, 11 deletions
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index c2de16e14f82..4f7cf745963c 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -28,7 +28,6 @@ CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-68-9].* postfix-current-2.* \
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
-USE_RC_SUBR= postfix.sh
SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
@@ -56,7 +55,8 @@ OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
CDB "CDB maps lookups" ${STATUS_CDB} \
NIS "NIS maps lookups" ${STATUS_NIS} \
VDA "VDA (Virtual Delivery Agent 32Bit)" ${STATUS_VDA} \
- TEST "SMTP/LMTP test server and generator" ${STATUS_Test}
+ TEST "SMTP/LMTP test server and generator" ${STATUS_Test} \
+ INST_BASE "Install into /usr and /etc/postfix" off
.include <bsd.port.options.mk>
@@ -218,6 +218,17 @@ PLIST_SUB+= TEST=""
PLIST_SUB+= TEST="@comment "
.endif
+.if defined(WITH_INST_BASE)
+PKGNAMESUFFIX= -base
+PREFIX= /usr
+ETCDIR= /etc/postfix
+USE_RCORDER= postfix.sh
+.else
+USE_RC_SUBR= postfix.sh
+.endif
+
+PLIST_SUB+= PFETC=${ETCDIR}
+
.if defined(NOPORTDOCS)
READMEDIR= no
.else
@@ -238,7 +249,7 @@ REINPLACE= s!^PATH=.*!PATH=/bin:/sbin:/usr/bin:/usr/sbin:${PREFIX}/bin:${PREFIX}
s!^(newaliases_path =)!\1 ${PREFIX}/bin/newaliases!g;\
s!^(mailq_path =)!\1 ${PREFIX}/bin/mailq!g;\
s!^(setgid_group =)!\1 maildrop!g;\
- s!^(manpage_directory =)!\1 ${PREFIX}/man!g;\
+ s!^(manpage_directory =)!\1 ${MANPREFIX}/man!g;\
s!^((html|readme)_directory =)!\1 ${READMEDIR}!g;\
\!^\#alias_database = dbm:/etc/mail/aliases$$!d;\
s!(:|= )/etc/postfix!\1$$config_directory!g;\
diff --git a/mail/postfix27/pkg-plist b/mail/postfix27/pkg-plist
index 8fb4a369b2c8..50ddec524e75 100644
--- a/mail/postfix27/pkg-plist
+++ b/mail/postfix27/pkg-plist
@@ -1,11 +1,5 @@
-@unexec if cmp -s %D/libexec/postfix/main.cf %D/%%ETCDIR%%/main.cf; then rm -f %D/%%ETCDIR%%/main.cf; fi
-@unexec if cmp -s %D/libexec/postfix/master.cf %D/%%ETCDIR%%/master.cf; then rm -f %D/%%ETCDIR%%/master.cf; fi
-%%ETCDIR%%/LICENSE
-%%ETCDIR%%/TLS_LICENSE
-%%ETCDIR%%/bounce.cf.default
-%%ETCDIR%%/main.cf.default
-%%ETCDIR%%/makedefs.out
-@dirrmtry %%ETCDIR%%
+@unexec if cmp -s %D/libexec/postfix/main.cf %%PFETC%%/main.cf; then rm -f %%PFETC%%/main.cf; fi
+@unexec if cmp -s %D/libexec/postfix/master.cf %%PFETC%%/master.cf; then rm -f %%PFETC%%/master.cf; fi
libexec/postfix/anvil
libexec/postfix/bounce
libexec/postfix/cleanup
@@ -230,3 +224,10 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/tlsmgr.8.html
%%PORTDOCS%%%%DOCSDIR%%/generic.5.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@cd /
+%%PFETC%%/LICENSE
+%%PFETC%%/TLS_LICENSE
+%%PFETC%%/bounce.cf.default
+%%PFETC%%/main.cf.default
+%%PFETC%%/makedefs.out
+@dirrmtry %%PFETC%%