aboutsummaryrefslogtreecommitdiff
path: root/mail/py-pyspf/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-02-03 20:54:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-02-03 20:54:37 +0000
commit5dab0e29c16bda684d63e2f3a2b32b6252437c6f (patch)
treeb0dc87bc8064445bfec3b1bf415aeea02318dfff /mail/py-pyspf/Makefile
parent1dc8e20ba00654b99d9d203d56dd949db4287977 (diff)
downloadports-5dab0e29c16bda684d63e2f3a2b32b6252437c6f.tar.gz
ports-5dab0e29c16bda684d63e2f3a2b32b6252437c6f.zip
- Sort knobs
- Remove outdated PYTHON_REL check - Use post-patch: - Do not silence test message
Notes
Notes: svn path=/head/; revision=407979
Diffstat (limited to 'mail/py-pyspf/Makefile')
-rw-r--r--mail/py-pyspf/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/mail/py-pyspf/Makefile b/mail/py-pyspf/Makefile
index e7f608bf9731..6643667cd5d7 100644
--- a/mail/py-pyspf/Makefile
+++ b/mail/py-pyspf/Makefile
@@ -17,11 +17,9 @@ LICENSE= PSFL
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}authres>=0:${PORTSDIR}/mail/py-authres
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml
-USES= python shebangfix
-USE_PYTHON= autoplist concurrent distutils
-
NO_ARCH= yes
-
+USE_PYTHON= autoplist concurrent distutils
+USES= python shebangfix
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/spf.py
@@ -29,10 +27,6 @@ SHEBANG_FILES= spf.py
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} <= 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipaddr>=0:${PORTSDIR}/devel/py-ipaddr
-.endif
-
.if ${PYTHON_REL} >= 3000
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}py3dns>=0:${PORTSDIR}/dns/py-py3dns
.else
@@ -40,7 +34,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dns>=0:${PORTSDIR}/dns/py-dns
.endif
# Make the tests run as a module
-post-extract:
+post-patch:
@${TOUCH} ${WRKSRC}/test/__init__.py
post-install:
@@ -48,6 +42,6 @@ post-install:
${LN} -s ${PYTHONPREFIX_SITELIBDIR}/spf.py ${STAGEDIR}${PREFIX}/bin/
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m test.testspf
+ cd ${WRKSRC}/ && ${PYTHON_CMD} -m test.testspf
.include <bsd.port.post.mk>