aboutsummaryrefslogtreecommitdiff
path: root/mail/py-python-slimta
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-01-08 16:30:48 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-01-08 16:30:48 +0000
commit4203db73b9d9ea030f9683f5417c331f65dc8422 (patch)
tree17fbb956f654c19ae0e387366a7445c685e04a5a /mail/py-python-slimta
parent2c5943e4bd8372527fc3e52db02005473e6a5206 (diff)
downloadports-4203db73b9d9ea030f9683f5417c331f65dc8422.tar.gz
ports-4203db73b9d9ea030f9683f5417c331f65dc8422.zip
New port: mail/py-python-slimta: Python libraries to send, receive, and queue email
Reviewed by: 0mp (mentor) Approved by: 0mp (mentor) Differential Revision: https://reviews.freebsd.org/D28033
Notes
Notes: svn path=/head/; revision=560792
Diffstat (limited to 'mail/py-python-slimta')
-rw-r--r--mail/py-python-slimta/Makefile35
-rw-r--r--mail/py-python-slimta/distinfo3
-rw-r--r--mail/py-python-slimta/pkg-descr7
3 files changed, 45 insertions, 0 deletions
diff --git a/mail/py-python-slimta/Makefile b/mail/py-python-slimta/Makefile
new file mode 100644
index 000000000000..e9e7ae5fadc5
--- /dev/null
+++ b/mail/py-python-slimta/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= python-slimta
+PORTVERSION= 4.1.1
+CATEGORIES= mail
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Python libraries to send, receive, and queue email
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>=1.1rc:devel/py-gevent@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycares>=1:dns/py-pycares@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysasl>=0.4.0:mail/py-pysasl@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+OPTIONS_DEFINE= BOTO REDIS SASL
+OPTIONS_DEFAULT= SASL
+
+BOTO_DESC= Support for Amazon Web Services
+REDIS_DESC= Redis Support
+SASL_DESC= SASL Support
+
+BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${PY_FLAVOR}
+REDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>0:databases/py-redis@${PY_FLAVOR}
+SASL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyspf>0:mail/py-pyspf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}py3dns>0:dns/py-py3dns@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/mail/py-python-slimta/distinfo b/mail/py-python-slimta/distinfo
new file mode 100644
index 000000000000..5c31208f0808
--- /dev/null
+++ b/mail/py-python-slimta/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609989461
+SHA256 (python-slimta-4.1.1.tar.gz) = 3d84fecfdb4e43e41fe7b6b6944d6902fbbf6f6f9d5ecd5dc20c0c8f776c5c90
+SIZE (python-slimta-4.1.1.tar.gz) = 119888
diff --git a/mail/py-python-slimta/pkg-descr b/mail/py-python-slimta/pkg-descr
new file mode 100644
index 000000000000..7f935194eeb7
--- /dev/null
+++ b/mail/py-python-slimta/pkg-descr
@@ -0,0 +1,7 @@
+The python-slimta project is a Python library offering the building blocks
+necessary to create a full-featured MTA. An MTA built with python-slimta can
+incorporate any protocol or policy - custom or built-in. An MTA built with
+python-slimta can integrate with other Python libraries and take advantage
+of Python’s great community.
+
+WWW: https://www.slimta.org/