aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-02-23 18:49:29 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-02-23 18:49:29 +0000
commit678eff9c21376f148cb541f9e5a9070cd9016690 (patch)
treecf8caf07763252cbc740b274c9638da674840b17 /mail/qmail/Makefile
parent18e5af8e58f3396d09f7b9b9a4a09271db31b632 (diff)
downloadports-678eff9c21376f148cb541f9e5a9070cd9016690.tar.gz
ports-678eff9c21376f148cb541f9e5a9070cd9016690.zip
- Cleanup example rc file
- Support SHUTDOWN - Check for needed files/dependencies in precmd - Respect LOCALBASE - Make rclint happy - Rename symlink from qmail.sh to qmailsmtpd - Rename installed example rc file from qmail-smtpd.rcNG to qmailsmtpd
Notes
Notes: svn path=/head/; revision=312845
Diffstat (limited to 'mail/qmail/Makefile')
-rw-r--r--mail/qmail/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 8e124fb0de05..fa2efb84b9df 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmail
PORTVERSION?= ${QMAIL_VERSION}
-PORTREVISION?= 7
+PORTREVISION?= 8
CATEGORIES= mail
MASTER_SITES+= ${MASTER_SITE_QMAIL}
DISTNAME= ${PORTNAME}-${QMAIL_VERSION}
@@ -60,7 +60,7 @@ QMAILQUEUE_PATCH_DESC= Run a QMAILQUEUE program
QMQP_COMPRESS_DESC= QMQP on the fly compression
QMTPC_PATCH_DESC= Send email using qmtp protocol
QUOTATRASH_DESC= Include the Trash in the quota
-RCDLINK_DESC= Create rc.d/qmail.sh symlink
+RCDLINK_DESC= Create rc.d/qmail symlink
SENDERCHECK4_DESC= LOOSE checks exclusively for RELAY clients
SMTPAUTHUSER_DESC= Create env SMTPAUTHUSER containing authuser
SMTPEXECCHECK_DESC= Smtp DOS/Windows executable detection
@@ -289,6 +289,10 @@ PKGMESSAGE?= ${WRKDIR}/pkg-message-${PKGMESSAGE_SUFFIX}
SUB_FILES+= pkg-message
.endif
+.if !defined(SLAVE_LDAP)
+SUB_FILES+= qmailsmtpd
+.endif
+
WRKDIR_doc= ${WRKDIR}/doc
PORTDOCS= *
@@ -813,7 +817,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${i:T} ${PREFIX}/boot
.endfor
.if !defined(SLAVE_LDAP)
- ${INSTALL_SCRIPT} ${FILESDIR}/qmail-smtpd.rcNG ${PREFIX}/boot
+ ${INSTALL_SCRIPT} ${WRKDIR}/qmailsmtpd ${PREFIX}/boot
.endif
.for i in 1 5 7 8
@${MKDIR} ${PREFIX}/man/man$i