aboutsummaryrefslogtreecommitdiff
path: root/mail/qmail/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-06-27 02:33:04 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-06-27 02:33:04 +0000
commit92d8ac9962b4506fd38d32d9c90a7881c40ec270 (patch)
treec0cd5a22c8d473a90f8f4a9fa14a2fbf1cc35330 /mail/qmail/Makefile
parent31c3fd84f2b9fc13e06b5d049701030a8de7e407 (diff)
downloadports-92d8ac9962b4506fd38d32d9c90a7881c40ec270.tar.gz
ports-92d8ac9962b4506fd38d32d9c90a7881c40ec270.zip
mail/qmail-spamcontrol: Update to 2.7.31
TLSREMOTE, NEWLINE, and BIGTODO are now mandatory upstream and have been removed as options. MOREIPME was removed upstream. Changes: http://www.fehcom.de/qmail/spamcontrol/RELEASE_27.spamcontrol CHANGES (2.6 -> 2.7) -------------------- Userland: +) ucspi-ssl (> 0.8) mandatory. +) Added CRAM-MD5 support for qmail-remote. +) Added qmail-smtpam PAM for Recipients extension. +) Added sender-domain based TLS settings for qmail-remote. :) Changed qmail-remote's 'tlspeerhosts' to' tlsdestinations'. -) Removed moreip and notipme feature. :) REQUIREAUTH has been collapsed into SMTPAUTH with leading "!", :) SMTPAUTH has been enhanced to support: "!" Required; "-" Off. :) SMTPAUTH cram-md5 annoucement has to be prefixed with a '+': SMTPAUTH='+cram' (to allow future additional AUTH mechanisms). :) UCSPITLS has been enhanced to support: "!" Required "-" Off. +) Added logging for qmail-popup. +) Added CAPA support for qmail-popup/qmail-pop3d. :) Unified qmail-smtpd and qmail-popup logging. +) SPF and RBLSMTPD hook to display info in Received header. +) LOCALMFCHECK='=' requiring 'Mail From:' = 'TCPREMOTEINFO'. Internal: !) Bigtodo is default now. !) Maximum silent concurrency increased to 500. #) Aligend with recipients-0.7.2. #) Aligned with smtp-authentication 0.7.6. %) qmail-smtpd logging and reply messages 'off-shored'. ?) qmail-smtpd tls vulnerability VU#555316 fixed. ?) qmail-smtpd DNS lookup failures don't result in dropped connections anymore. %) qmail-remote evalutes in addition Alternative Subject for TLS host verification. %) Complete FreeBSD AMD64 support (conf-cc, conf-ld, conf-spamcontrol). #) Aligned with mav 0.20. +) Added partial clang support. ADDITIONAL CHANGES ------------------ +) Added SMTP Authentication based on smtproutes/destination. #) Aligned with SMTP Authentication 0.8.0. -) Removed obsolete SUBMISSION environment variable and special treatement. :) Enhanced badmailfrom with new qualifier '~' for extended addresses to filter mismatched domain names. +) Added *.3 man pages in setup (dirs were missing before). ;) SPF Hook working now.
Notes
Notes: svn path=/head/; revision=359437
Diffstat (limited to 'mail/qmail/Makefile')
-rw-r--r--mail/qmail/Makefile81
1 files changed, 28 insertions, 53 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index cf4d6f65b2cf..1bb61576c9ae 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -59,8 +59,6 @@ IGNOREVERISIGN_DESC= Disallow dns wildchar matches on gtlds
LDAP_DEBUG_DESC= Possibility to log and debug imap/pop
LOCALTIME_PATCH_DESC= Emit dates in the local timezone
MAILDIRQUOTA_PATCH_DESC= Maildir++ support
-MOREIPME_DESC= Add control files (more|not)ipme
-NEWLINE_DESC= Smtpd accept bare line feeds
OUTGOINGIP_PATCH_DESC= Set the IP address to send messages
PAM111421_DESC= Smtpd allow email in case PAM failure
QEXTRA_DESC= Enable QUEUE_EXTRA copy feature
@@ -79,7 +77,6 @@ SPF_PATCH_DESC= Implement SPF checker
SRS_DESC= Sender Rewriting Scheme support
TARPIT_PATCH_DESC= Implement TARPIT functions
TLS_DESC= SMTP TLS support
-TLSREMOTE_DESC= TLS support
TLS_DEBUG_DESC= Enable additional debug information
XF_QUITASAP_DESC= Close SMTP session ASAP (SMTPEXTFORK)
@@ -244,10 +241,10 @@ LDAP_PARAMS= ALTQUEUE BIGBROTHER BIGTODO BIND_8_COMPAT CLEARTEXTPASSWD \
QLDAP_CLUSTER QMQP_COMPRESS QUOTATRASH SMTPEXECCHECK
.elif defined(SLAVE_SPAMCONTROL)
-OPTIONS_DEFINE+=TLSREMOTE MOREIPME BIGTODO NEWLINE PAM111421 SMTPEXTFORK \
+OPTIONS_DEFINE+=PAM111421 SMTPEXTFORK \
XF_QUITASAP
-OPTIONS_DEFAULT+= TLSREMOTE PAM111421
+OPTIONS_DEFAULT+= PAM111421
.endif
OPTIONS_DEFINE+=QEXTRA
@@ -287,11 +284,12 @@ PKGMESSAGE_SUFFIX= mysql
.if defined(SLAVE_SPAMCONTROL)
EXTRA_MAN8= qmail-badloadertypes.8 qmail-badmimetypes.8 qmail-mfrules.8 \
- qmail-recipients.8
+ qmail-recipients.8 qmail-smtpam.8
ALL_TARGET+= ${EXTRA_MAN8}
MMAN8+= ${EXTRA_MAN8}
USES+= perl5
USE_PERL5= patch build
+CFLAGS+= -include /usr/include/errno.h
.endif
.if defined(SLAVE_LDAP)
@@ -358,14 +356,15 @@ DOCFILES_WRKDIR_doc+= FILES.spamcontrol HISTORY.spamcontrol \
INSTALL.spamcontrol LICENSE.spamcontrol \
LOGGING.spamcontrol PROPOSAL.mav README.bigtodo \
README.bouncemaxbytes README.clamav README.djbdns \
- README.doublebouncetrim README.mav README.moreipme \
+ README.mav \
README.qmailqueue README.recipients \
README.wildmat README_spamcontrol.html \
RELEASE_22.spamcontrol RELEASE_23.spamcontrol \
RELEASE_24.spamcontrol RELEASE_25.spamcontrol \
- RELEASE_26.spamcontrol SMTPREPLY.spamcontrol \
+ RELEASE_26.spamcontrol RELEASE_27.spamcontrol \
+ SMTPREPLY.spamcontrol \
TODO.spamcontrol badloadertypes badmailfrom \
- badmimetypes badrcptto
+ badmimetypes badrcptto smtpreplies
SCRIPTS+= qmail-alias2recipients qmail-pwd2recipients \
qmail-users2recipients qmail-vpopmail2recipients
.endif
@@ -390,8 +389,8 @@ NO_PREFIX_RMDIR=yes
.include <bsd.port.options.mk>
-# XXX Not needed with spamcontrol-2730
-.if ( ${ARCH} == "amd64" || ${ARCH} == "ia64" ) && !defined(SLAVE_LDAP)
+.if ( ${ARCH} == "amd64" || ${ARCH} == "ia64" ) && !defined(SLAVE_LDAP) \
+ && !defined(SLAVE_SPAMCONTROL)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-amd64
.endif
@@ -405,7 +404,7 @@ DOCSDIR= ${PREFIX}/doc
SUB_LIST+= MANPATH="@comment "
. if defined(SLAVE_LDAP)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-utmpx-ldap
-. else
+. elif !defined(SLAVE_SPAMCONTROL)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-utmpx
. endif
.else
@@ -474,7 +473,7 @@ PATCHFILES+= qmail-discard-double-bounces.patch:doublebounce
.if ${PORT_OPTIONS:MSPF_PATCH}
. if defined(SLAVE_TLS) || defined(SLAVE_SPAMCONTROL)
. if defined(SLAVE_SPAMCONTROL)
-SPF_SPAMCONTROL_PATCH= qmail-spf-rc5.patch-spamcontrol-26
+SPF_SPAMCONTROL_PATCH= qmail-spf-rc5.patch-spamcontrol-27
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:spf_spamcontrol/}
MASTER_SITE_SUBDIR+= garga/qmail/:spf_spamcontrol
DISTFILES+= ${SPF_SPAMCONTROL_PATCH}:spf_spamcontrol
@@ -582,8 +581,7 @@ PATCHFILES+= tarpit.patch:tarpit
.if ${PORT_OPTIONS:MSMTPEXTFORK} && \
( defined(SLAVE_SPAMCONTROL) || defined(SLAVE_LDAP) )
. if defined(SLAVE_SPAMCONTROL)
-SMTPEXTFORK_PATCH= smtpextfork-spamcontrol-2519.patch
-CFLAGS+= -Wno-return-type
+SMTPEXTFORK_PATCH= smtpextfork-spamcontrol-2731.patch
. else
SMTPEXTFORK_PATCH= smtpextfork-ldap-${LDAP_PATCH_DATE}_4.patch
. endif
@@ -630,16 +628,16 @@ PATCHFILES+= SMTPAUTHUSER.patch:smtpauthuser
.if defined(SLAVE_SPAMCONTROL)
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:ucspi_ssl/} \
- http://www.superscript.com/ucspi-ssl/:ucspi_ssl \
- http://dev.qmailrocks.org/downloads/qmailrocks_3.0-beta/:ucspi_ssl \
- ${MASTER_SITE_GENTOO:S/$/:ucspi_ssl/}
-MASTER_SITE_SUBDIR+= garga/ucspi-ssl/:ucspi_ssl
-DISTFILES+= ucspi-ssl-0.70.tar.gz:ucspi_ssl
-
-MASTER_SITES+= http://www.fehcom.de/qmail/spamcontrol/:ucspi_ssl_patch
-DISTFILES+= ucspi-ssl-0.70_ucspitls-0.6.patch_:ucspi_ssl_patch
+ http://www.fehcom.de/ipnet/ucspi-ssl/:ucspi_ssl
+MASTER_SITE_SUBDIR+= bdrewery/ucspi-ssl/:ucspi_ssl
+UCSPI_SSL_VER= 0.94
+UCSPI_SSL_DIST= ucspi-ssl-${UCSPI_SSL_VER}.tgz
+DISTFILES+= ${UCSPI_SSL_DIST}:ucspi_ssl
-UCSPISRC= ${WRKDIR}/host/superscript.com/net/ucspi-ssl-0.70
+UCSPISRC= ${WRKDIR}/host/superscript.com/net/ucspi-ssl-${UCSPI_SSL_VER}
+# XXX not yet, needs more cleanup
+#UCSPISRC!= ${MAKE} -C ${PORTSDIR}/sysutils/ucspi-ssl-tls -V WRKSRC
+#PATCH_DEPENDS+= ${UCSPISRC}/compile/ucspissl.a:${PORTSDIR}/sysutils/ucspi-ssl-tls:build
.endif
# Some default values, these can be modified by make command line
@@ -659,30 +657,6 @@ RCDLINK= \#
# Fill SELECTED_OPTIONS with options to write conf-spamcontrol
.if defined(SLAVE_SPAMCONTROL)
-. if ${PORT_OPTIONS:MTLSREMOTE}
-SELECTED_OPTIONS+= tlsremote=yes
-. else
-SELECTED_OPTIONS+= tlsremote=no
-. endif
-
-. if ${PORT_OPTIONS:MMOREIPME}
-SELECTED_OPTIONS+= moreipme=yes
-. else
-SELECTED_OPTIONS+= moreipme=no
-. endif
-
-. if ${PORT_OPTIONS:MBIGTODO}
-SELECTED_OPTIONS+= bigtodo=yes
-. else
-SELECTED_OPTIONS+= bigtodo=no
-. endif
-
-. if ${PORT_OPTIONS:MNEWLINE}
-SELECTED_OPTIONS+= newline=yes
-. else
-SELECTED_OPTIONS+= newline=no
-. endif
-
. if ${PORT_OPTIONS:MPAM111421}
SELECTED_OPTIONS+= pam111421=yes
. else
@@ -718,7 +692,7 @@ pre-everything::
post-extract:
.if defined(SLAVE_SPAMCONTROL)
@cd ${WRKSRC} && ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${SPAMCONTROL_DIST}
- @cd ${WRKDIR} && ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/ucspi-ssl-0.70.tar.gz
+ @cd ${WRKDIR} && ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${UCSPI_SSL_DIST}
.endif
# XXX - Move all the major patch applications to post-extract
@@ -748,13 +722,16 @@ post-patch:
-e "s,MYSQL_LIBS=.*,MYSQL_LIBS=\`${LOCALBASE}/bin/mysql_config --libs\`," \
${WRKSRC}/Makefile
.elif defined(SLAVE_SPAMCONTROL)
+. if ${OSVERSION} < 900007
+# Prevent applying utmpx patch
+ @${ECHO_CMD} > ${WRKSRC}/qbiff.c.patch
+. endif
@${ECHO_CMD} ${WRKDIR} > ${WRKSRC}/conf-qmail
@${ECHO_CMD} "# Generated by qmail-spamcontrol FreeBSD port" \
> ${WRKSRC}/conf-spamcontrol
. for option in ${SELECTED_OPTIONS}
@${ECHO_CMD} ${option} >> ${WRKSRC}/conf-spamcontrol
. endfor
- @cd ${UCSPISRC}/src && ${PATCH} -p0 < ${DISTDIR}/${DIST_SUBDIR}/ucspi-ssl-0.70_ucspitls-0.6.patch_
@${ECHO_CMD} "${UCSPISRC}/compile" > ${WRKSRC}/conf-ucspissl
${ECHO_CMD} "${CC} ${CFLAGS}" > ${UCSPISRC}/src/conf-cc
${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${UCSPISRC}/src/conf-ld
@@ -766,8 +743,6 @@ post-patch:
@cd ${UCSPISRC} && ${SETENV} ${MAKE_ENV} package/compile
@cd ${WRKSRC} && ./install_spamcontrol.sh
@${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-spamcontrol-qmail-smtpd.c
- @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-spamcontrol-qmail-remote.c
- @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-spamcontrol-tls_remote.c
. if ${PORT_OPTIONS:MSPF_PATCH} && defined(SPF_SPAMCONTROL_PATCH)
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SPF_SPAMCONTROL_PATCH}
. if ${PORT_OPTIONS:MEXTTODO_PATCH} && defined(EXTTODO_PATCH)
@@ -776,7 +751,6 @@ post-patch:
. endif
. if ${PORT_OPTIONS:MSMTPEXTFORK}
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SMTPEXTFORK_PATCH}
- @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-smtpextfork-qmail-smtpd.c
. if ${PORT_OPTIONS:MXF_QUITASAP}
@${REINPLACE_CMD} 's!//#define XF_QUITASAP!#define XF_QUITASAP!g' \
${WRKSRC}/qmail-smtpd.c
@@ -797,6 +771,7 @@ post-patch:
${WRKSRC}/Makefile
. if ${PORT_OPTIONS:MSMTPEXTFORK}
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SMTPEXTFORK_PATCH}
+# @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-smtpextfork-qmail-smtpd.c
. if ${PORT_OPTIONS:MXF_QUITASAP}
@${REINPLACE_CMD} 's!//#define XF_QUITASAP!#define XF_QUITASAP!g' \
${WRKSRC}/qmail-smtpd.c