aboutsummaryrefslogtreecommitdiff
path: root/mail/qmailadmin
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-06-15 13:48:32 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-06-15 13:48:32 +0000
commit62a24c0086c5fe3f9f8d91a6314832644d5a1b1e (patch)
treee968056609a5a76dc48a841ad4043762a99f8041 /mail/qmailadmin
parentb50b5fdd0e3c710296f81b62255b66a71095fd01 (diff)
downloadports-62a24c0086c5fe3f9f8d91a6314832644d5a1b1e.tar.gz
ports-62a24c0086c5fe3f9f8d91a6314832644d5a1b1e.zip
Use new options helpers
Notes
Notes: svn path=/head/; revision=320998
Diffstat (limited to 'mail/qmailadmin')
-rw-r--r--mail/qmailadmin/Makefile94
1 files changed, 31 insertions, 63 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index d0ae54c883ae..9b976f1d32cd 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -45,13 +45,43 @@ IDX_DESC= Use ezmlm-idx instead of ezmlm
IDX_SQL_DESC= Enable MySQL support for ezmlm
HELP_DESC= Show help links on login page
SPAM_DETECTION_DESC= Allow users to toggle spam checking
-SPAM_NEEDS_EMAIL_DESC= Append user's email to spam command
+SPAM_NEEDS_EMAIL_DESC= Append user's email to spam command #'
CATCHALL_DESC= Enable catch-all accounts
TRIVIAL_PASSWORD_DESC= Disallow password containing username
NOCACHE_DESC= Prohibit caching via http headers
+CONFIGURE_ARGS+= \
+ --enable-qmaildir=${QMAIL_PREFIX} \
+ --enable-htmldir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
+ --enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR}/images \
+ --enable-imageurl=${WEBDATAURL}/${WEBDATASUBDIR}/images \
+ --enable-htmllibdir=${DATADIR} \
+ --enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
+ --enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
+ --enable-vpopmaildir=${VPOPMAIL_DIR} \
+ --enable-autoresponder-path=${LOCALBASE}/bin \
+ --enable-maxusersperpage=${MAXUSERSPERPAGE} \
+ --enable-maxaliasesperpage=${MAXALIASESPERPAGE} \
+ --enable-ezmlmdir=${LOCALBASE}/bin
+
+IPAUTH_CONFIGURE_OFF= --disable-ipauth
+USER_INDEX_CONFIGURE_OFF= --disable-user-index
+MODIFY_QUOTA_CONFIGURE_OFF= --enable-modify-quota
+DOMAIN_AUTOFILL_CONFIGURE_ON= --enable-domain-autofill
+IDX_SQL_CONFIGURE_OFF= --disable-ezmlm-mysql
+HELP_CONFIGURE_ON= --enable-help
+CATCHALL_CONFIGURE_OFF= --disable-catchall
+TRIVIAL_PASSWORD_CONFIGURE_OFF= --disable-trivial-password
+NOCACHE_CONFIGURE_ON= --enable-no-cache
+SPAM_DETECTION_CONFIGURE_ON= --enable-modify-spam=y
+SPAM_NEEDS_EMAIL_CONFIGURE_ENABLE= spamcmd-needs-email
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MSPAM_DETECTION} && defined(SPAM_COMMAND)
+CONFIGURE_ARGS+= --enable-spam-command="${SPAM_COMMAND}"
+.endif
+
# vpopmail installation directory
#
# NB: change this with extreme caution! For instance, if vpopmail is not
@@ -97,66 +127,4 @@ BUILD_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
RUN_DEPENDS+= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
.endif
-CONFIGURE_ARGS+= \
- --enable-qmaildir=${QMAIL_PREFIX} \
- --enable-htmldir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR} \
- --enable-imagedir=${PREFIX}/${WEBDATADIR}/${WEBDATASUBDIR}/images \
- --enable-imageurl=${WEBDATAURL}/${WEBDATASUBDIR}/images \
- --enable-htmllibdir=${DATADIR} \
- --enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
- --enable-cgipath=${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
- --enable-vpopmaildir=${VPOPMAIL_DIR} \
- --enable-autoresponder-path=${LOCALBASE}/bin \
- --enable-maxusersperpage=${MAXUSERSPERPAGE} \
- --enable-maxaliasesperpage=${MAXALIASESPERPAGE} \
- --enable-ezmlmdir=${LOCALBASE}/bin
-
-.if empty(PORT_OPTIONS:MIPAUTH)
-CONFIGURE_ARGS+= --disable-ipauth
-.endif
-
-.if empty(PORT_OPTIONS:MUSER_INDEX)
-CONFIGURE_ARGS+= --disable-user-index
-.endif
-
-.if ${PORT_OPTIONS:MMODIFY_QUOTA}
-CONFIGURE_ARGS+= --enable-modify-quota
-.endif
-
-.if ${PORT_OPTIONS:MDOMAIN_AUTOFILL}
-CONFIGURE_ARGS+= --enable-domain-autofill
-.endif
-
-.if empty(PORT_OPTIONS:MIDX_SQL)
-CONFIGURE_ARGS+= --disable-ezmlm-mysql
-.endif
-
-.if ${PORT_OPTIONS:MHELP}
-CONFIGURE_ARGS+= --enable-help
-.endif
-
-.if ${PORT_OPTIONS:MSPAM_DETECTION}
-CONFIGURE_ARGS+= --enable-modify-spam=y
-.if defined(SPAM_COMMAND)
-CONFIGURE_ARGS+= --enable-spam-command="${SPAM_COMMAND}"
-.endif
-.if ${PORT_OPTIONS:MSPAM_NEEDS_EMAIL}
-CONFIGURE_ARGS+= --enable-spamcmd-needs-email
-.else
-CONFIGURE_ARGS+= --disable-spamcmd-needs-email
-.endif
-.endif
-
-.if empty(PORT_OPTIONS:MCATCHALL)
-CONFIGURE_ARGS+= --disable-catchall
-.endif
-
-.if empty(PORT_OPTIONS:MTRIVIAL_PASSWORD)
-CONFIGURE_ARGS+= --disable-trivial-password
-.endif
-
-.if ${PORT_OPTIONS:MNOCACHE}
-CONFIGURE_ARGS+= --enable-no-cache
-.endif
-
.include <bsd.port.mk>