aboutsummaryrefslogtreecommitdiff
path: root/mail/qmailadmin
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-04-24 13:07:34 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-04-24 13:07:34 +0000
commitae361266f4da8467de19f30b1db66c4a4196985d (patch)
treeaed1366fc53b397f77d1fb4010b2e232ab25e192 /mail/qmailadmin
parentff3d721d2b1848d0ae817dba2482b74921385206 (diff)
downloadports-ae361266f4da8467de19f30b1db66c4a4196985d.tar.gz
ports-ae361266f4da8467de19f30b1db66c4a4196985d.zip
- Fix ezmlm support by using subcommands of ezmlm-list
on the main database dir instead of subdirs [1]. This is reported upstream at: http://sourceforge.net/tracker/?func=detail&aid=3094082&group_id=6691&atid=306691 - Ignore the devel 1.2.16 version, it is not buildable - Mirror distfile - Convert tab to space in pkg-descr PR: ports/177389 [1] Submitted by: Tsunehiko Suzuki <tss-fbspr@e-ontap.com> [1]
Notes
Notes: svn path=/head/; revision=316429
Diffstat (limited to 'mail/qmailadmin')
-rw-r--r--mail/qmailadmin/Makefile7
-rw-r--r--mail/qmailadmin/files/patch-mailinglist.c33
-rw-r--r--mail/qmailadmin/pkg-descr2
3 files changed, 39 insertions, 3 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index df6af0a089a4..3677c45242a6 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -3,10 +3,11 @@
PORTNAME= qmailadmin
PORTVERSION= 1.2.15
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= mail www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION} \
+ http://mirror.shatow.net/freebsd/${PORTNAME}/
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= CGI program for administering Qmail with vchkpw/vpopmail
@@ -30,6 +31,8 @@ PATCH_SITES+= http://qmail.jms1.net/vpopmail/:onchange \
PATCHFILES+= qmailadmin-1.2.12-onchange.3.patch:onchange
PATCH_DIST_STRIP+= -p1
+PORTSCOUT= ignore:1.2.16
+
OPTIONS_DEFINE= IPAUTH USER_INDEX MODIFY_QUOTA DOMAIN_AUTOFILL \
IDX IDX_SQL HELP SPAM_DETECTION SPAM_NEEDS_EMAIL \
CATCHALL TRIVIAL_PASSWORD NOCACHE
diff --git a/mail/qmailadmin/files/patch-mailinglist.c b/mail/qmailadmin/files/patch-mailinglist.c
new file mode 100644
index 000000000000..d19c26d7bbca
--- /dev/null
+++ b/mail/qmailadmin/files/patch-mailinglist.c
@@ -0,0 +1,33 @@
+--- mailinglist.c~ 2009-03-09 10:35:01.000000000 +0900
++++ mailinglist.c 2013-03-25 23:48:29.000000000 +0900
+@@ -681,13 +681,15 @@
+ dup2(handles[1],fileno(stdout));
+ sprintf(TmpBuf1, "%s/ezmlm-list", EZMLMDIR);
+ if(mod == 1) {
+- sprintf(TmpBuf2, "%s/%s/mod", RealDir, ActionUser);
++ sprintf(TmpBuf2, "%s/%s", RealDir, ActionUser);
++ execl(TmpBuf1, "ezmlm-list", TmpBuf2, "mod", NULL);
+ } else if(mod == 2) {
+- sprintf(TmpBuf2, "%s/%s/digest", RealDir, ActionUser);
++ sprintf(TmpBuf2, "%s/%s", RealDir, ActionUser);
++ execl(TmpBuf1, "ezmlm-list", TmpBuf2, "digest", NULL);
+ } else {
+ sprintf(TmpBuf2, "%s/%s/", RealDir, ActionUser);
++ execl(TmpBuf1, "ezmlm-list", TmpBuf2, NULL);
+ }
+- execl(TmpBuf1, "ezmlm-list", TmpBuf2, NULL);
+ exit(127);
+ } else {
+ close(handles[1]);
+@@ -799,9 +801,9 @@
+ pid=fork();
+ if (pid==0) {
+ snprintf(subpath, sizeof(subpath), "%s/ezmlm-sub", EZMLMDIR);
+- snprintf(listpath, sizeof(listpath), "%s/%s/%s",
+- RealDir, ActionUser, dir);
+- execl(subpath, "ezmlm-sub", listpath, email, NULL);
++ snprintf(listpath, sizeof(listpath), "%s/%s",
++ RealDir, ActionUser);
++ execl(subpath, "ezmlm-sub", listpath, dir, email, NULL);
+ exit(127);
+ } else wait(&pid);
diff --git a/mail/qmailadmin/pkg-descr b/mail/qmailadmin/pkg-descr
index 5ff40bf2cab5..ab0ec02b8bcf 100644
--- a/mail/qmailadmin/pkg-descr
+++ b/mail/qmailadmin/pkg-descr
@@ -1,3 +1,3 @@
QmailAdmin is a cgi program for administering Qmail with vchkpw.
-WWW: http://www.inter7.com/qmailadmin/
+WWW: http://www.inter7.com/qmailadmin/