aboutsummaryrefslogtreecommitdiff
path: root/mail/qtools/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-07-13 15:05:20 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-07-13 15:05:20 +0000
commit1bbbb9b19f29f49e22757dbeddcf7681a7b6314b (patch)
tree2dd82ff5c542f79f904cf3adf13bb6b57bf5f99d /mail/qtools/Makefile
parent16b3a7d41064c8fea1c153781f8d039aa4f0089c (diff)
downloadports-1bbbb9b19f29f49e22757dbeddcf7681a7b6314b.tar.gz
ports-1bbbb9b19f29f49e22757dbeddcf7681a7b6314b.zip
The qtools package comprises several utilities for use with qmail,
typically as part of .qmail command processing. PR: 28662 Submitted by: Pete Fritchman <petef@databits.net>
Notes
Notes: svn path=/head/; revision=45106
Diffstat (limited to 'mail/qtools/Makefile')
-rw-r--r--mail/qtools/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/mail/qtools/Makefile b/mail/qtools/Makefile
new file mode 100644
index 000000000000..e19685c96fe7
--- /dev/null
+++ b/mail/qtools/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: qtools
+# Date created: 3 July 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtools
+PORTVERSION= 0.55
+CATEGORIES= mail
+MASTER_SITES= http://www.superscript.com/qtools/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+
+ALL_TARGET= it
+INSTALL_TARGET= setup check
+
+.if exists(${PREFIX}/qmail/bin/qmail-send)
+QMAIL_DIR?= ${PREFIX}/qmail
+.else
+QMAIL_DIR?= /var/qmail
+.endif
+
+NO_PACKAGE= A possibly inherited DJB-style license would prohibit \
+ distribution of modified binary packages
+
+post-patch:
+ @${ECHO} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO} "${CC} ${CFLAGS} ${STRIP}" > ${WRKSRC}/conf-ld
+ @${PERL} -pi -e 's!/usr/local!${PREFIX}!g' ${WRKSRC}/conf-home
+
+.include <bsd.port.mk>